ID do artigo: 315346 - Última revisão: terça-feira, 1 de maio de 2012 - Revisão: 5.0

Mensagem de erro ao tentar adicionar ou remover um programa em um computador que esteja executando o Windows XP ou Windows Server 2003: "O serviço Windows Installer não pôde ser acessado"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Se você for um cliente do Small Business, encontrar a solução de problemas e recursos de aprendizagem adicionais do Suporte para pequenas empresas (http://smallbusiness.support.microsoft.com) site.

Para continuar recebendo atualizações de segurança para Windows, verifique se que você estiver executando o Windows XP com Service Pack 3 (SP3). Para obter mais informações, consulte esta página da Web da Microsoft: O suporte está terminando para algumas versões do Windows (http://windows.microsoft.com/en-us/windows/help/end-support-windows-xp-sp2-windows-vista-without-service-packs)

Suporte para esse problema no Windows 7 e Windows Vista, consulte o seguinte artigo no site da Microsoft:

2642495 (http://support.microsoft.com/kb/2642495) Erro "O serviço Windows Installer não pôde ser acessado" no Windows 7 e Windows Vista

Este artigo destina-se a usuários avançados. Se você não estiver familiarizado com a solução de problemas avançada, convém solicitar a Ajuda de alguém ou contatar o suporte. Para obter mais informações sobre como contatar o suporte da Microsoft, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Quando você tenta instalar um aplicativo de software no Windows XP ou Windows Server 2003, você pode receber a seguinte mensagem de erro:
O serviço Windows Installer não pôde ser acessado. Isso pode ocorrer se você estiver executando o Windows no modo de segurança ou se o Windows Installer não está instalado corretamente. Contacte o suporte técnico para obter assistência.
Observação Esse problema também pode ocorrer quando você tenta desinstalar um aplicativo de software.

Causa

Esse problema pode ocorrer se uma das seguintes condições for verdadeiro:
  • São os arquivos do Windows Installer no disco rígido danificado ou faltando.
  • Instalar ou remover um programa que usa o Windows Arquivo de pacote de instalação de Software da Microsoft (MSI) do Installer (. msi). Para exemplo, isso pode ocorrer quando você tenta instalar o Microsoft Office em seu computador.

Resolução

Para resolver esse problema, use os seguintes métodos.

Método 1: Registrar novamente o Windows Installer

Para registrar novamente o Windows Installer, verifique se o local da Arquivo Msiexec. exe no disco rígido e no registro do Windows e, em seguida Registre novamente o Windows Installer. Para fazer isso, siga estas etapas.

Observação Porque existem várias versões do Microsoft Windows, o as etapas a seguir pode ser diferente no seu computador. Se estiverem, consulte a documentação do produto para concluir estas etapas.
  1. Determinar o local da Msiexec. exe arquivo no disco rígido disco. Para fazer isso, siga estas etapas:
    1. Clique em Início, clique em Executar, tipo %windir%\System32.e clique em OK.

      Observação Esta etapa será aberta a pasta onde o Msiexec. exe arquivo está localizado.
    2. Anote o local do Msiexec. exe arquivo. O local da Msiexec. exe arquivo será uma combinação do valor de Endereço caixa de texto e o Msiexec. exe nome do arquivo propriamente dito.

      Por exemplo se o Endereço caixa de texto contém um valor de C:\Windows\System32, o local da Msiexec. exe arquivo será C:\Windows\system32\Msiexec.exe.
  2. Importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Portanto, certifique-se de seguir estas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows


    Certifique-se de que o local do arquivo Msiexec. exe no Editor do registro está correto. Para fazer isso, siga estas etapas:
    1. Clique em Início, clique em Executar, tipo Regedit no Aberto caixa de texto e clique OK.
    2. Expandir HKEY_LOCAL_MACHINE, expanda SISTEMA, expanda CurrentControlSet, expanda Serviçose clique em MSIServer.
    3. No painel direito, clique com o botão direito ImagePathe clique em Modificar.
    4. No Dados do valor texto, digite o local do Msiexec. exe arquivo que você determinou na etapa 1, seguida pelo valor do /Ve clique em OK.

      Por exemplo, se o local da Msiexec. exe arquivo C:\Windows\system32\Msiexec.exe, digite o seguinte texto na Dados do valor caixa de texto:
      C:\WINDOWS\System32\msiexec.exe /V
    5. Clique em OK para fechar o Editar seqüência caixa de diálogo.
    6. Clique no Arquivo menu e clique Sair para fechar o Editor do registro.
  3. Inicie seu computador no modo de segurança e registre o Arquivo Msiexec. exe. Para fazer isso, siga estas etapas:
    1. Clique em Inícioe clique em Desligar o computador ou Desligar.
    2. Selecione o Reiniciar opção e clique em OK, ou clique em Reiniciar.
    3. Pressione a tecla F8 antes de aparece a tela inicial do Windows.
    4. Sobre o Opção avançada do Windows menu, use as teclas de seta para selecionar o Modo de segurança opção e pressione ENTER.
    5. Se você usar um computador de dupla inicialização ou inicialização múltipla, selecione o sistema operacional adequado na lista exibida e pressione ENTER.
    6. Faça logon no computador.
    7. Clique em Início, clique em Executar, tipo msiexec /regserver no Aberto caixa de texto e clique OK.

      Observação Para sistemas operacionais de 64 bits, você também precisa registrar novamente o instalador MSI de 64 bits. Para fazer isso, clique em Início, clique em Executar, tipo %windir%\Syswow64\Msiexec /regserver no Aberto caixa de texto e clique OK.

      Em edições de 64 bits do sistema operacional Windows, binários de 32 bits estão localizados em %systemroot%\SysWow64. pasta. Os binários de 64 bits estão localizados na %systemroot%\System32. pasta.
    8. Clique em Inícioe clique em Desligar o computador ou Desligar.
    9. Selecione o Reiniciar opção e clique em OK, ou clique em Reiniciar.
Se o problema persistir e você ainda receber a mensagem de erro mencionado na seção "Sintomas", siga as etapas no método 2.

Método 2: Reinstalar o Windows Installer

Para reinstalar o Windows Installer, renomeie o Windows danificado Arquivos do Installer e reinstalar o Windows Installer. Para fazer isso, siga estas etapas:
  1. Clique em Início, clique em Executar, tipo cmd no Aberto caixa de texto e clique OK.
  2. Tipo CD %windir%\system32, e pressione ENTER.
  3. Tipo attrib - r -s -h dllcache, e pressione ENTER.
  4. Tipo ren msi. dll msi.old, e pressione ENTER.
  5. Tipo ren Msiexec. exe msiexec.old, e pressione ENTER.
  6. Tipo ren Msihnd. dll msihnd.old, e pressione ENTER.
  7. Tipo sair, e pressione ENTER.
  8. No prompt de comando, digite sair, e pressione ENTER.
  9. Clique em Inícioe clique em Desligar o computador ou Desligar.
  10. Selecione o Reiniciar opção e clique em OK, ou clique em Reiniciar.
  11. Faça logon no computador.
  12. Baixe e instale a versão mais recente do Windows Installer. Para obter mais informações sobre como obter o Windows Installer, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    893803  (http://support.microsoft.com/kb/893803/ ) Windows Installer 3.1 v2 (3.1.4000.2435) está disponível
  13. Clique em Inícioe clique em Desligar o computador ou Desligar.
  14. Selecione o Reiniciar opção e clique em OK, ou clique em Reiniciar.

Mais Informações

O Windows Installer 4.0 não está disponível como um redistribuível para Windows Vista. O Windows Installer 4.0 está incluído com o sistema operacional Windows Vista.

Se os métodos descritos neste artigo não resolverem o problema descrito neste artigo, contate o Atendimento Microsoft para obter mais assistência.

Esse problema também ocorrerá se a propriedade de tipo de inicialização para o serviço Windows Installer estiver definida como um valor de desativar. Para verificar se o serviço Windows Installer está definido para um valor de desativar, execute estas etapas:
  1. Clique em Início, clique em Executar, tipo Services. msc no Aberto caixa de texto e clique OK.
  2. No Serviços (Local) lista, clique com botão direito O Windows Installere clique em Propriedades.
  3. Se o Tipo de inicialização na lista suspensa estiver definida como um valor de Desativar, selecione o Manual opção do Tipo de inicialização na lista suspensa e clique em OK.
  4. Clique no Arquivo menu e clique Sair.
Para obter mais informações sobre o Windows Installer visite o seguinte site da Microsoft Developer Network (MSDN):
http://msdn2.microsoft.com/en-us/library/aa370566.aspx (http://msdn2.microsoft.com/en-us/library/aa370566.aspx)
Para obter mais informações sobre como obter o mecanismo Windows Installer, clique no seguinte número de artigo para ler o artigo na Base de dados de Conhecimento da Microsoft:
292539  (http://support.microsoft.com/kb/292539/ ) Como obter o mecanismo Windows Installer

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
Palavras-chave: 
kbresolve kberrmsg kbprb kbmt KB315346 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 315346  (http://support.microsoft.com/kb/315346/en-us/ )