一部のデバイスで 1394 PC カードを使用したデバッグが初期化されない

文書翻訳 文書翻訳
文書番号: 315399 - 対象製品
この記事は、以前は次の ID で公開されていました: JP315399
すべて展開する | すべて折りたたむ

現象

1394 PC カードを使用してデバッグしようとしたときに、デバッグがオンにならない場合があります。

原因

この問題が発生するのは、ハードウェア アブストラクション レイヤ (HAL) による、CardBus バス初期化の待機時間が十分でないためです。また、電源がオンになった後にカードの初期化を待つ HAL の待機時間が十分でない場合もあります。この問題が発生すると、正しい Boot.ini ファイル スイッチを使用し、Kd1394.dll を読み込んでいる場合であっても、Windows は実際にデバッグ モードで起動しません。

デバッグ モードが使用されているかどうかは、次のサンプル コードを含むプログラムを作成することによって確認できます。
void main(void)  {
     _asm {  int 3 }
     return 0;
}
デバッグ モードが使用されている場合は、このコードを実行するとプログラムはハング (デバッガに介入) します。デバッグ モードが使用されていない場合は、ワトソン博士エラー メッセージが表示されます。

解決方法

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを受ける場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows XP Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/default.aspx?scid=fh;JA;CNTACTMS
: Microsoft Support Professional が、特定のアップデートを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定のアップデートの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。

修正プログラム (英語版) の属性は次のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。
   日付         時刻     バージョン        サイズ      ファイル名
   ------------------------------------------------------
   27-Jan-2002  17:56  5.1.2600.28  101,376  Hal.dll
   27-Jan-2002  17:56  5.1.2600.28  128,000  Halaacpi.dll
   27-Jan-2002  17:56  5.1.2600.28   77,440  Halacpi.dll
   27-Jan-2002  17:56  5.1.2600.28  146,432  Halapic.dll
   27-Jan-2002  17:56  5.1.2600.28  130,048  Halmacpi.dll
   27-Jan-2002  17:56  5.1.2600.28  148,352  Halmps.dll
   27-Jan-2002  17:56  5.1.2600.28   75,136  Halsp.dll

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。この問題は、Windows XP Service Pack 1 で修正済みです。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 315399 (最終更新日 2002-05-13) をもとに作成したものです。

この資料に含まれているサンプル コード/プログラムは英語版を前提に書かれたものをありのままに記述しており、日本語環境での動作は確認されておりません。

プロパティ

文書番号: 315399 - 最終更新日: 2006年3月24日 - リビジョン: 1.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kbhotfixserver kbbug kbfix kbwinxppresp1fix kbwinxpsp1fix KB315399
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com