MS01-052: Clients with an Expired Temporary License May Be Unable to Connect to Terminal Services

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Artikel ID: 315404 - Bekijk de producten waarop dit artikel van toepassing is.
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Symptomen

New Terminal Server clients, Terminal Services clients, or Remote Desktop Connection clients may connect to Terminal Services correctly, but some existing clients that could previously connect may be unable to connect. If an existing client cannot connect, the following error message may be displayed on the client computer:
Terminal Server has ended the connection
In all cases, clients can connect as if they were new clients if you delete the license from the client. For additional information about deleting licenses, click the article number below to view the article in the Microsoft Knowledge Base:
248430 How to Transfer Terminal Services CAL from One Computer to Another

Oorzaak

If a client's temporary license expires and the license server that is contacted by the Terminal Services server is not the issuer of the client's temporary license, the license server does not upgrade the license to a permanent license. This is most likely to occur because the original issuer of the temporary license cannot be contacted by the Terminal Services server. This may occur because the license server has been rebuilt or is currently unavailable.

Oplossing

To resolve this problem, either obtain the hotfix referenced in this section or Windows 2000 Security Rollup Package 1 (SRP1). For additional information about SRP1, click the article number below to view the article in the Microsoft Knowledge Base:
311401 Windows 2000 Security Rollup Package 1 (SRP1), January 2002
The fix for this issue is included in the following patch:
Microsoft Security Bulletin MS01-052
You can also use this patch as a replacement for the licensing enhancements that are documented in the following Microsoft Knowledge Base article:
287687 Terminal Services Licensing Enhancements

Status

Microsoft has confirmed that this problem could result in some degree of security vulnerability in Microsoft Windows 2000.

Meer informatie

The fix for this problem is server-side (on the license server). Because Terminal Services may potentially have a wide variety of clients that connect to it, it is not possible to list every affected client platform in this article. This may also affect clients running third-party operating systems or other Microsoft clients that may not be explicitly listed.

Eigenschappen

Artikel ID: 315404 - Laatste beoordeling: woensdag 15 december 2004 - Wijziging: 2.2
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows® 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 95
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 98 Tweede editie
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Trefwoorden: 
kberrmsg kbbug kbfix kbwin2000presp3fix kbsecurity KB315404

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