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"Server object error 'ASP 0178 : 80070005'" error message when you attempt to connect to a database results page created in FrontPage

Article ID:315454
Last Review:January 31, 2007
Revision:3.2
This article was previously published under Q315454

SYMPTOMS

When you attempt to browse to an Active Server Page (ASP) database results page created in Microsoft FrontPage, you may receive an error message similar to the following:
Server object error 'ASP 0178 : 80070005'

Server.CreateObject Access Error

/_fpclass/fpdbrgn1.inc, line 99

The call to Server.CreateObject failed while checking permissions. Access is denied to this object.

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CAUSE

This behavior can occur if incorrect NTFS permissions are defined for your "%ProgramFiles%\Common Files\System" folder.

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RESOLUTION

To resolve your issue, reset the NTFS permissions on the "%ProgramFiles%\Common Files\System" folder. To do this, follow these steps:
1.Open Windows Explorer. To do this, right-click Start and then click Explore on the shortcut menu.
2.In Folders view, expand the "%ProgramFiles%\Common Files\System" folder.
3.Right-click the folder and click Properties on the shortcut menu.
4.Click the Security tab.
5.Add Everyone to the existing permissions, give at least Read permissions to Everyone, and apply these new settings to all files and subfolders.
6.Click OK.

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MORE INFORMATION

For additional information how to troubleshoot ASP/IIS errors when you work with the database connectivity features of FrontPage, click the article numbers below to view the articles in the Microsoft Knowledge Base:
265161 (http://support.microsoft.com/kb/265161/EN-US/) FP: Errors Appear When You Attempt to Connect to Database Results Page
219170 (http://support.microsoft.com/kb/219170/EN-US/) FP2000: Error Browsing Database Results Pages After Publishing from Disk-Based Web
315453 (http://support.microsoft.com/kb/315453/EN-US/) FP: ASP Error 0177: 800401f3 When You Attempt to Connect to Database Results Page
315456 (http://support.microsoft.com/kb/315456/EN-US/) FP: Error: Unable to Open Jet Temporary Key When You Attempt to Connect to Database
For additional information how to troubleshoot IIS permissions, click the article numbers below to view the articles in the Microsoft Knowledge Base:
185874 (http://support.microsoft.com/kb/185874/EN-US/) How to Troubleshoot Permissions in Internet Information Server 4.0
309051 (http://support.microsoft.com/kb/309051/) How To Troubleshoot ASP in IIS 5.0

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APPLIES TO
Microsoft FrontPage 2002 Standard Edition
Microsoft FrontPage 2000 Standard Edition

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Keywords: 
kberrmsg kbopenfile kbasp kbprb KB315454

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