Games: Error message: Not a Valid Win32 Application

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Article ID: 315589 - View products that this article applies to.
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SYMPTOMS

When you start any of the Microsoft games listed in the "Applies To" section, you may experience one of the following symptoms:
  • You recieve the following error message:
    <game>.exe is Not a Valid Win32 Application.
  • A black command prompt box flashes on the screen.
  • When you run in a command prompt, you receive the following error message:
    Program too big to fit in memory.

CAUSE

This issue may occur if your game's installation is damaged (corrupted).

RESOLUTION

To resolve this issue, use the following methods in the order presented.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

Remove the game

Microsoft Windows XP

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. In the list of installed programs, click the game, and then click Add/Remove.
  4. When you are prompted to uninstall the program, click Yes.
  5. When the removal process is complete, click Start, point to Find, and then click Files or Folders.
  6. In the Named box, type "DungeonSiege.exe", "fs2002.exe", "train.exe", or "zoo.exe". Include the quotation marks.

    Note The name of the executable you type in will depend on what game you have installed. The executable names match the following games:
    Dungeon Siege = "DungeonSiege.exe"
    Flight Simulator 2002 = "fs2002.exe"
    Train Simulator = "train.exe"
    Zoo Tycoon = "zoo.exe"
  7. In the Look In box, click the hard disk where you installed the game, and then click Find Now.
  8. In the list of found files and folders, right-click the game executable file, and then click Delete.

Windows Vista

  1. Click Start
    Collapse this imageExpand this image
    the Start button
    , type programs and features in the Start Search box, and then click Programs and Features in the Programs list.
  2. In the list of programs installed, click the game, and then click Uninstall.
  3. When you are prompted to remove the program, click Yes.
  4. After the removal process is complete, click Start
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    the Start button
    , and then type the executable file name for the game that you removed in the Start Search box, and then click See all results.

    Note The name of the executable file that you type will depend on the game that you have installed. The executable file names match the following games:
    Dungeon Siege = "DungeonSiege.exe"
    Flight Simulator 2002 = "fs2002.exe"
    Train Simulator = "train.exe"
    Zoo Tycoon = "zoo.exe"
  5. In the list of found files and folders, right-click the game executable file, and then click Delete.
If you are prompted to confirm the deletion, click Yes or click Yes to all.

Empty the Temp folder

To empty the Temp folder and the Temporary Internet Files folder, use the Disk Cleanup tool. To do this, follow the steps for the operating system that you are using.

Windows XP

  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click Disk Cleanup.
  2. Click C: or click the drive where Windows XP is installed, and then click OK.
  3. Click to select the Temporary files check box.
  4. Click OK, and then click Yes to confirm the deletion.

Windows Vista

To resolve this issue, follow the steps in the appropriate section.

The computer is connected to the Internet

View the "Delete files using Disk Cleanup" topic on the following Windows Online Help and Support Web site:
http://windowshelp.microsoft.com/

The computer is not connected to the Internet

View the "Delete files using Disk Cleanup" topic in Windows Help and Support on the computer's hard disk by following these steps:
  1. Click Start, and then click Help and Support.
  2. In the Search Help box or in the Search online Help box, type Delete files using Disk Cleanup, and then click Search Help.
  3. In the list of topics, click Delete files using Disk Cleanup.
  4. Click the link that best describes the problem that you are experiencing.
  5. Follow the suggestions to troubleshoot the problem that you are experiencing.

Restart the computer by performing a clean boot procedure

To perform a clean boot procedure, follow the steps appropriate to your version of Microsoft Windows.

Windows Vista

To resolve this issue, follow the steps in the appropriate section.

The computer is connected to the Internet

View the "Run Selective Startup using System Configuration" topic on the following Windows Online Help and Support Web site:
http://windowshelp.microsoft.com/

The computer is not connected to the Internet

View the "Run Selective Startup using System Configuration" topic in Windows Help and Support on the computer's hard disk by following these steps:
  1. Click Start, and then click Help and Support.
  2. In the Search Help box or in the Search online Help box, type Run Selective Startup using System Configuration, and then click Search Help.
  3. In the list of topics, click Run Selective Startup using System Configuration.
  4. Click the link that best describes the problem that you are experiencing.
  5. Follow the suggestions to troubleshoot the problem that you are experiencing.

Windows XP

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
310353 How to perform a clean boot in Windows XP

Microsoft Windows Millennium Edition

  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Selective startup.
  3. Under Selective startup, click to clear all the check boxes.
  4. On the Startup tab, click to select the *StateMgr check box.
  5. Click OK. When you receive the message to restart the computer, click Yes.
  6. After the computer restarts, click Start, click Run, type msconfig in the Open box, and then click OK.
Important Look closely at the General tab to make sure that the check boxes that you cleared are still cleared. If none of the check boxes are selected, proceed to the following method. If you see a selected, unavailable check box (it appears dimmed and has a check mark in it), the computer is not truly "clean-booted," and you may have to contact the manufacturer of the program that is listed next to the selected, unavailable check box for assistance.

Microsoft Windows 98

  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click System Information.
  2. On the Tools menu, click System Configuration Utility.
  3. On the General tab, click Selective Startup, and then click to clear the following check boxes:
    • Process Config.sys file
    • Process Autoexec.bat file
    • Process Winstart.bat file (if available)
    • Process Win.ini file
    • Load Startup group items
  4. Click OK. When you are prompted to restart the computer, do so.
Note To restore your original Startup options, click Normal Startup on the General tab in the System Configuration Utility tool.

Reinstall the game

To reinstall the game, follow these steps:
  1. Insert the game CD into the computer's CD or DVD drive.

    If the Setup program does not start automatically, follow these steps:
    1. Click Start, click Run, type <cd-rom>:\setup.exe in the Open box. In this example, <cd-rom> is the letter of the computer's CD or DVD drive.
    2. Click OK.
  2. Follow the instructions that appear on the screen to install the game.

Properties

Article ID: 315589 - Last Review: November 14, 2007 - Revision: 5.3
APPLIES TO
  • Microsoft Bicycle Board Games 1.5
  • Microsoft Bicycle Card Games 1.0
  • Microsoft Dungeon Siege
  • Microsoft Flight Simulator 2004: Century of Flight
  • Microsoft Flight Simulator 2002 Standard Edition
  • Microsoft Flight Simulator 2002 Professional Edition
  • Microsoft eMbedded Visual C++ 4.0
  • Microsoft Zoo Tycoon 1.0
  • Microsoft Zoo Tycoon Complete Collection
  • Microsoft Zoo Tycoon: Dinosaur Digs 1.0
  • Microsoft Zoo Tycoon: Marine Mania
Keywords: 
kbsetup kberrmsg kbprb KB315589

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