Artigo: 315589 - Última revisão: quarta-feira, 14 de Novembro de 2007 - Revisão: 5.3

Jogos: Mensagem de erro: não uma aplicação Win32 válida

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando inicia um dos jogos Microsoft listados na secção "Aplica-se A", poderá detectar um dos seguintes sintomas:
  • Pode receber a seguinte mensagem de erro:
    .exe <game> não é uma aplicação de Win32 válida.
  • Uma caixa preta comandos ficar intermitente no ecrã.
  • Quando é executado num prompt de comando, receberá a seguinte mensagem de erro:
    Programa demasiado grande para caber na memória.

Causa

Este problema poderá ocorrer se instalação o jogo está danificada (danificado).

Resolução

Para resolver este problema, utilize os seguintes métodos pela ordem apresentada.

Nota Uma vez que existem várias versões do Microsoft Windows, os seguintes passos podem ser diferentes no computador. Se forem, consulte a documentação do produto para concluir estes passos.

Remover o jogo

Microsoft Windows XP

  1. Clique em Iniciar , aponte para definições e, em seguida, clique em Painel de controlo .
  2. Faça duplo clique em Adicionar/remover programas .
  3. Na lista de programas instalados, clique no jogo e, em seguida, clique em Adicionar/remover .
  4. Quando for pedido para desinstalar o programa, clique em Sim .
  5. Quando o processo de remoção estiver concluído, clique em Iniciar , aponte para Localizar e, em seguida, clique em ficheiros ou pastas .
  6. Na caixa com o nome , escreva "DungeonSiege.exe" , "fs2002.exe" , "train.exe" ou "zoo.exe" . Inclua as aspas.

    Nota O nome do executável que escreve no dependerá o jogo instalou. Os nomes executáveis correspondem aos jogos seguintes:
    Dungeon Siege = "DungeonSiege.exe"
    Flight Simulator 2002 = "fs2002.exe"
    Preparar Simulator = "train.exe"
    Zoo Tycoon = "zoo.exe"
  7. Na caixa Procurar em , clique no disco rígido onde instalou o jogo e, em seguida, clique em Localizar agora .
  8. Na lista de pastas e ficheiros encontrados, clique com o botão direito do rato no ficheiro executável jogo e, em seguida, clique em Eliminar .

Windows Vista

  1. Faça clique sobre
    Reduzir esta imagemExpandir esta imagem
    the Start button
    Iniciar , escreva programas e funcionalidades na caixa Iniciar procura e, em seguida, clique em programas e funcionalidades na lista programas .
  2. Na lista de programas instalados, clique no jogo e, em seguida, clique em desinstalar .
  3. Quando for pedido para remover o programa, clique em Sim .
  4. Depois do processo de remoção concluído, clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
    the Start button
    e escreva o nome de ficheiro executável para o jogo que removeu na caixa Iniciar procura e, em seguida, clique em Ver todos os resultados .

    Nota O nome do ficheiro executável que escrever depende do jogo que instalou. Os nomes de ficheiro executável correspondem aos jogos seguintes:
    Dungeon Siege = "DungeonSiege.exe"
    Flight Simulator 2002 = "fs2002.exe"
    Preparar Simulator = "train.exe"
    Zoo Tycoon = "zoo.exe"
  5. Na lista de pastas e ficheiros encontrados, clique com o botão direito do rato no ficheiro executável jogo e, em seguida, clique em Eliminar .
Se lhe for pedido para confirmar a eliminação, clique em Sim ou clique em Sim para tudo .

Esvaziar a pasta Temp

Para esvaziar a pasta Temp e a pasta Temporary Internet Files, utilize a ferramenta Limpeza do disco. Para o fazer, siga os passos para o sistema operativo que está a utilizar.

Windows XP

  1. Clique em Iniciar , aponte para programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique em Limpeza do disco .
  2. Clique em C: ou clique na unidade onde o Windows XP está instalado e, em seguida, clique em OK .
  3. Clique para seleccionar a caixa de verificação de ficheiros temporários .
  4. Clique em OK e, em seguida, clique em Sim para confirmar a eliminação.

Windows Vista

Para resolver este problema, siga os passos na secção apropriada.

O computador está ligado à Internet

Consulte o tópico "Eliminar ficheiros utilizando a limpeza do disco" no seguinte site de Web de suporte e ajuda online do Windows:
http://windowshelp.microsoft.com/ (http://windowshelp.microsoft.com/)

O computador não está ligado à Internet

Visualize o tópico "Eliminar ficheiros utilizando a limpeza do disco" na ajuda e suporte do Windows no disco rígido do computador seguindo estes passos:
  1. Clique em Iniciar e, em seguida, clique em Ajuda e suporte .
  2. Na caixa Procurar na ajuda ou na caixa de procura online ajuda , escreva Eliminar ficheiros utilizando a limpeza do disco e, em seguida, clique em Procurar na ajuda .
  3. Na lista de tópicos, clique em Eliminar ficheiros utilizando a limpeza do disco .
  4. Clique na hiperligação que melhor descreve o problema que está a ocorrer.
  5. Siga as sugestões para resolver o problema que está a ocorrer.

Reinicie o computador executando um procedimento de arranque limpo

Para efectuar um procedimento de arranque limpo, siga os passos adequados à sua versão do Microsoft Windows.

Windows Vista

Para resolver este problema, siga os passos na secção apropriada.

O computador está ligado à Internet

Consulte o tópico "Executar o arranque Selectivo utilizando a configuração do sistema" no seguinte site de Web de suporte e ajuda online do Windows:
http://windowshelp.microsoft.com/ (http://windowshelp.microsoft.com/)

O computador não está ligado à Internet

Visualize o tópico "Executar o arranque Selectivo utilizando a configuração do sistema" na ajuda e suporte do Windows no disco rígido do computador seguindo estes passos:
  1. Clique em Iniciar e, em seguida, clique em Ajuda e suporte .
  2. Na caixa Procurar na ajuda ou na caixa de procura online ajuda , escreva Executar arranque Selectivo utilizando a configuração do sistema e, em seguida, clique em Procurar na ajuda .
  3. Na lista de tópicos, clique em Executar arranque Selectivo utilizando a configuração do sistema .
  4. Clique na hiperligação que melhor descreve o problema que está a ocorrer.
  5. Siga as sugestões para resolver o problema que está a ocorrer.

Windows XP

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
310353  (http://support.microsoft.com/kb/310353/ ) Como efectuar um arranque limpo no Windows XP

Microsoft Windows Millennium Edition

  1. Clique em Iniciar , clique em Executar , escreva msconfig na caixa Abrir e, em seguida, clique em OK .
  2. No separador Geral , clique em arranque selectivo .
  3. Em arranque selectivo , clique para desmarcar todas as caixas de verificação.
  4. No separador arranque , clique para seleccionar o * StateMgr caixa de verificação.
  5. Clique em OK . Quando receber a mensagem para reiniciar o computador, clique em Sim .
  6. Depois de reiniciar o computador, clique em Iniciar , clique em Executar , escreva msconfig na caixa Abrir e, em seguida, clique em OK .
importante Observe atentamente o separador Geral para se certificar de que as caixas de verificação que desmarcou continuam desmarcadas. Se nenhuma das caixas de verificação estiver seleccionada, avance para o método seguinte. Se vir uma caixa de verificação seleccionada, não disponível (que aparece esbatido e tem uma marca de verificação), o computador não é realmente um "arranque limpo" e poderá ter de contactar o fabricante do programa que é listado junto da caixa de verificação seleccionada, indisponível para obter assistência.

Microsoft Windows 98

  1. Clique em Iniciar , aponte para programas , aponte para Acessórios , aponte para Ferramentas do sistema e, em seguida, clique em Informações de sistema .
  2. No menu Ferramentas , clique em Utilitário de configuração do sistema .
  3. No separador Geral , clique em Arranque selectivo (Selective Startup) e, em seguida, clique para desmarcar as seguintes caixas de verificação:
    • Processar ficheiro Config.sys
    • Processar o ficheiro Autoexec.bat
    • Processar ficheiro Winstart.bat (se disponível)
    • Processar ficheiro Win.ini
    • Carregar itens de grupo de arranque
  4. Clique em OK . Quando lhe for pedido para reiniciar o computador, fazê-lo.
Nota Para restaurar as opções de arranque originais, clique em Arranque Normal no separador Geral na ferramenta Utilitário de configuração do sistema.

Reinstalar o jogo

Para reinstalar o jogo, siga estes passos:
  1. Introduza o CD do jogo na unidade de CD ou DVD do computador.

    Se o programa de configuração não iniciar automaticamente, siga estes passos:
    1. Clique em Iniciar , clique em Executar , escreva < CD-ROM >: \setup.exe na caixa Abrir . Neste exemplo < CD ro m > é a letra da unidade de CD ou DVD do computador.
    2. Clique em OK .
  2. Siga as instruções que aparecem no ecrã para instalar o jogo.

A informação contida neste artigo aplica-se a:
  • Microsoft Bicycle Board Games 1.5
  • Microsoft Bicycle Card Games 1.0
  • Microsoft Dungeon Siege
  • Microsoft Flight Simulator 2004 Century of Flight
  • Microsoft Flight Simulator 2002 Standard Edition
  • Microsoft Flight Simulator 2002 Professional Edition
  • Microsoft eMbedded Visual C++ 4.0
  • Microsoft Zoo Tycoon 1.0
  • Microsoft Zoo Tycoon Complete Collection
  • Microsoft Zoo Tycoon: Dinosaur Digs 1.0
  • Microsoft Zoo Tycoon: Marine Mania
Palavras-chave: 
kbmt kbsetup kberrmsg kbprb KB315589 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 315589  (http://support.microsoft.com/kb/315589/en-us/ )