Internet Explorer kan ikke åpne Office-dokumenter fra et SSL-webområde

Artikkeloversettelser Artikkeloversettelser
Artikkel-ID: 316431 - Vis produkter som denne artikkelen gjelder for.
Vis alt | Skjul alt

På denne siden

Symptom

Når du forsøker å åpne eller laste ned et Microsoft Office-dokument (DOC-fil, XLS-fil, PPT-fil og så videre) fra et sikkert webområde i Internet Explorer, kan det hende du får en av følgende feilmeldinger, selv om dokumentet er tilgjengelig og lastet ned fra serveren:

Feilmelding 1

Internet Explorer kan ikke laste ned fil fra server.
Kan ikke åpne dette Internett-området. Det aktuelle området er enten utilgjengelig eller finnes ikke. Prøv på nytt senere.
Feilmelding 2

Siden kan ikke vises.
Siden du ser etter, er for øyeblikket ikke tilgjengelig. Web-området kan ha tekniske problemer, eller det kan være at du må justere leserinnstillingene.
Finner ikke server eller DNS-feil
Feilmelding 3

Kan ikke åpne filen..
Feilmelding 4

Finner ikke den angitte filen.
Problemet oppstår hvis serveren bruker SSL (Secure Sockets Layer), og har lagt til en av eller begge de følgende HTTP-hodene i svarmeldingen:
Pragma: no-cache
Cache-control: no-cache,max-age=0,must-revalidate
				

Årsak

Før Internet Explorer kan åpne dokumenter i Office (eller en prosessekstern ActiveX-dokumentserver), må Internet Explorer lagre filen i den lokale hurtigbufferkatalogen, og be det tilknyttede programmet laste inn filen ved hjelp av IPersistFile::Load. Hvis filen ikke er lagret på disk, mislykkes denne operasjonen.

Når Internet Explorer kommuniserer med et sikkert webområde via SSL, tvinger Internet Explorer frem eventuelle no-cache-forespørsler. Hvis hodet eller hodene finnes, hurtigbufrer ikke Internet Explorer filen. Følgelig kan ikke Office åpne filen.

Løsning

Webområder som ønsker å tillate slike operasjoner, bør fjerne no-cache-hodet eller -hodene.

Status

Dette er den ønskede virkemåten.

Mer informasjon

Filer som er tilknyttet selve Internet Explorer (blant annet TXT-filer, HTML-filer, GIF-filer, JPG-filer, XML-filer og så videre), har vanligvis ikke dette problemet. Det kan hende at filer som er tilknyttet programmer som ikke er Office-programmer, har dette problemet, men det avhenger av programmet.

Webutviklere bør notere seg at noen brannmurer og sikkerhetsprogrammer kan legge til disse hodene automatisk i alle utgående HTTP-svar. Selv om du ikke har konfigurert webserveren, ISAPI-utvidelsen (Internet Server Application Programming Interface) eller ASP-skriptet (Active Server Pages) til å returnere disse hodene, kan det hende området inkluderer dem som standard. Hør med den sikkerhetsansvarlige om dette er tilfelle, og diskuter sikkerhetsrisikoene for ditt firma hvis du velger å deaktivere dette alternativet for å tillate hurtigbufring for disse filene.

Fremgangsmåte for å gjenskape problemet

  1. Opprett en ny ASP-fil i Wwwroot-mappen for IIS-serveren. Gi filen navnet Testnocache.asp, og legg deretter til følgende kode i filen:
    <%
     'Response.ContentType = "application/msword"
     Response.AddHeader "Cache-control", "no-cache"
    %>
    <HTML><BODY>Test File Loaded in Microsoft Word</BODY></HTML>
    					
  2. Konfigurere IIS-serveren til å bruke SSL.
  3. Gå til ASP-filen som bruker HTTPS på et klientsystem der Word er installert:
    https://[servername]/testnocache.asp
    På noen systemer kan det hende du blir bedt om å åpne eller lagre filen. Uansett hvilket alternativ du velger (eller hvis du ikke blir bedt om å åpne eller lagre filen), får du en feilmelding, og du kan ikke åpne eller lagre filen.
  4. Fjern linjen AddHeader fra ASP-filen, og gå deretter til URL-adressen fra klienten. Dokumentet åpnes i Word.

Referanser

Hvis du vil ha mer informasjon, klikker du følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base (Denne artikkelen kan være på engelsk.):
248107 Opprette serversertifikater ved hjelp av webskjemaer for sertifikattjenester

Egenskaper

Artikkel-ID: 316431 - Forrige gjennomgang: 2. februar 2006 - Gjennomgang: 7.3
Informasjonen i denne artikkelen gjelder:
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0
Nøkkelord: 
kbprb KB316431

Gi tilbakemelding

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com