PRB: Обозревателю Internet Explorer не удается открыть документы Microsoft Office с защищенного веб-узла

Переводы статьи Переводы статьи
Код статьи: 316431 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

При попытке открыть или загрузить документ Microsoft Office (.doc, .xls, .ppt, и т. д.) с защищенного веб-узла в обозревателе Internet Explorer может появиться одно из следующих сообщений об ошибке, даже если документ доступен и загружается с сервера:
Не удается загрузить файл с сервера.

Не удается открыть этот узел Интернета. Узел недоступен или не найден. Повторите попытку позднее.
- или -
Не удается отобразить страницу.

Эта страница сейчас недоступна. Возможно, это вызвано техническими проблемами на веб-узле, или требуется изменение параметров обозревателя.

Не удается найти сервер или ошибка DNS
- или -
Приложению Office не удается открыть файл.
Неполадка возникает, если сервером используется протокол SSL (Secure Sockets Layer) и один или оба из следующих заголовков HTTP в ответном сообщении:
Pragma: no-cache
Cache-control: no-cache,max-age=0,must-revalidate
				

Причина

Чтобы открыть документы в обозревателе Internet Explorer приложением Office (или любым внепроцессным приложением, сервером ActiveX), необходимо в обозревателе Internet Explorer сохранить файл в любом каталоге локального кэша и с помощью соответствующего приложения загрузить файл, используя IPersistFile::Load. Если файл не сохранен на диске, эта операция невозможна.

При соединении обозревателя Internet Explorer с защищенным веб-узлом по протоколу SSL, обозревателем запрашивается несохранение в оперативной памяти. При наличии одного или обоих заголовков файл не сохраняется обозревателем Internet Explorer в оперативной памяти. Поэтому Office не может открыть файл.

Решение

С веб-страниц, разрешающих этот тип операции, необходимо удалить заголовки о несохранении в оперативной памяти.

Статус

Такое поведение является особенностью данного продукта.

Дополнительная информация

При работе с файлами, связанными с самим обозревателем Internet Explorer (в том числе с файлами .txt, .html, .gif, .jpg, .xml, и т.д.), такой неполадки обычно не наблюдается. Файлы, связанные с некоторыми приложениями, отличными от Office, могут вызывать эту неполадку.

Веб-разработчикам необходимо помнить, что при использовании некоторых брандмауэров и программ безопасности эти заголовки автоматически добавляются в исходящие ответы HTTP. Даже если возврат этих заголовков не задан в конфигурации веб-сервера, расширения ISAPI (Internet Server Application Programming Interface) или на страницах ASP, веб-узел может добавлять их по умолчанию. Обратитесь к администратору безопасности или брандмауэра и выясните, насколько опасно для организации отключение этого параметра с целью разрешить кэширование файлов.

Шаги для воспроизведения поведения

  1. На сервере ISS в папке Wwwroot создайте новый ASP-файл. Назовите файл Testnocache.asp и добавьте в него следующий код:
    <%
     Response.ContentType = "application/msword"
     Response.AddHeader "Cache-control", "no-cache"
    %>
    <HTML><BODY>Test File Loaded in Microsoft Word</BODY></HTML>
    					
  2. На сервере ISS настройте использование протокола SSL.
  3. На клиентском компьютере с установленной программой Word задайте путь к ASP-файлу по протоколу HTTPS:
    https://[servername]/testnocache.asp
    Может появиться запрос на открытие или сохранение файла. При любом выборе (или при отсутствии запроса) появляется сообщение об ошибке: «Не удается открыть или сохранить файл».
  4. Удалите строку AddHeader из ASP-файла и откройте URL-адрес с клиентского компьютера. Документ откроется в Word.

Ссылки

Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
248107 Создание серверных сертификатов с помощью веб-форм служб сертификатов

Свойства

Код статьи: 316431 - Последний отзыв: 15 февраля 2008 г. - Revision: 7.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0 на следующих платформах
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
Ключевые слова: 
kbprb KB316431

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com