The Removable Storage Service Hangs on Startup

Article translations Article translations
Article ID: 316500 - View products that this article applies to.
This article was previously published under Q316500
Expand all | Collapse all

SYMPTOMS

After you install Windows 2000, the following error message may be displayed in the System Event log:
Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7022
Description: The Removable Storage service hung on starting.
The %SystemRoot%\System32\NtmsData folder that is created by Removable Storage Manager (RSM) may not present on your computer. Additionally, one of the following registry keys (or one of its entries) may be missing or damaged:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NtmsSvc
Enum, Config, Parameters and Security keys.
HKEY_LOCAL_MACHINE\System\CCS\Control
Initialized key.

If you attempted to start the Removable Storage service manually, you may receive an error with code 1053.

CAUSE

The Removable Storage service may not have been completely installed during Windows 2000 Setup, or registry damage occurred since the last reboot.

RESOLUTION

To resolve this issue:
  1. Locate the %Systemroot%\INF\Rsm.inf file.
  2. Right-click the Rsm.inf file, and then click Install.
  3. Create an new, empty folder (named Ntmsdata) in the %Systemroot%\System32 folder, and then restart your computer.
If a system state backup is available, you can restore the system hive from backup, and not use the preceding manual steps:
235032 Problems with a Damaged Removable Storage Manager Database

MORE INFORMATION

After installing Removable Storage Manager by using the Rsm.inf file, the following registry keys are recreated:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NtmsSvc\Parameters
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NtmsSvc\Config
This installation process for RSM also registers the Ntmssvc.dll, Ntmsmgr.dll, and Ntmsevt.dll file on the next reboot when the RunOnce registry key is parsed.

Properties

Article ID: 316500 - Last Review: November 1, 2006 - Revision: 2.1
APPLIES TO
  • Microsoft Windows 2000 Server
Keywords: 
kbenv kbprb KB316500

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com