Zobrazí chybové hlásenie "Len správca" v systéme Windows XP, keď navštívite webová lokalita Windows Update alebo Microsoft Update

Preklady článku Preklady článku
ID článku: 316524 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Príznaky

Keď sa pokúsite navštíviť webová lokalita Windows Update alebo Microsoft Update, môže sa zobraziť chybové hlásenie podobné nasledovnému:
Číslo chyby: 0x8DDD0002

Chcete inštalovať položky z lokality Windows Update, musíte byť prihlásení ako správca alebo člen skupiny Administrators. Ak je počítač pripojený k sieti, vykonaniu tohto postupu môže tiež zabrániť nastavenie sieťovej politiky.
Zobrazí toto hlásenie, napriek tomu, že ste prihlásení ako správca alebo člen skupiny Administrators.

Poznámka: Ďalšie informácie o lokality Windows Update a Microsoft Update nájdete v časti "Ďalšie informácie".

Príčina

Toto správanie sa môže vyskytnúť niektorej z nasledujúcich príčin:
  1. Nie ste prihlásení ako používateľ patrí do tejto skupiny.
  2. Nemáte povolenie na kľúče orfolders v databáze registry.
  3. Operačný systém nemôže čítať údaje v priečinku the%Systemroot%\System32\Catroot2.

Riešenie

Dôležité upozornenie: Táto časť, postup alebo úloha obsahuje kroky, ktoré informujú o úpravách databázy Registry. Ak databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Postupujte preto presne podľa týchto krokov. Na dosiahnutie lepšej ochrany zálohujte databázu Registry pred úpravou. Potom môžete obnoviť databázu Registry, ak sa vyskytne problém. Ďalšie informácie o zálohovaní a obnovení databázy Registry získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
322756 Zálohovanie a obnovovanie databázy Registry v systéme Windows


Ak chcete vyriešiť tento problém, použite jeden z nasledujúcich postupov. Ak metóda 1 sa problém nevyrieši, použite metódu 2.
  • Metóda 1

    Skontrolujte, či ste prihlásení ako používateľ patrí do lokálnej skupiny Administrators. Chcete urobiť, kliknite na tlačidlo Štart, kliknite na položku spustiť, zadajte príkaznusrmgr.cpl, a kliknite na tlačidlo OK otvorte okno používateľské kontá .

    Ak sú súčasťou sieťového domény, postupujte nasledovne:
    1. V okne Používateľské kontá kliknutím vyberte konto v zozname a potom kliknite na položku Vlastnosti.
    2. Na karte Členstvo v skupine , aby ste overili skupiny Administrators.

    Ak nie ste členom sieťovej domény, vPoužívateľské kontáokno, kliknite na konto a potom skontrolujte, čiSprávca počítača zobrazí sa v časti názov konta.

    Keď ste sa prihlásili ako správca, skúste znova navštívte Windows Update webové stránky alebo webovej lokality Microsoft Update. Ak problemis vyriešený, nepokračujte, riešenia problémov.
  • Metóda 2

    Odstránenie dočasných internetových súborov. Ak to chcete urobiť, postupujte nasledovne:
    1. Otvorte okno Programu Internet Explorer kliknite na ponuku Nástrojea kliknite na položku Možnosti siete Internet.
    2. V okne Možnosti siete Internet kliknite na karte Všeobecné v časti dočasné internetové súbory, kliknite na položku Odstrániť súborya kliknite na tlačidlo OK.
    Skúste znova navštívte webová lokalita Windows Update alebo MicrosoftUpdate. Ak sa problém vyriešil, to nie je continuetroubleshooting.
  • Metóda 3

    Skontrolujte povolenia pre kľúče databázy registry, ktoré používa klienta Windows Update a Microsoft Update klienta.
    1. Kliknite na tlačidlo Štart, kliknite na položku spustiť, zadajte príkaz regedit, a kliknite na tlačidlo OK.
    2. Vyhľadajte a vyberte nasledujúci kľúč databázy registry:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
    3. V ponuke úpravy kliknite na položku povolenia, kliknite na tlačidlo pridaťa zadajte každý v dialógovom okne, ktoré sa zobrazí.
    4. Kliknite na tlačidlo Skontrolovať názvya potom kliknite na tlačidlo OK.
    5. Každý vyberte v zozname skupinu alebo používateľa názvy .
    6. Všetkých používateľov, kliknutím začiarknite políčko Úplný prístup v stĺpci Povoliť .

      Všimnite si, že čítanie v stĺpci Povoliť teraz aj políčko.
    7. Vyberte každý používateľ v poradí, v zozname skupinu alebo používateľa názvy a potom skontrolujte, či žiadne políčka v stĺpci zakázať . Kliknutím zrušte začiarknutie políčok v stĺpci zakázať vybraté.
    8. Kliknite na položku Rozšírenéa začiarknite políčka pre všetky podradené objekty nahradiť zobrazenými položkami , kliknite na tlačidlo OK.
    9. Ak sa zobrazí výzva na potvrdenie, a kliknite na tlačidlo OK zatvorte dialógové okno, kliknite na tlačidlo Áno .
    Skúste znova navštívte webová lokalita Windows Update alebo MicrosoftUpdate. Ak sa problém vyriešil, to nie je continuetroubleshooting.
  • Metóda 4

    Skontrolujte povolenia pre vás priečinok štruktúry používané ktorú klient služby Windows Update alebo Microsoft Update klienta.
    1. Kliknite na tlačidlo Štart, kliknite na položku spustiť, zadajte explorera kliknite na tlačidlo OK.
    2. Rozbaľte môj počítač, rozbaľteSystémová jednotka, a potom rozbaľte položku WINDOWS.
    3. Kliknite pravým tlačidlom myši na SoftwareDistributiona kliknite na položku Vlastnosti.
    4. V okne SoftwareDistribution vlastnosti kliknite na kartu zabezpečenie a potom overte, či sa v zozname skupinu alebo používateľa názvy .
    5. V zozname skupinu alebo používateľa , vyberte každý. Všetkých používateľov, kliknutím začiarknite políčko Úplný prístup v stĺpci Povoliť .

      Všimnite si, že čítanie v stĺpci Povoliť teraz aj políčko.
    Skúste znova navštívte webová lokalita Windows Update alebo MicrosoftUpdate. Ak sa problém vyriešil, to nie je continuetroubleshooting.
  • Metóda 5

    Premenujte priečinok Catroot2. Chcete urobiť, do príkazového riadka zadajte followingcommands stlačte kláves ENTER po každom riadku:
    net stop cryptsvc
    Ren %systemroot%\system32\catroot2 oldcatroot2
    net start cryptsvc
    Pokúste sa znova navštívte webová lokalita Windows Update alebo MicrosoftUpdate. Ak sa problém vyriešil, to nie je continuetroubleshooting.
  • Postup 6

    Premenovanie priečinka SoftwareDistribution.Postupujte podľa nasledujúcich krokov.
    1. Reštartujte počítač v núdzovom režime.
    2. Vyhľadajte a premenujte Jednotka: \Windows\SoftwareDistribution priečinok SoftwareDistribution.old.

      Poznámka: Jednotka je zástupný symbol pre systémovú jednotku.
    3. Reštartujte počítač v normálnom režime.

Ďalšie informácie

Musí byť lokálny správca, navštívte webová lokalita Windows Update alebo Microsoft Update. Po prihlásení ako správca non-sa nedá na webovej lokalite aj v prípade, že umožňuje spustiť program Internet Explorer spustiť z konta správcu. Tento problém sa vyskytuje, pretože iné systémové služby do procesu. Ďalšie informácie získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
326686 Zobrazí chybové hlásenia, keď správca systému zakáže Windows Update alebo Microsoft Update

Vlastnosti

ID článku: 316524 - Posledná kontrola: 24. júla 2014 - Revízia: 3.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows Update
  • Microsoft Update
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Kľúčové slová: 
kbwindowsupdatev6 kbenv kberrmsg kbprb ocsso kbmt KB316524 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok je preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft a možno ho opraviť prostredníctvom technológie Community Translation Framework (CTF). Microsoft ponúka strojovo preložené články, články upravené komunitou aj články preložené prekladateľmi, aby zabezpečil prístup ku všetkým článkom databázy Knowledge Base vo viacerých jazykoch. Strojovo preložené články aj upravené články môžu obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky. Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené neprávnym prekladom obsahu alebo jeho použitím zo strany našich zákazníkov. Ďalšie informácie o technológii CTF nájdete na lokalite http://support.microsoft.com/gp/machine-translation-corrections/sk.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 316524

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com