ID do artigo: 316731 - Última revisão: quarta-feira, 31 de janeiro de 2007 - Revisão: 5.3

Você pode receber "as macros neste projeto foram desabilitadas" mensagem de erro e uma assinatura de erro Vbe6.dll quando você tenta iniciar o Word 2002 ou Word 2003

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Para uma versão deste artigo do Microsoft Word 2000, consulte 316033  (http://support.microsoft.com/kb/316033/ ) .

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Quando você tenta iniciar o Microsoft Office Word 2003 ou Microsoft Word 2002, poderá receber uma mensagem de erro é semelhante a um destes procedimentos:
As macros neste projeto foram desabilitadas. Consulte a Ajuda on-line ou a documentação do aplicativo host para determinar como habilitar macros.
Microsoft Word encontrou um problema e precisa ser fechado. Desculpe pela inconveniência.
Observação Se você clicar no link Clique aqui na caixa de diálogo de mensagem de erro, a assinatura de erro refere-se a Vbe6.dll.

No Office XP Document Imaging, se você clicar em Enviar para o Microsoft Word , você receber uma das seguintes mensagens de erro
O servidor emitiu uma exceção.
uma mensagem de erro servidor DDE (Dynamic Data Exchange), como o seguinte:
Servidor DDE: Winword.exe - Erro de aplicativo

A instrução em "0x77f531f5" consultou a memória "0x000c0fc5" a memória não pôde ser "lida"

Causa

Esse comportamento pode ocorrer se qualquer uma das seguintes condições for verdadeira:
  • O modelo WinFax (da Symantec) está instalado no computador.
  • Norton AntiVirus versão 2000 ou 2001 está instalado no computador.
  • Um modelo no Microsoft Office ou na pasta Startup do Word está causando o erro.
  • O arquivo Vbe6.dll está corrompido.
  • Um modelo que contenha macros é de um local não confiável, como a pasta de inicialização do Office.

Resolução

Para resolver esse problema, use um ou mais dos seguintes métodos, conforme necessário.

Método 1: Instalar o Service Pack mais recente para sua versão do Office.

Para resolver esse problema, obtenha o service pack mais recente para sua versão do Office. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
307841  (http://support.microsoft.com/kb/307841/ ) Como obter o service pack mais recente do Office XP
870924  (http://support.microsoft.com/kb/870924/ )
Como obter o service pack mais recente para o Office 2003

Método 2: Remover o modelo WinFax

Remova Wfword2k.dot da pasta de inicialização do Office. Para fazer isso, siga estas etapas.

Observação Como existem várias versões do Microsoft Windows, as seguintes etapas podem ser diferentes no seu computador. Se estiverem, consulte a documentação do produto para concluir estas etapas.
  1. Clique em Iniciar , aponte para Pesquisar e, em seguida, clique em arquivos ou pastas .
  2. Em Procurar ficheiros ou pastas nomeados caixa, digite wfword2k.dot e em seguida clique em Pesquisar .
  3. Na caixa de diálogo Resultados da pesquisa , localize o arquivo Wfword2k.dot e arraste-o para a área de trabalho.
  4. Inicie o Word.
Para obter mais informações sobre como desativar o WinFax, visite o seguinte site da Symantec:
http://service4.symantec.com/SUPPORT/faxprod.nsf/docid/2000021017174504 (http://service4.symantec.com/SUPPORT/faxprod.nsf/docid/2000021017174504)

Método 3: Contato o fornecedor de software antivírus

Entre em contato com a Symantec Corporation para obter uma versão atualizada do seu produto ou contatá-los se você precisar de ajuda com a reconfiguração dos seus produtos para resolver esse problema.

Para obter mais informações sobre o plug-in do Norton AntiVirus Office, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
329820  (http://support.microsoft.com/kb/329820/ ) Como usar programas do Office com o plug-in do Norton AntiVirus Office

Método 4: Determinar se um modelo está causando o erro

Para determinar se um modelo ou suplemento está causando o problema, renomeie o modelo Normal.dot no Word e remover os itens de arranque do pastas.

Método 5: Substituir Vbe6.dll

Para substituir o arquivo Vbe6.dll, execute essas etapas.

Observação Como existem várias versões do Microsoft Windows, as seguintes etapas podem ser diferentes no seu computador. Se estiverem, consulte a documentação do produto para concluir estas etapas.
  1. Clique em Iniciar , aponte para Pesquisar e, em seguida, clique em arquivos ou pastas .
  2. Em Procurar ficheiros ou pastas nomeados digite Vbe6.dll e então clique em Localizar agora .
  3. Na caixa Resultados da pesquisa , clique com o botão direito do mouse em Vbe6.dll e, em seguida, clique em Renomear .
  4. Digite Vbe6.old , pressione ENTER e clique em Sim quando solicitado a confirmar a alteração da extensão. Feche a caixa de diálogo Resultados da pesquisa .
  5. Clique em Iniciar , aponte para configurações e, em seguida, clique em Painel de controle .
  6. Clique duas vezes em Adicionar ou remover programas .
  7. Na guia Instalar/desinstalar , clique em Microsoft Word ou Microsoft Office (dependendo de como você instalou o Word) e, em seguida, clique em Adicionar/remover .
  8. clique em Reparar e, em seguida, siga as instruções para corrigir erros no seu Office instalação.

    Esse procedimento irá instalar uma nova cópia do VBE6.dll.

Método 6: Verificar o nível de segurança

Se você recebeu a mensagem de erro que as macros foram desabilitadas, o nível de segurança de proteção contra vírus de macro pode ser definido como segurança alta. Para verificar o nível de segurança atual, execute estas etapas:
  1. No menu Ferramentas , aponte para macro e, em seguida, clique em segurança .
  2. Clique na guia Nível de segurança .
Se a opção alto é selecionada, use um dos seguintes métodos:
  • Adicione assinaturas digitais a suas macros.
  • Obter suplementos com uma assinatura digital.
  • Confie em suplementos todos instalados.
  • Altere o nível de proteção contra vírus de macro.
Para obter mais informações sobre esses métodos, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
285514  (http://support.microsoft.com/kb/285514/ ) Macros e suplementos não são executados quando segurança é definida como alta no PowerPoint 2003, no PowerPoint 2002, no Word 2003 e no Word 2002

Método 7: Mova o arquivo de suplemento para o caminho de inicialização do Word

Este é o local padrão para o caminho de inicialização do Word:

Observação Como existem várias versões do Microsoft Windows, as seguintes etapas podem ser diferentes no seu computador. Se estiverem, consulte a documentação do produto para concluir estas etapas.

Microsoft Windows 2000 ou Microsoft Windows XP:
<drive><unidade> \Documents and Settings\ usuário nome \Application Data\Microsoft\Word\STARTUP

Se você deseja verificar o caminho de inicialização do Word antes de mover o arquivo de add-in, verifique se o caminho seguindo estas etapas:
  1. No menu Ferramentas no Word, clique em Opções .
  2. Selecione a guia arquivos .
  3. Na lista de tipos de arquivo, selecione inicialização e, em seguida, clique em Modificar .
  4. Na caixa de diálogo Modificar local , clique na seta para baixo na caixa Examinar para ver o local completo da pasta.
  5. Clique em Cancelar na caixa de diálogo Modificar local .
  6. Clique em Fechar na caixa de diálogo Opções .
Depois que você souber o nome de arquivo e local do arquivo add-in, bem como o caminho de inicialização do Word, mova o arquivo de add-in de seu local atual para a pasta especificada no caminho de inicialização do Word.

Mais Informações

Se você continuar a receber essa mensagem de erro, há outras possíveis causas.

Para obter mais informações sobre outras causas de erros com base em Vbe6.dll, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
290935  (http://support.microsoft.com/kb/290935/ ) Receber mensagens de erro ao iniciar o Editor do Visual Basic do Word 2002
302596  (http://support.microsoft.com/kb/302596/ ) Mensagem de erro "Uma versão do Adobe Acrobat PDFMaker conhecida por causar instabilidades" ao iniciar um programa do Office com o suplemento Adobe PDFMaker instalado


A Microsoft fornece terceiros informações de contatos para ajudá-lo a encontrar suporte técnico. Essa informações de contatos podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações contatos de terceiros.

Para obter informações sobre como contatar Symantec Corporation, clique no número apropriado na lista a seguir para ler o artigo na Base de dados de Conhecimento da Microsoft:
65416  (http://support.microsoft.com/kb/65416/ ) Informações de contatos de fornecedor de hardware e software, da a K

60781  (http://support.microsoft.com/kb/60781/ ) Informações de contatos de fornecedores de hardware e software, L a P

60782  (http://support.microsoft.com/kb/60782/ ) Informações para contatos fornecedores de hardware e software de Q a Z
Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

A informação contida neste artigo aplica-se a:
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Office XP Document Imaging
Palavras-chave: 
kbmt kbcorrupt kbstartprogram kberrmsg kbofficexpsp2fix kbprb KB316731 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 316731  (http://support.microsoft.com/kb/316731/en-us/ )