クラスタ サービス アカウントのパスワードを変更すると Event ID 1107 および 1079 メッセージが発生する

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文書番号: 317232 - 対象製品
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現象

ドメイン コントローラでクラスタ サービス アカウントのパスワードを変更すると、2 番目のノードがクラスタに参加できなくなることがあります。システム イベント ログには、以下のいずれかのイベントが記録されます。
イベント ID : 1107
ソース : ClusSvc
説明 : クラスタ ノードxxxxxxxは、ネットワーク 'Public' 上でノードへの接続に失敗しました。 エラー コードは 5.
および
イベント ID : 1079
イベント ソース : ClusSvc
説明 : クラスタが、内部クラスタ通信のために構成されたネットワーク上のノード xxx と通信できないため、ノードはクラスタに参加できません。ノードとクラスタのネットワーク構成を確認してください。

原因

この問題は、クラスタ サービスを再起動しなかった場合に発生することがあります。クラスタ サービス アカウントまたはクラスタ サービスのパスワードを変更した後は、両方のノードでクラスタ サービスを停止させ、再起動する必要があります。

クラスタ サービスはすべての認証処理に NTLM を使用します。クラスタに参加しているノードでクラスタ サービスが開始されると、このノードの資格情報がドメイン コントローラによって検証されます。ノードの資格情報がドメインで検証されると、既存のクラスタに参加する処理が開始されます。このとき、ノードは資格情報を既存のノードに渡し、リモート プロシージャ コール (RPC) バインディングの作成を要求します。この処理のとき、既存のノードのローカル セキュリティ機関は、参加しようとしているノードの資格情報をドメイン コントローラに問い合わせて検証します。有効なノードであると検証された場合、ローカルのセキュリティ機関はドメイン コントローラから参加ノードのアクセス トークン (パスワード ハッシュ) を受け取ります。最後に、既存のノードのクラスタ サービスが資格情報を検証します。サービス アカウントは同じであるため、既存のノードのトークンと参加ノードのトークンが比較されます。参加ノードのサービス アカウントが検証され、次に、両方のトークンが一致した場合は参加が許可されます。ただし、既存のノードでクラスタ サービスを再起動しなかった場合、既存のノードは古いパスワードを使用して作成されたトークンを持ちつづけます。この場合は、トークンが一致せず、参加ノードのクラスタ サービスは "Error 5 (Access Denied)" というエラー メッセージを出力します。

認証プロセスはまず、パブリック ネットワークのインターフェイスで試みられます。認証に失敗した場合は、次にプライベート ネットワークのインターフェイスで試みられます。そのため、認証の失敗には 2 つのイベント ID 1107 メッセージが関連付けられます。

解決方法

この問題を解決するには、クラスタ サービス アカウントを変更するか、パスワードをリセットした後、両方のノードでクラスタ サービスを停止させて再起動します。

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。

詳細

マイクロソフトでは、クラスタ内のすべてのノードに対して同じサービス アカウントを使用することを推奨しています。サービス アカウントの変更方法、またはクラスタ サービス アカウントのパスワードのリセット方法については、Windows のオンライン ヘルプを参照してください。

サービス アカウントを変更する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
157780 How to Change the Service Account Password
157780 [XADM] サービス アカウントのパスワード変更方法
239885 INF: How To Change Service Accounts on a SQL Virtual Server

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 317232 (最終更新日 2002-02-19) をもとに作成したものです。

プロパティ

文書番号: 317232 - 最終更新日: 2003年1月31日 - リビジョン: 1.2
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT 4.0 Service Pack 3
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
  • Microsoft Windows NT 4.0 Service Pack 6
  • Microsoft Windows NT 4.0 Service Pack 6a
キーワード:?
kberrmsg kbenv kbprb KB317232
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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