El equipo deja de responder al reanudar desde el estado S3 en Windows XP

Seleccione idioma Seleccione idioma
Id. de artículo: 317272 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E317272
Expandir todo | Contraer todo

Síntomas

Al reanudar el funcionamiento de un equipo que tiene dos unidades IDE conectadas a un cable después del modo de suspensión, dicho equipo puede dejar de responder (se bloquea).

Causa

El controlador del disco IDE no comprueba el bit de ocupado en el estado de la unidad antes de restablecerla. Es un problema que aparece en equipos que usan el proceso S3 para el modo de suspensión. Estos equipos detienen la alimentación de la unidad en lugar de enviar un comando de inactividad a la unidad como hace el proceso de suspensión S2. Como consecuencia, las unidades se restablecen antes de que la negociación de la unidad haya finalizado cuando se reinician las unidades.

Las especificaciones para las unidades ATAPI requieren la comprobación del bit de ocupado antes de restablecer la unidad. Las especificaciones también indican que las unidades harán caso omiso de los restablecimientos hasta que las unidades se sincronicen y estén preparadas para funcionar después de la negociación. A partir de julio de 2002, algunas unidades no lo harán. Esto puede hacer que los equipos con dos unidades se inicien con las dos unidades programadas para ser maestras en el mismo cable. Si ocurre así, el equipo puede dejar de responder (se bloquea).

Solución

Ahora hay disponible en Microsoft una revisión admitida, pero sólo se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Puede que se hagan más pruebas de esta revisión. Por tanto, si no se ve muy afectado por este problema, Microsoft recomienda que espere al próximo Service Pack de Windows XP que contenga esta revisión.

Para resolver este problema inmediatamente, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtener la revisión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico de Microsoft, así como información acerca de los costos de soporte técnico, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;ES-ES;CNTACTMS
NOTA: en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas y temas de soporte técnico adicionales que no reúnan las condiciones necesarias para la actualización en cuestión.

La versión en inglés de esta revisión debe tener los atributos de archivo siguientes o posteriores:
 Fecha          Hora      Versión         Tamaño    Nombre de archivo
 ---------------------------------------------------------------------
 09-05-2002     16:10     5.1.2600.44     87.040    Atapi.sys

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información en este artículo se refiere a:" de este artículo.

Propiedades

Id. de artículo: 317272 - Última revisión: miércoles, 29 de marzo de 2006 - Versión: 2.3
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Palabras clave: 
kbqfe kbhotfixserver kbbug kbenv kbfix kbtool kbwinxppresp1fix kbwinxpsp1fix KB317272

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com