État d'ordinateur cesse répondre lorsque vous reprendre sur le site de S3 dans Windows XP

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Numéro d'article: 317272 - Voir les produits auxquels s'applique cet article
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Symptômes

Lorsque vous sortez votre ordinateur équipé de deux lecteurs IDE connectés à un câble de mise en veille, votre ordinateur peut cesser de répondre (se bloquer).

Cause

Ce problème se produit parce que le pilote de disque IDE ne vérifie pas le bit occupé dans l'état de lecteur avant elle réinitialise le lecteur. C'est un problème avec les ordinateurs qui utilisez veille S3 pour la mise en veille. Ces ordinateurs cesser de l'alimentation du lecteur au lieu d'émettre une commande de mise en veille sur le lecteur de la même manière que le processus de mise en veille S2. Ce comportement provoque les lecteurs à être réinitialisée avant la négociation lecteur lorsque les lecteurs redémarrez.

Spécifications d'atapi nécessitent vérification le bit occupé avant que le lecteur est réinitialisé. Les spécifications Précisez également que les lecteurs ignorera réinitialise jusqu'à ce que les lecteurs sont synchronisées et jusqu'à elles sont prêtes à fonctionner après la négociation. De juillet 2002, certains lecteurs ne le faites pas. Ce comportement peut provoquer des ordinateurs avec deux lecteurs pour démarrer avec deux lecteurs programmés pour être principal sur le même câble. Lorsque ce problème se produit, votre ordinateur peut cesser de répondre (se bloquer).

Résolution

Pour résoudre ce problème, procurez-vous le dernier service pack pour Windows XP. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322389 Comment faire pour obtenir le dernier Windows XP Service Pack
Microsoft propose un pilote ATAPI.sys qui attend que les lecteurs terminer la négociation avant que la commande de réinitialisation soit envoyée. Cette attente est contrôlée par l'entrée clée de Registre DWORD suivante :
HKey_Local_Machine\System\CurrentControlSet\Services\Atapi\Parameters\WaitOnBusyOnPowerUp
Le comportement par défaut de ce correctif est de Atapi.sys ne pas à attendre avant la commande de réinitialisation est émise. Ce problème se produit car le correctif logiciel est en place, mais la clé de Registre n'existe pas ou la valeur de la clé de Registre est définie sur 0.

Si vous rencontrez les symptômes qui sont décrits dans cet article, vous devez créer la clé de Registre et définissez la valeur sur 1. Lorsque vous effectuez cette opération, Atapi.sys d'attente avant l'envoi de commandes de réinitialisation au lecteur et empêche l'ordinateur de devenir qui ne répond pas.

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Informations de fichier

La version anglaise de ce correctif doit avoir les attributs de fichier suivants ou ceux d'une version ultérieure :
   Date         Time   Version      Size    File name
   --------------------------------------------------
   08-16-2002  10:31am 5.1.2600.55 87,168   Atapi.sys
				

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés au début de cet article. Ce problème a été corrigé dans Windows XP Service Pack 1. Ce correctif est inclu dans SP1. Lorsque ce correctif est installé par le Service Pack 1, le comportement par défaut reste inchangé et Atapi.sys envoie la commande de réinitialisation. Si votre ordinateur présente ces symptômes après avoir appliqué le Service Pack 1, vous devez créer la clé de Registre mentionnée dans la section « Résolution » de cet article et définissez la valeur sur 1 pour activer le délai.

Plus d'informations

Ce problème est matériel principalement liée et existe également dans Windows 2000. Pour plus d'informations sur votre ordinateur ne répond pas lorsque vous sortez d'état S3 dans Windows 2000, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
323153 L'ordinateur peut se bloquer pendant la reprise veille S3 avec deux lecteurs IDE

Propriétés

Numéro d'article: 317272 - Dernière mise à jour: vendredi 27 octobre 2006 - Version: 1.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
Mots-clés : 
kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbenv kbfix kboswin2000fix kbwinxpsp1fix KB317272 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 317272
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