Mensagem de erro quando um utilizador da página Web efectua uma procura no FrontPage: "HTTP/1.1 404 Object Not Found"

Traduções de Artigos Traduções de Artigos
Artigo: 317390 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando configurar o componente de procura do Microsoft FrontPage para utilizar o servidor de índice remissivo, o utilizadores da página Web receber a seguinte mensagem de erro quando clicam no botão Procurar na página Web:
HTTP/1.1 404 objecto não encontrado

Não é possível encontrar o /_vti_script/PAGENAME.html0.IDQ

Causa

Este comportamento ocorre se a definição para permitir o acesso a ficheiros de consulta de dados da Internet (.idq) está desactivada. Esta definição está desactivada, muitas vezes, por razões de segurança. Para activar esta definição ou desactivar, execute a Internet Information Services (IIS) Lockdown Wizard (Iislockd.exe).

Resolução

Para resolver este problema, utilize qualquer um dos seguintes métodos.

Método 1: Permitir aos utilizadores aceder a ficheiros .IDQ

Para inverter as alterações efectuadas pelo Assistente de bloqueio do IIS, execute novamente o assistente. Para o fazer, siga estes passos:
  1. Para obter o IIS Lockdown Wizard e obter mais informações, visite o seguinte Web site da Microsoft:
    http://www.microsoft.com/technet/security/tools/locktool.mspx
  2. Vá para a hiperligação na parte inferior da página, transfira o ficheiro Iislockd.exe e, em seguida, siga no ecrã instruções para anular as alterações efectuadas pelo assistente.

Método 2: Utilizar o motor de procura FreeWAIS para efectuar procuras

Se pretender manter o nível de segurança gerado pelo IIS Lockdown Wizard, pode configurar extensões de servidor para utilizar o motor de procura FreeWAIS (Wide área informações de serviço), que está incluído no FrontPage. Utilize o método adequado à sua situação.

Método 2a: procurar todas as Webs através de todas as raízes virtuais no servidor Web

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows
  1. Clique em Iniciar e, em seguida, clique em Executar .
  2. Na caixa Abrir , escreva regedit e, em seguida, clique em OK .
  3. Localize a seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\All portas
  4. Clique com o botão direito do rato em Todas as portas , aponte para Novo e, em seguida, clique em Valor da cadeia .
  5. Para o nome da cadeia, escreva noindexserver .
  6. Faça duplo clique sobre a cadeia.
  7. Na caixa Dados do valor , escreva 1 e, em seguida, clique em OK .
  8. Saia do Editor de registo.
  9. Recalcula as hiperligações para cada servidor virtual recriar os índices de texto. Para o fazer, siga estes passos:
    1. Inicie o FrontPage.
    2. Abra um Web site.
    3. No menu Ferramentas , clique em Recalcular hiperligações .

      Repita os passos b e c para cada Web site.

Método 2b: Procurar um Web site específico ou raiz virtual no servidor Web

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows
  1. Clique em Iniciar e, em seguida, clique em Executar .
  2. Na caixa Abrir , escreva regedit e, em seguida, clique em OK .
  3. Localize a seguinte subchave do registo
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\Ports\Port xx
    onde xx é o número instância para a raiz virtual. Para obter mais informações sobre como determinar o número de instância, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    197891Enumerar os nomes de Web sites do IIS utilizando o WSH
  4. Clique com o botão direito do rato em Todas as portas , aponte para Novo e, em seguida, clique em Valor da cadeia .
  5. Para o nome da cadeia, escreva noindexserver .
  6. Faça duplo clique sobre a cadeia.
  7. Na caixa Dados do valor , escreva 1 e, em seguida, clique em OK .
  8. Saia do Editor de registo.
  9. Recalcula as hiperligações para o servidor virtual recriar os índices de texto. Para o fazer, siga estes passos:
    1. Inicie o FrontPage.
    2. Abra o Web site que deseja recalcular.
    3. No menu Ferramentas , clique em Recalcular hiperligações .

Propriedades

Artigo: 317390 - Última revisão: 31 de janeiro de 2007 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Office FrontPage 2003
Palavras-chave: 
kbmt kbpermissions kbregistry kberrmsg kbprb KB317390 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 317390

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com