Mensagem de erro quando um usuário da página da Web executa uma pesquisa no FrontPage: "HTTP/1.1 404 objeto não encontrado"

Traduções deste artigo Traduções deste artigo
ID do artigo: 317390 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando você configura o componente de pesquisa do Microsoft FrontPage para usar o servidor de índice, os usuários da sua página da Web receber a seguinte mensagem de erro quando clicam no botão Pesquisar na sua página da Web:
HTTP/1.1 404 objeto não encontrado

/_vti_script/PAGENAME.html0.idq não pode ser encontrado

Causa

Esse comportamento ocorre se a configuração para permitir o acesso a arquivos de consulta de dados de Internet (.idq) estiver desativada. Essa configuração geralmente está desativada por motivos de segurança. Para ativar essa configuração ou desativar, execute a Internet Information Services (IIS) Lockdown Wizard (IISLockd.exe).

Resolução

Para resolver esse problema, use qualquer um dos seguintes métodos.

Método 1: Permitir que usuários tenham acesso a arquivos .idq

Para reverter as alterações feitas pelo Assistente de bloqueio do IIS, execute o assistente novamente. Para fazer isso, execute estas etapas:
  1. Para obter o IIS Lockdown Wizard e saber mais sobre ele, visite o seguinte site:
    http://www.microsoft.com/technet/security/tools/locktool.mspx
  2. Vá para o link na parte inferior da página, baixe o arquivo IISLockd.exe e, em seguida, siga na tela instruções para desfazer as alterações foram feitas pelo assistente.

Método 2: Usar o mecanismo de pesquisa FreeWAIS para realizar pesquisas

Se você preferir manter o nível de segurança gerado pelo Assistente de bloqueio do IIS, você pode configurar extensões de servidor para usar o mecanismo de pesquisa FreeWAIS (Wide Area serviço), que está incluído no FrontPage do FrontPage. Use o método apropriado para sua situação.

Método 2a: pesquisar todas as Webs em todas as raízes virtuais no servidor Web

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows
  1. Clique em Iniciar e, em seguida, clique em Executar .
  2. Na caixa Abrir , digite regedit e, em seguida, clique em OK .
  3. Localize a seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ferramentas compartilhadas\Extensões de servidor Web\Todas as portas
  4. Clique com o botão direito do mouse Todas as portas , aponte para novo e em Valor da seqüência .
  5. Para o nome da seqüência de caracteres, digite noindexserver .
  6. Clique duas vezes a seqüência de caracteres.
  7. Na caixa Dados do valor , digite 1 e, em seguida, clique em OK .
  8. Feche o Editor do Registro.
  9. Recalcule os hiperlinks para cada servidor virtual recriar os índices de texto. Para fazer isso, execute as seguintes etapas:
    1. Inicie o FrontPage.
    2. Abra um site.
    3. No menu Ferramentas , clique em Recalcular hiperlinks .

      Repita as etapas b e c para cada site.

Método 2b: pesquisar um site específico ou a raiz virtual no servidor Web

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows
  1. Clique em Iniciar e, em seguida, clique em Executar .
  2. Na caixa Abrir , digite regedit e, em seguida, clique em OK .
  3. Localize a seguinte subchave do registro
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ferramentas compartilhadas\Extensões Server Extensions\Ports\Port xx
    onde xx é o número de instância para a raiz virtual. Para obter mais informações sobre como determinar o número de instância, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    197891Enumerando os nomes dos sites do IIS usando o WSH
  4. Clique com o botão direito do mouse Todas as portas , aponte para novo e em Valor da seqüência .
  5. Para o nome da seqüência de caracteres, digite noindexserver .
  6. Clique duas vezes a seqüência de caracteres.
  7. Na caixa Dados do valor , digite 1 e, em seguida, clique em OK .
  8. Feche o Editor do Registro.
  9. Recalcule os hiperlinks para o servidor virtual recriar os índices de texto. Para fazer isso, execute as seguintes etapas:
    1. Inicie o FrontPage.
    2. Abra o site que você deseja recalcular.
    3. No menu Ferramentas , clique em Recalcular hiperlinks .

Propriedades

ID do artigo: 317390 - Última revisão: quarta-feira, 31 de janeiro de 2007 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Office FrontPage 2003
Palavras-chave: 
kbmt kbpermissions kbregistry kberrmsg kbprb KB317390 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 317390

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com