ID do artigo: 317780 - Última revisão: quarta-feira, 24 de fevereiro de 2010 - Revisão: 3.0

Trabalhos de impressão que são enviados para serviços de terminal impressoras redirecionadas podem ser impressos na impressora do cliente

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao tentar imprimir na impressora redirecionada, o trabalho de impressão pode imprimir na impressora local do usuário. Além disso, os trabalhos de impressão do outro usuário podem iniciar imediatamente a impressão na impressora local quando você faz logon em uma nova sessão de serviços de terminal.

Causa

Esse problema pode ser causado se o servidor está configurado incorretamente. Impressoras redirecionadas de serviços de terminal estão destinadas a ser criada pelo servidor quando o cliente fizer logon no e, em seguida, excluídas pelo servidor quando o cliente fizer logoff. Isso foi projetado para funcionar automaticamente.

Os drivers para impressoras redirecionadas são identificados por nome do driver e nome do driver mis-matches entre os drivers OEM no computador cliente e do Windows interno drivers no servidor de algumas vezes causar essa falha do processo automatizado. Quando esse processo falhar, impressora redirecionada do usuário não é criada, mas os serviços de terminal redirecionado porta de impressora para esse dispositivo ainda está disponível no Assistente para adicionar impressora. Alguns administradores tentam corrigir esse problema para o usuário instalar manualmente uma nova impressora local e, em seguida, configurando-o na porta de serviços de terminal redirecionada apontando para a impressora do cliente que essa sessão atual. Isso não é a maneira correta para resolver esse problema.

Resolução

A maneira correta de corrigir esse problema é descrita no seguinte artigo da Base de dados de Conhecimento da Microsoft:
239088  (http://support.microsoft.com/kb/239088/EN-US/ ) Windows 2000 Terminal Services Logs de eventos do servidor 1111, 1105 e 1106
O servidor deve ser configurado para que entende o processo automatizado para substituir os drivers do Windows internos no servidor para os drivers OEM no computador cliente.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo.

Mais Informações

Cenário de exemplo

O usuário A faz logon no Windows Terminal Server. Algum tempo depois, usuário B faz logon também. Ambos estão se conectando clientes que estejam executando o Microsoft Windows 98 com impressoras Hewlett Packard (HP) DeskJet 722 C. As impressoras não serão automaticamente redirecionadas porque os drivers HP OEM são nomeados "HP DeskJet 720 Series Printer", mas o driver do Windows interno para isso no servidor chamado "HP DeskJet 722 C" no arquivo Ntprint.inf. Essa incompatibilidade faz com que o redirecionamento automático para falhas e os logs de eventos IDs 1111, 1105 e 1106 no log de eventos do sistema no servidor de terminal.

Para tentar corrigir esse problema, um administrador tenta instalar novas impressoras locais e de usuário A usuário B no servidor. O administrador configura a impressora para o usuário A usar a porta TS001 e a impressora para o usuário B para usar a porta TS002 como essas são as portas que redirecionar para LPT do cliente ou portas de impressora do windows em suas sessões atuais.

O usuário A e B do usuário faça logoff e B logon do usuário novamente mais tarde algum tempo. Como os serviços de terminal portas de impressora redirecionado são reatribuídas e reutilizadas assim que ficam disponíveis, usuário B redirecionado porta de impressora do windows agora é TS001. No entanto, a impressora local no servidor criado pelo administrador para o usuário B ainda aponta para TS002 (onde o administrador especificamente configurado para imprimir). O usuário B tenta imprimir nessa impressora, mas os trabalhos de impressão apenas fila. Isso ocorre porque a porta que TS002 não está atualmente atribuído para qualquer cliente RDP e assim, não está disponível. Quando o usuário A faz back logon, sua porta de impressora redirecionado é atribuída ao TS002. Agora que a porta TS002 está disponível repentinamente, o Terminal Server será iniciado spool os trabalhos que o usuário que B tiver impressa em impressora local do usuário.

Para, desde que o usuário A e o usuário B permanecer conectados como este, todos os trabalhos que o usuário A imprime na impressora administrador instalado para que ele irá spool na impressora do usuário do B e trabalhos do usuário B serão efetuem spool de impressora do usuário.

Se por acaso usuário A e o usuário B recebem as mesmas portas de impressora redirecionada do Terminal Services originalmente tinha, será exibido o problema desaparecer por um curto período de tempo. Isso dificulta identificar e solucionar problemas e pode tornar o problema parece ocorrer aleatoriamente.

Em um ambiente com mais de dois usuários isso pode se tornar muito mais complexo. Todos os tipos de variações são possíveis, como A impressão em B, impressão de B para C, C ao imprimir A, ou A e B tanto impressão à impressora do B (supondo que B é realmente a impressão em uma impressora criada automaticamente e A está imprimindo a um administrador criou) e assim por diante.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Palavras-chave: 
kbmt kbprb kbprint kbui KB317780 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 317780  (http://support.microsoft.com/kb/317780/en-us/ )