PRB: Sending a Large Recordset Over a Slow Modem May Cause an Error Message on a Blue Screen

Article translations Article translations
Article ID: 317791 - View products that this article applies to.
This article was previously published under Q317791
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

If you send a large recordset over a very slow modem line from a computer that is running Microsoft Windows 95 or Microsoft Windows 98, you may receive the following error message on a blue screen:
An exception OE has occurred at 0028:C14C0CC5 VXD PPPMAC (01) + 000030B5 called from 0028C184EA2C in VXD PPPMAC (04) + 0000935C

CAUSE

The error message occurs because the modem connection is too slow and cannot support the packet size that Windows is using.

RESOLUTION

To resolve this issue, reduce the maximum packet size to a size that the connection can support. In Windows 95 or Windows 98, you can modify the default Maximum Transmission Unit (MTU) setting:
  1. Click Start, point to Settings, click Control Panel, and then double-click Network.
  2. On the Configuration tab, click Dial-Up Adapter, and then click Properties.
  3. On the Advanced tab, click IP Packet Size. In the Values box, click one of the following settings: The following list shows the values you can select in the Values box:
    Setting     Description
    -------------------------------------------------------------
    Automatic   Programmatic control; this is the default setting
    Large       1,500
    Medium      1,000
    Small       576
    						

STATUS

This behavior is by design.

MORE INFORMATION

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
183437 Description of the Internet Protocol Packet Size Setting

Properties

Article ID: 317791 - Last Review: February 27, 2014 - Revision: 1.2
APPLIES TO
  • Microsoft Visual Studio 6.0 Enterprise Edition
  • Microsoft Visual Studio 6.0 Service Pack 5
Keywords: 
kbnosurvey kbarchive kbprb KB317791

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com