SSDP Discover Service および Universal Plug and Play Device Host を無効にしても SSDP トラフィックが送信される

文書翻訳 文書翻訳
文書番号: 317843 - 対象製品
この記事は、以前は次の ID で公開されていました: JP317843
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

現象

Windows では以下のユニバーサル プラグ アンド プレイ サービスが使用されています。
  • SSDP (Simple Service Discovery Protocol) Discovery Service : ホーム ネットワーク上のユニバーサル プラグ アンド プレイ デバイスを検出するサービス
  • Universal Plug and Play Device Host : ユニバーサル プラグ アンド プレイ デバイスをホストするためのサポートを提供するサービス
SSDP Discovery Service と Universal Plug and Play Device Host の両方を無効にしても、一部の SSDP トラフィックが停止せず、UDP (User Datagram Protocol) ポート 1900 のトラフィックが、ファイアウォール ログまたはパケット フィルタリング デバイス ログに記録されます。このときトラフィックのトレースを採取すると、次の情報がパケットのデータ部に記録されます。
SSDP: Method = M-SEARCH
SSDP: Uniform Resource Identifier = *
SSDP: HTTP Protocol Version = HTTP/1.1
SSDP: Host = 239.255.255.250:1900
SSDP: Search Target = urn:schemas-upnp-org:device:InternetGatewayDevice:1
SSDP: Mandatory Extension = "ssdp:discover"
SSDP: Maximum Wait = 3

原因

この問題は、Windows Messenger によって、アップストリームのインターネット ゲートウェイ デバイスがあるかどうかの確認に SSDP 検出プロセスが使用されているために発生します。Windows Messenger では、この確認に組み込みのユニバーサル プラグ アンド プレイ サービスは使用されず、所定の形式で SSDP 検出メッセージが作成され、送信されます。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。
この問題を解決するには、レジストリの設定を変更して SSDP 検出メッセージを無効にします。
  1. レジストリ エディタ (Regedt32.exe) を起動します。
  2. レジストリの次のキーに移動し、クリックします。
    HKEY_LOCAL_MACHINE\Software\Microsoft\DirectPlayNATHelp\DPNHUPnP
  3. [編集] メニューの [新規] をポイントし、[DWORD 値] をクリックし、次のレジストリの値を追加します。
    値の名前 : UPnPMode
    種類 : REG_DWORD
    値のデータ : 2
  4. レジストリ エディタを終了します。
: UPnPMode を 2 に設定すると、ユニバーサル プラグ アンド プレイの NAT (Network Address Translation) トラバース検出は実行されないようになります。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 317843 (最終更新日 2003-09-19) を基に作成したものです。

プロパティ

文書番号: 317843 - 最終更新日: 2005年6月10日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kbprb KB317843
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com