Come utilizzare l'aggiornamento guidato Visual Basic

Traduzione articoli Traduzione articoli
Identificativo articolo: 317885 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo viene descritto come creare un semplice Applicazione Visual Basic 6.0 e quindi l'aggiornamento dell'applicazione Visual Basic .NET o Visual Basic 2005 tramite l'aggiornamento guidato Visual Basic in Visual Studio .net o in Visual Studio 2005.

Nota L'aggiornamento guidato Visual Basic .net Ŕ incluso in Visual Studio .net Professional.

NotaáL'aggiornamento guidato 2005 Visual Basic Ŕ stato migliorato rispetto alle versioni precedenti di Visual Basic.

Requisiti

Di seguito sono indicati l'hardware consigliato, software, infrastruttura di rete, competenze, conoscenze e i service pack Ŕ necessario:
  • Microsoft Windows 2000 Professional (o Server), o Microsoft Windows XP Professional (o Server) con il.NET Framework installato
  • Microsoft Visual Basic 6.0
  • Microsoft SQL Server 7.0 o versione successiva con Northwind database, le autorizzazioni appropriate e i valori di ID utente e Password
Conoscenza necessaria:
  • Conoscenza generale di come creare applicazioni utilizzando Visual Basic 6.0

Utilizzare l'aggiornamento guidato Visual Basic

La seguente procedura mostra come creare un semplice Visual Basic applicazione 6.0 e quindi l'aggiornamento dell'applicazione .net Visual Basic o Visual Basic 2005 utilizzando Visual Basic aggiornamento guidato di Visual Studio .net o di Visual Studio 2005:
  1. Nel menu Start , scegliere programmiMicrosoft Visual Studio 6.0e quindi fare clic su Microsoft 6.0 Visual Basic.
  2. Nella finestra di dialogo Nuovo progetto , fare clic su EXE Standarde quindi fare clic su Apri.
  3. Il primo modulo in questa applicazione utilizza ADO per recuperare un Recordset e visualizza l'oggetto recordset in un controllo Microsoft Hierarchical FlexGrid Controllo. Nel campo nome della finestra di dialogo proprietÓ di Form1, digitarefrmADO.
  4. Se la casella degli strumenti non Ŕ aperto, scegliere casella degli strumentidal menu Visualizza .
  5. Dalla casella degli strumenti, posizionare un MSHFlexGrid sul form in modo che occupi gran parte del modulo. Lasciare spazio sufficiente nella parte inferiore della maschera per inserire un pulsante.

    Nota: se non vedete l'icona MSHFlexGrid nella casella degli strumenti, Ŕ necessario aggiungerlo alla casella degli strumenti. Pulsante destro del mouse il Casella degli strumenti, quindi fare clic su componenti. Nella finestra di dialogo componenti selezionare Microsoft Hierarchical FlexGrid controllo 6.0 (OLEDB) dall'elenco dei componenti disponibili e quindi fare clic su OK.
  6. Dalla casella degli strumenti, posizionare un controllo CommandButton nel form sotto il MSHFlexGrid. Nel campo didascalia della finestra di dialogo proprietÓ , digitare OK.
  7. Il pulsante destro del mADOe quindi scegliere Visualizza codice. Aggiungere il codice seguente, che crea una connessione di database e Restituisce un recordset che contiene tutti i dati della tabella Products del database Northwind.

    Nota: nell'esempio di codice riportato di seguito, Ŕ necessario modificare id utente =<username></username> e password =<strong password=""></strong> per i valori corretti. Assicurarsi che l'ID utente dispone delle autorizzazioni appropriate per eseguire questa operazione sul database.
    Private Sub Command1_Click()
        Unload Me
    End Sub
    
    Private Sub Form_Load()
        Dim cn As Connection
        Set cn = New Connection
        cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"
        cn.Open
        
        Dim rs As Recordset
        Set rs = New Recordset
        rs.CursorLocation = adUseClient
        rs.Open "select * from products", cn
        
        Set MSHFlexGrid1.DataSource = rs
    End Sub
    					
  8. Premere CTRL + S per salvare il modulo. Dal menu File scegliere Salva con nome. Nella finestra di dialogo Salva con nome , fare clic su Salva.
  9. In Esplora progetti destro Progetto1, fare clic su Aggiungie quindi fare clic su modulo. Fare clic su Apri.
  10. Nel campo nome della finestra di dialogo proprietÓ , digitare frmClipboard.
  11. Dalla casella degli strumenti, posizionare un controllo Textbox sul form. Nel campo di testo , digitare La rapida pelide Achille l'ira cane.
  12. Inserire un controllo CommandButton di sotto della casella di testo. Nel campo didascalia della finestra di dialogo proprietÓ , digitare Copia.
  13. Inserire un secondo controllo CommandButton nel form. Nel campo didascalia della finestra di dialogo proprietÓ , digitare Incolla.
  14. Il pulsante destro del frmClipboarde quindi scegliere Visualizza codice. Incolla il seguente codice per il controllo CommandButton eventi click. Questo codice viene utilizzato negli Appunti l'oggetto GET e Incolla il testo:
    Private Sub Command1_Click()
        Clipboard.SetText Text1.SelText
    End Sub
    
    Private Sub Command2_Click()
        Text1.SelText = Clipboard.GetText
    End Sub
    					
  15. Premere CTRL + S per salvare il modulo.
  16. L'ultimo modulo che Ŕ necessario Ŕ il form principale dell'applicazione. In Esplora progetti destro Progetto1, scegliere Aggiungi, fare clic su moduloe quindi fare clic su Apri.
  17. Nel campo nome della finestra di dialogo proprietÓ , digitare frmMain.
  18. Dalla casella degli strumenti, inserire un controllo CommandButton nel form frmMain. Nel campo didascalia della finestra di dialogo proprietÓ , digitare ADO.
  19. Inserire un secondo controllo CommandButton nel form. Nel campo didascalia della finestra di dialogo proprietÓ , digitare Appunti.
  20. Destro frmMaine quindi scegliere Visualizza codice. Incolla il seguente codice per il controllo CommandButton, eventi, fare clic per Mostra le due forme:
    Private Sub Command1_Click()
        frmADO.Show
    End Sub
    
    Private Sub Command2_Click()
        frmClipboard.Show
    End Sub
    					
  21. Premere CTRL + S per salvare il modulo.
  22. In Esplora soluzioni, destro Progetto1e quindi scegliere ProprietÓ Progetto1. Nel campo Oggetto di avvio , fare clic su frmMaine quindi fare clic su OK.
  23. Per aggiungere un riferimento al componente di ADO, dal menu progetto , fare clic su riferimenti. Nell'elenco dei riferimenti disponibili, fare clic per selezionare Libreria di oggetti dati Microsoft ActiveX (esegue qualsiasi versione 2.0 o versione successiva). Fare clic su OK.
  24. Per compilare il progetto dal menu File , fare clic su Progetto1 apportare. Fare clic su OK nella finestra di dialogo Crea progetto (accettare il nome file predefinito).
  25. Premere F5 per eseguire l'applicazione in modalitÓ debug.

    Nota: non Ŕ necessario verificare che il precedente Visual Basic applicazione viene eseguita senza problemi prima dell'aggiornamento.
  26. Chiudere l'ambiente di sviluppo Visual Basic. Al Chiedi conferma prima di salvare le modifiche apportate al progetto, fare clic su . Utilizzare il nome predefinito e salvare il progetto.
  27. Nel menu Start , scegliere programmiMicrosoft Visual Studio.NETe quindi fare clic su Microsoft Visual Studio.NET.
  28. Nella pagina iniziale, fare clic su Apri progetto. Individuare la cartella che contiene il progetto 6.0 Visual Basic file che avete appena creato (generalmente C:\Program Files\Microsoft Visual Studio\VB98). Fare clic su Project1.vdpe quindi fare clic su Apri.
  29. Visual Studio .net rileva che si tratta di un elemento visivo legacy Progetto di base e viene avviato l'aggiornamento guidato Visual Basic. La procedura guidata visualizza una Descrizione di ogni passaggio come si procede attraverso la procedura di seguito sequenza:
    • Creare un nuovo progetto di in cui il progetto esistente viene aggiornato.
    • Copiare i file di modulo e classe nella nuova progetto.
    • Fornire un rapporto di aggiornamento che elenca i componenti di il progetto aggiornato correttamente e i componenti che non esegue l'aggiornamento completata.

  30. Fare clic su Avanti attraverso i passaggi fino a quando non inizia il processo di aggiornamento. Il aggiornamento richiederÓ circa 30-60 secondi per il completamento.
  31. In Esplora soluzioni, fare doppio clic su UpgradeReport. htm. Questo report vengono visualizzati i risultati dell'aggiornamento. Si noti che tutti i i moduli, ad eccezione di frmClipboard aggiornato senza problemi.
  32. Espandere frmClipboard.vb per visualizzare i problemi. Clipboard.SetText e GetText non sono stati aggiornati correttamente. Fare clic sui collegamenti nella Descrizione per visualizzare la procedura correggere i problemi.
  33. In Esplora soluzioni, si noti che tutti i moduli conservati i nomi originali, ma l'estensione del file viene modificato da frm a . vb.
  34. Espandere i riferimenti. Si noti che i riferimenti a tutti i componenti necessari Per utilizzare i componenti legacy Visual Basic e ADO sono stati aggiunti automaticamente.
  35. Pulsante destro del mouse una delle forme e quindi scegliere Visualizza codice. Espandere l'area di Supporto per l'aggiornamento . Questa area Visualizza come configurata Visual Studio .net o Visual Studio 2005 diverse proprietÓ e variabili per supportare il codice aggiornato.
  36. In Esplora soluzioni, fare frmClipboard.vbe quindi scegliere Visualizza codice. Si noti che esistono commenti inseriti prima le righe che non aveva non eseguire l'aggiornamento.
  37. Modificare gli eventi Command1_Click e Command2_Click come segue:
    Private Sub Command1_Click(ByVal eventSender As System.Object, _
        ByVal eventArgs As System.EventArgs) Handles Command1.Click
            Clipboard.SetDataObject(Text1.Text)
        End Sub
    
        Private Sub Command2_Click(ByVal eventSender As System.Object, _
        ByVal eventArgs As System.EventArgs) Handles Command2.Click
            Text1.SelectedText = _
                Clipboard.GetDataObject().GetData(GetType(System.String))
        End Sub
    					

Esempi di codice completo

Elenco completo del codice (frmADO.frm)

Private Sub Command1_Click()
    Unload Me
End Sub

Private Sub Form_Load()
    Dim cn As Connection
    Set cn = New Connection
    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"
    cn.Open
    
    Dim rs As Recordset
    Set rs = New Recordset
    rs.CursorLocation = adUseClient
    rs.Open "select * from products", cn
    
    Set MSHFlexGrid1.DataSource = rs
End Sub
				

Elenco completo del codice (frmClipboard.frm)

Private Sub Command1_Click()
    Clipboard.SetText Text1.SelText
End Sub

Private Sub Command2_Click()
    Text1.SelText = Clipboard.GetText
End Sub

Complete Code Listing (frmMain.frm)
Private Sub Command1_Click()
    frmADO.Show
End Sub

Private Sub Command2_Click()
    frmClipboard.Show
End Sub
				

Verificare che l'applicazione funzioni

  1. Premere F5 per avviare l'applicazione.
  2. Alla richiesta di salvare il progetto, fare clic su OK.
  3. In Form1, fare clic su ADO. Viene visualizzato un modulo che contiene i dati in una griglia. Chiudere questa modulo.
  4. In Form1, fare clic su Appunti.
  5. Fare clic su Copia.
  6. Posizionare il cursore nella casella di testo all'inizio il testo, quindi scegliere Incolla. VerrÓ visualizzato il testo incollato.

Risoluzione dei problemi

Visual Basic .net Ŕ un cambiamento importante rispetto alle versioni precedenti di Visual Basic. Per molti progetti, Ŕ consigliabile un lavoro di preparazione approfondita prima dell'aggiornamento. Consultare il documento seguente per le informazioni che possono consentono di eseguire pi¨ facilmente l'aggiornamento:
Aspetti da considerare prima dell'aggiornamento

RIFERIMENTI

Per ulteriori informazioni, consultare il seguente Microsoft Developer Articoli Network (MSDN):
Preparazione delle applicazioni Visual Basic 6.0 per l'aggiornamento a Visual Basic.NET

Aggiornamento di applicazioni create in versioni precedenti di Visual Basic

ProprietÓ

Identificativo articolo: 317885 - Ultima modifica: lunedý 2 luglio 2012 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Visual Basic 2005
  • Microsoft Visual Basic .NET 2003 Standard Edition
  • Microsoft Visual Basic .NET 2002 Standard Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft .NET Framework 1.1
Chiavi:á
kbvs2005swept kbvs2005applies kbmigration kbhowtomaster kbmt KB317885 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 317885
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com