Visual Basic 업그레이드 마법사를 사용 하는 방법

기술 자료 번역 기술 자료 번역
기술 자료: 317885 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

요약

이 문서에서는 간단 하 고 만드는 방법을 설명 합니다. Visual Basic 6.0 응용 프로그램 및 응용 프로그램에 Visual Basic 다음 업그레이드 .NET 또는.net Visual Studio 또는 Visual Studio 2005 Visual Basic 업그레이드 마법사를 사용 하 여 Visual Basic 2005.

참고 Visual Basic.net 업그레이드 마법사는 Visual에 포함 되어 Studio.net Professional입니다.

참고?Visual Basic 2005 업그레이드 마법사 Visual Basic 이전 버전에서 향상 되었습니다.

요구 사항

다음은 권장된 하드웨어, 소프트웨어 설명, 네트워크 인프라, 기술, 지식 및 서비스 팩이 필요 합니다.
  • Microsoft Windows 2000 Professional (또는 Server) 또는 .NET Framework Microsoft Windows XP Professional (또는 Server) 설치
  • Microsoft Visual Basic 6.0
  • Microsoft SQL Server 7.0 이상에서 Northwind 데이터베이스, 적절 한 사용 권한 및 UserID 및 암호 값
필요한 사전 지식:
  • 일반적인 지식을 사용 하 여 응용 프로그램을 만드는 방법 Visual Basic 6.0

Visual Basic 업그레이드 마법사를 사용 합니다.

다음 단계에서는 간단한 Visual Basic 만드는 방법을 보여 줍니다. 6.0 응용 프로그램 및 다음 업그레이드를 사용 하 여 응용 프로그램에.net Visual Basic 또는 Visual Basic 2005 Visual Basic 업그레이드 마법사 또는.net Visual Studio Visual Studio 2005.
  1. 시작 메뉴에서 프로그램, Microsoft Visual Studio 6.0차례로 가리킨 다음 Microsoft Visual Basic 6.0을 클릭.
  2. 새 프로젝트 대화 상자에서 표준 EXE를 클릭 한 다음 열기를 클릭 합니다.
  3. 첫 번째 폼이 응용이 프로그램에서 ADO를 사용 하 여 검색을 레코드 집합을 다음 Microsoft 계층적 Flexgrid에 레코드 표시 컨트롤입니다. Form1에 대 한 속성 대화 상자의 이름 필드에 입력 합니다.frmADO.
  4. 도구 상자가 열려 있지 않으면 보기 메뉴에서 도구 상자를 클릭 합니다.
  5. 도구 상자에서 폼의 대부분을 채우도록 MSHFlexGrid 는 양식에 배치 합니다. 충분 한 공간이 단추를 배치할 양식 아래쪽에 있습니다.

    참고: MSHFlexGrid 아이콘이 도구 상자에 없으면 도구 상자에 추가 합니다. 마우스는 도구 상자를 클릭 하 고 다음 구성 요소를 클릭 합니다. 구성 요소 대화 상자에서 사용 가능한 구성 요소 목록에서 Microsoft 계층적 FlexGrid 컨트롤 6.0 (OLEDB)을 선택 합니다 및 다음 확인을 클릭 합니다.
  6. 도구 상자에서 Mshflexgrid는 아래 폼에 명령 단추 를 배치 합니다. 속성 대화 상자의 캡션 필드에 입력 합니다. 확인.
  7. MADO, 마우스 오른쪽 단추로 클릭 한 다음 코드 보기를클릭 합니다. 데이터베이스 연결을 만들고 다음 코드를 추가 하 고 Northwind 데이터베이스의 Products 테이블의 데이터를 포함 하는 레코드 집합을 반환 합니다.

    참고: 다음 샘플 코드를 변경 해야 사용자 id =<username></username>암호 =<strong password=""></strong> 올바른 값으로. 사용자 ID 데이터베이스에서이 작업을 수행할 적절 한 권한이 있습니다.
    Private Sub Command1_Click()
        Unload Me
    End Sub
    
    Private Sub Form_Load()
        Dim cn As Connection
        Set cn = New Connection
        cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"
        cn.Open
        
        Dim rs As Recordset
        Set rs = New Recordset
        rs.CursorLocation = adUseClient
        rs.Open "select * from products", cn
        
        Set MSHFlexGrid1.DataSource = rs
    End Sub
    					
  8. 폼을 저장 하려면 CTRL + S를 누릅니다. 파일 메뉴에서 다른 이름으로 저장을 클릭 합니다. 다른 이름으로 저장 대화 상자에서 저장을 클릭 합니다.
  9. 프로젝트 탐색기에서 Project1마우스 오른쪽 단추로 클릭 추가클릭 한 다음 을 클릭 합니다. 열기를 클릭 합니다.
  10. 속성 대화 상자의 이름 필드에 입력 합니다. frmClipboard.
  11. 도구 상자에서 텍스트 상자 를 폼에 배치 합니다. 텍스트 필드에 입력 합니다. 빠른 갈색 여우 점프 통해 지연 강아지.
  12. 텍스트 상자아래의 명령 단추 를 배치 합니다. 속성 대화 상자의 캡션 필드에 입력 합니다. 복사.
  13. 두 번째 명령 단추 를 폼에 배치 합니다. 속성 대화 상자의 캡션 필드에 입력 합니다. 붙여넣기.
  14. FrmClipboard, 마우스 오른쪽 단추로 클릭 한 다음 코드 보기를클릭 합니다. 붙여넣기 명령 단추에 다음 코드를 이벤트를 클릭 합니다. 이 코드에서는 클립보드 에 GET 개체 및 텍스트를 붙여넣을:
    Private Sub Command1_Click()
        Clipboard.SetText Text1.SelText
    End Sub
    
    Private Sub Command2_Click()
        Text1.SelText = Clipboard.GetText
    End Sub
    					
  15. 폼을 저장 하려면 CTRL + S를 누릅니다.
  16. 필요한 마지막 폼 응용 프로그램의 기본 폼이입니다. 프로젝트 탐색기에서 Project1마우스 오른쪽 단추로 클릭 추가, 양식클릭 누른 다음 열기를 클릭 합니다.
  17. 속성 대화 상자의 이름 필드에 입력 합니다. 프로시저.
  18. 도구 상자에서 프로시저 폼에 명령 단추 를 배치 합니다. 속성 대화 상자의 캡션 필드에 입력 합니다. ADO.
  19. 두 번째 명령 단추 를 폼에 배치 합니다. 속성 대화 상자의 캡션 필드에 입력 합니다. 클립보드.
  20. FrmMain, 마우스 오른쪽 단추로 클릭 한 다음 코드 보기를클릭 합니다. 붙여넣기 명령 단추에 다음 코드를 클릭 이벤트에 다른 두 가지 형태를 보여 줍니다.
    Private Sub Command1_Click()
        frmADO.Show
    End Sub
    
    Private Sub Command2_Click()
        frmClipboard.Show
    End Sub
    					
  21. 폼을 저장 하려면 CTRL + S를 누릅니다.
  22. 솔루션 탐색기에서 Project1마우스 오른쪽 단추로 클릭 한 다음 Project1 속성을 클릭 합니다. 시작 개체 필드에서 frmMain을 누른 다음 확인을 누릅니다.
  23. 프로젝트 메뉴에서 참조를 ADO 구성 요소를 추가 하려면 참조를 클릭 합니다. 사용 가능한 참조 목록에서 Microsoft ActiveX 데이터 개체 라이브러리 (버전 2.0 이상의 일 수)을 선택 합니다. 확인을 클릭 합니다.
  24. 파일 메뉴에서 프로젝트 컴파일하려면 Project1.exe 만들기를 클릭 합니다. 프로젝트 만들기 대화 상자에서 확인 을 클릭 (기본 파일 이름을 그대로).
  25. 디버그 모드에서 응용 프로그램을 실행 하려면 F5 키를 누릅니다.

    참고: 확인 하지 않아도 레거시 Visual Basic 업그레이드 하기 전에 응용 프로그램이 문제 없이 실행 됩니다.
  26. Visual Basic 개발 환경을 닫습니다. 에 프로젝트에 변경 내용을 저장 하려면 를 눌러 확인 합니다. 기본 이름을 사용 하 여 프로젝트를 저장 합니다.
  27. 시작 메뉴에서 프로그램, Microsoft Visual Studio차례로 가리킨 누른 다음 Microsoft Visual Studio.
  28. 시작 페이지에서 프로젝트 열기를 클릭 합니다. Visual Basic 6.0 프로젝트가 있는 폴더를 찾습니다. 방금 (일반적으로 C:\Program 상자 시각적 만든 파일 Studio\VB98)입니다. Project1.vdp를 누른 다음 열기를 클릭 합니다.
  29. Visual Studio.net이 레거시 시각적 인지 감지 기본 프로젝트 및 Visual Basic 업그레이드 마법사를 시작 합니다. 마법사에 표시 된 각 단계에 대 한 진행 단계 다음에 시퀀스:
    • 에 기존 프로젝트에 새 프로젝트 만들기 업그레이드 됩니다.
    • 양식 파일 및 클래스 파일의 새 파일에 복사 프로젝트입니다.
    • 구성 요소를 나열 된 업그레이드 보고서를 제공 합니다. 프로젝트를 업그레이드 하 고 업그레이드 되지 않는 구성 요소 했습니다.

  30. 업그레이드 프로세스가 시작 될 때까지 다음 단계를 클릭 합니다. 는 업그레이드는 약 30-60 완료 하려면 초 걸립니다.
  31. 솔루션 탐색기에서 _UpgradeReport.htm두 번 클릭 합니다. 이 보고서는 업그레이드 결과 표시합니다. 이때 모든 폼의 frmClipboard 업그레이드 하지 않고 문제를 제외 하 고.
  32. 문제를 보려면 frmClipboard.vb 를 확장 합니다. Clipboard.SetTextGetText 제대로 업그레이드 되지 않았습니다. 설명 있는 문제를 해결 하는 방법을 보려면 링크를 클릭 합니다.
  33. 솔루션 탐색기에서 폼의 모든 유지 하는 note 원래 이름 있지만 파일 확장명은.frm 하에서 바뀝니다. . vb.
  34. 참조를 확장 합니다. 참고 모든 필수 구성 요소에 참조 레거시 ADO 및 Visual Basic 구성 요소를 사용 하려면 추가 되었습니다. 자동으로.
  35. 폼을 마우스 오른쪽 단추로 클릭 한 다음 코드 보기를클릭 합니다. 업그레이드 지원 영역을 확장 합니다. .Net Visual Studio 또는 Visual Studio 2005 구성 방법이 영역이 표시 됩니다. 다양 한 속성 및 변수 업그레이드 된 코드를 지원 합니다.
  36. 솔루션 탐색기에서 frmClipboard.vb를 마우스 오른쪽 단추로 누른 다음 코드 보기. 참고 주석 하지 않은 줄 앞에 배치 됩니다 업그레이드.
  37. Command1_ClickCommand2_Click 이벤트를 다음과 같이 변경:
    Private Sub Command1_Click(ByVal eventSender As System.Object, _
        ByVal eventArgs As System.EventArgs) Handles Command1.Click
            Clipboard.SetDataObject(Text1.Text)
        End Sub
    
        Private Sub Command2_Click(ByVal eventSender As System.Object, _
        ByVal eventArgs As System.EventArgs) Handles Command2.Click
            Text1.SelectedText = _
                Clipboard.GetDataObject().GetData(GetType(System.String))
        End Sub
    					

전체 코드 예제

전체 코드 예제 (frmADO.frm)

Private Sub Command1_Click()
    Unload Me
End Sub

Private Sub Form_Load()
    Dim cn As Connection
    Set cn = New Connection
    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"
    cn.Open
    
    Dim rs As Recordset
    Set rs = New Recordset
    rs.CursorLocation = adUseClient
    rs.Open "select * from products", cn
    
    Set MSHFlexGrid1.DataSource = rs
End Sub
				

전체 코드 예제 (frmClipboard.frm)

Private Sub Command1_Click()
    Clipboard.SetText Text1.SelText
End Sub

Private Sub Command2_Click()
    Text1.SelText = Clipboard.GetText
End Sub

Complete Code Listing (frmMain.frm)
Private Sub Command1_Click()
    frmADO.Show
End Sub

Private Sub Command2_Click()
    frmClipboard.Show
End Sub
				

응용 프로그램이 제대로 작동 하는지 확인 합니다.

  1. 응용 프로그램을 시작 하려면 F5 키를 누릅니다.
  2. 프로젝트를 저장 하는 메시지가 나타나면 확인을 클릭 합니다.
  3. ADO에서 form1을 클릭 합니다. 폼 모눈에 데이터가 표시 됩니다. 이 닫습니다 양식입니다.
  4. Form1에서 클립보드를 클릭 합니다.
  5. 복사를 클릭 합니다.
  6. 텍스트 상자 시작 부분에 삽입점을 놓습니다. 텍스트를 클릭 한 다음 붙여넣기를 클릭 합니다. 붙여넣은 텍스트가 표시 되어야 합니다.

문제 해결

Visual Basic.net 이전 버전의 큰 변화는 Visual Basic. 여러 프로젝트에 대 한 몇 가지 광범위 한 준비 작업은 것이 좋습니다. 업그레이드 하기 전에. 정보는 다음 문서를 참조 하십시오. 보다 쉽게 업그레이드할 수 있습니다.
업그레이드 하기 전에 고려할 사항

참조

자세한 내용은 다음 Microsoft 개발자에 게 네트워크 (MSDN) 문서:
에 임의의 다른 Visual Basic 6.0 응용 프로그램 업그레이드를 준비합니다.

Visual Basic 이전 버전에서 만든 응용 프로그램 업그레이드

속성

기술 자료: 317885 - 마지막 검토: 2012년 7월 2일 월요일 - 수정: 1.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Visual Basic 2005
  • Microsoft Visual Basic .NET 2003 Standard Edition
  • Microsoft Visual Basic .NET 2002 Standard Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft .NET Framework 1.1
키워드:?
kbvs2005swept kbvs2005applies kbmigration kbhowtomaster kbmt KB317885 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.
이 문서의 영문 버전 보기:317885

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com