Help and Support

Article ID: 318080 - Last Review: February 4, 2006 - Revision: 2.7

"The system cannot open the device or file specified" error message occurs when you try to install the .NET Framework

This article was previously published under Q318080

On This Page

Expand all | Collapse all

SYMPTOMS

When you try to install the .NET Framework, you receive the following error message:
The system cannot open the device or file specified.
Internal Error 2755. 110,
. . . \LOCALS~1\Temp\IXP000.TMP\netfx.msi
When this behavior occurs, the following entry appears in the Event log:
The system cannot open the device or file specified.
. . . \LOCALS~1\Temp\IXP000.TMP\netfx.msi
In the VS .NET Windows Component Update Setup dialog box, you receive the following error message:
The following component failed to install:

X Microsoft .NET Framework.
The following entry may appear in the Baseventlog.txt file:
Microsoft .NET Framework: ***ERRORLOG EVENT*** : Error code 110 for this component means "The system cannot open the device or file specified."

CAUSE

This behavior occurs because the Temp folder is encrypted by using the Encrypted File System.

RESOLUTION

Do not encrypt the Temp folder until after the .NET Framework Setup has completed.

MORE INFORMATION

Steps to Reproduce the Behavior

On a computer running Windows XP Professional, follow these steps:
  1. Right-click the Temp folder (typically C:\Documents and Settings\User Profile\Local Settings\Temp), and then click Properties.
  2. Click Advanced.
  3. Click to select the Encrypt contents to secure data check box. Click OK.
  4. Install the .NET Framework.

APPLIES TO
  • Microsoft .NET Framework 1.1
  • Microsoft .NET Framework 1.0
  • Microsoft Visual Studio .NET 2003 Professional Edition
  • Microsoft Visual Studio .NET 2003 Enterprise Architect
  • Microsoft Visual Studio .NET 2003 Enterprise Developer
  • Microsoft Visual Studio .NET 2003 Academic Edition
  • Microsoft Visual Studio .NET 2002 Enterprise Architect
  • Microsoft Visual Studio .NET 2002 Enterprise Developer
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2002 Academic Edition
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C++ .NET 2002 Standard Edition
  • Microsoft Visual Basic .NET 2002 Standard Edition
  • Microsoft Visual C# .NET 2003 Standard Edition
  • Microsoft Visual C# .NET 2002 Standard Edition
  • Microsoft Visual J# .NET 2003 Standard Edition
Keywords: 
kbvs2005doesnotapply kbvs2005swept kbtshoot kberrmsg kbprb kbsetup KB318080

Article Translations