Help and Support

"The system cannot open the device or file specified" error message occurs when you try to install the .NET Framework

Article ID:318080
Last Review:February 4, 2006
Revision:2.6
This article was previously published under Q318080
On This Page

SYMPTOMS

When you try to install the .NET Framework, you receive the following error message:
The system cannot open the device or file specified.
Internal Error 2755. 110,
. . . \LOCALS~1\Temp\IXP000.TMP\netfx.msi
When this behavior occurs, the following entry appears in the Event log:
The system cannot open the device or file specified.
. . . \LOCALS~1\Temp\IXP000.TMP\netfx.msi
In the VS .NET Windows Component Update Setup dialog box, you receive the following error message:
The following component failed to install:

X Microsoft .NET Framework.
The following entry may appear in the Baseventlog.txt file:
Microsoft .NET Framework: ***ERRORLOG EVENT*** : Error code 110 for this component means "The system cannot open the device or file specified."

Back to the top

CAUSE

This behavior occurs because the Temp folder is encrypted by using the Encrypted File System.

Back to the top

RESOLUTION

Do not encrypt the Temp folder until after the .NET Framework Setup has completed.

Back to the top

MORE INFORMATION

Steps to Reproduce the Behavior

On a computer running Windows XP Professional, follow these steps:
1.Right-click the Temp folder (typically C:\Documents and Settings\User Profile\Local Settings\Temp), and then click Properties.
2.Click Advanced.
3.Click to select the Encrypt contents to secure data check box. Click OK.
4.Install the .NET Framework.

Back to the top


APPLIES TO
Microsoft .NET Framework 1.1
Microsoft .NET Framework 1.0
Microsoft Visual Studio .NET (2003), Professional Edition
Microsoft Visual Studio .NET 2002 Enterprise Architect
Microsoft Visual Studio .NET 2002 Enterprise Developer
Microsoft Visual Studio .NET 2002 Professional Edition
Microsoft Visual Studio .NET 2002 Academic Edition
Microsoft Visual C++ .NET 2003 Standard Edition
Microsoft Visual C++ .NET 2002 Standard Edition
Microsoft Visual Basic .NET 2002 Standard Edition
Microsoft Visual C# .NET 2003 Standard Edition
Microsoft Visual C# .NET 2002 Standard Edition
Microsoft Visual J# .NET 2003 Standard Edition

Back to the top

Keywords: 
kbvs2005doesnotapply kbvs2005swept kbtshoot kberrmsg kbprb kbsetup KB318080

Back to the top

Article Translations

 

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.