Help and Support

[PRB] .NET Framework のインストール時にエラー メッセージ "指定されたデバイスまたはファイルを開けません" が表示される

文書番号:318080
最終更新日:2005年12月6日
リビジョン:2.6
目次

現象

.NET Framework のインストール時に、次のエラー メッセージが表示されます。
指定されたデバイスまたはファイルを開けません。
内部エラー 2755 110,
. . . \LOCALS~1\Temp\IXP000.TMP\netfx.msi
この現象が発生すると、次のエントリがイベント ログに記録されます。
指定されたデバイスまたはファイルを開けません。
. . . \LOCALS~1\Temp\IXP000.TMP\netfx.msi
[Visual Studio .NET Windows コンポーネント アップデート セットアップ] ダイアログ ボックスでは、次のエラー メッセージが表示されます。
以下のコンポーネントをインストールできませんでした。

X Microsoft .NET Framework.
Baseventlog.txt ファイルには、次のエントリが記録されている可能性があります。
Microsoft .NET Framework: ***ERRORLOG EVENT*** : Error code 110 for this component means "指定されたデバイスまたはファイルを開けません。"

先頭へ戻る

原因

この現象は、Temp フォルダが暗号化ファイル システムを使用して暗号化されているために発生します。

先頭へ戻る

解決方法

.NET Framework セットアップが完了するまでは、Temp フォルダを暗号化しないでください。

先頭へ戻る

詳細

現象の再現手順

Windows XP Professional を実行しているコンピュータで、以下の手順を実行します。
1. Temp フォルダ (通常は C:\Documents and Settings\User Profile\Local Settings\Temp) を右クリックし、[プロパティ] をクリックします。
2. [詳細設定] をクリックします。
3. [内容を暗号化してデータをセキュリティで保護する] チェック ボックスをオンにします。[OK] をクリックします。
4. .NET Framework をインストールします。

先頭へ戻る


この資料は以下の製品について記述したものです。
?Microsoft Visual Studio .NET 2003 Enterprise Architect
?Microsoft Visual Studio .NET 2003 Enterprise Developer
?Microsoft Visual Studio .NET 2003 Professional Edition
?Microsoft Visual Studio .NET 2003 Academic Edition
?Microsoft Visual Studio .NET 2002 Enterprise Architect
?Microsoft Visual Studio .NET 2002 Enterprise Developer
?Microsoft Visual Studio .NET 2002 Professional Edition
?Microsoft Visual Studio .NET 2002 Academic Edition
?Microsoft Visual C++ .NET 2003 Standard Edition
?Microsoft Visual C++ .NET 2002 Standard Edition
?Microsoft Visual Basic .NET 2002 Standard Edition
?Microsoft Visual C# .NET 2003 Standard Edition
?Microsoft Visual C# .NET 2002 Standard Edition
?Microsoft .NET Framework 1.1
?Microsoft .NET Framework 1.0
?Microsoft Visual J# .NET 2003 Standard Edition

先頭へ戻る

キーワード:?
kberrmsg kbprb kbsetup KB318080

先頭へ戻る

"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.