Como usar endereços de uma planilha do Excel para criar etiquetas no Word

Traduções deste artigo Traduções deste artigo
ID do artigo: 318117 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

É possível usar o recurso Mala direta no Microsoft Word para criar e imprimir etiquetas para envio em massa usando os dados de uma planilha do Microsoft Excel. Este artigo contém instruções que você pode usar para criar tal lista.

Ao usar o recurso mala direta do Word, o Word mescla um "documento principal" com uma "lista de destinatários" para gerar um conjunto de "documentos de saída".
  • O documento principal contém o texto básico que é o mesmo em todos os documentos de saída. Ele pode conter um papel timbrado, texto e instruções nos "campos de mesclagem" para inserir texto (tais como nomes e endereços de destinatários) que variam de um documento de saída para outro.
  • A lista de destinatários é um banco de dados, por exemplo, um arquivo de banco de dados do Microsoft Access 2002 ou uma pasta de trabalho do Excel, que contém os dados a serem mesclados nos documentos de saída. Normalmente, este banco de dados é uma lista de nomes, endereços e números de telefone.
  • Os documentos de saída são o resultado da mala direta. O texto em um documento de saída pode ser o mesmo em todos os documentos de saída, mas é possível aplicar formatação em diferentes documentos.

Etapa 1: Configurar o arquivo de dados do Excel

Antes de continuar com o Assistente de mala direta, verifique se sua planilha do Excel está bem estruturada para esse propósito. Observe os seguintes requisitos para a tabela de dados:
  • A primeira linha deve conter nomes de campo para cada coluna. Por exemplo, título, saudação, nome, segundo nome, sobrenome, endereço1 e endereço2.
  • Cada nome de campo deve ser exclusivo.
  • Cada linha deve fornecer informações sobre um item específico. Em uma lista de endereçamento, por exemplo, cada linha pode incluir informações sobre um destinatário específico.
  • A tabela não deve ter linhas em branco.
Para organizar seus arquivos de dados do Excel, execute as etapas a seguir:
  1. Crie seu arquivo de dados do Excel e organize-o usando os campos que deseja usar para sua etiqueta, conforme exibido no seguinte arquivo de dados de exemplo:

    Last Name First Name Title Address City Postal Code Country
    Davolio Nancy Sales Representative 1234 Main St. Apt. 2A Seattle 14222 USA
    Fuller Andrew Vice President, Sales 1235 Main St. Tacoma 14222 USA
    Leverling Janet Sales Representative 1235 Elm St. Kirkland 14222 USA
    Peacock Margaret Sales Representative 1236 Main St. Redmond 14222 USA
    Buchanan Steven Sales Manager 1237 Main St London SW2 8MR UK
    Suyama Michael Sales Representative 1238 Elm St. London EC3 7HR UK
    King Robert Sales Representative 1239 Main St. London RK2 9NP UK
    Callahan Laura Inside Sales Coordinator 1230 Elm St. Seattle 14222 USA
    Dodsworth Anne Sales Representative 1231 Elm St. London WG2 7LT UK


  2. Após a criação do seu arquivo de dados do Excel, salve-o e feche-o.
Para obter mais informações sobre como criar uma lista de endereço de mala direta, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
294688 Como criar e configurar uma lista de endereço de mala direta no Word 2002

Etapa 2: Configurar o documento principal

  1. Inicie o Microsoft Office Word 2003 ou uma versão anterior do Word, aponte para Cartas e correspondências no menu Ferramentas e clique em Assistente de mala direta.

    Inicie o Microsoft Office Word 2007, clique na guia Endereçamentos, em Iniciar mala direta no grupo Iniciar mala direta e clique em Assistente de Mala Direta Passo a Passo.
  2. Em Selecionar o tipo de documento, clique em Etiquetas.

    O documento ativo torna-se o documento principal (o documento que contém o texto e os gráficos iguais para cada versão do documento mesclado. por exemplo, o remetente ou a saudação em uma carta modelo).
  3. Clique em Próximo: Iniciar o documento.

    OBSERVAÇÃO: Se você estiver familiarizado com o recurso mala direta ou preferir trabalhar sem o assistente, será possível usar a barra de ferramentas Mala direta.
  4. Execute um dos seguintes procedimentos:
    • Crie uma nova planilha de etiquetas:
      1. Clique em Alterar o layout do documento.
      2. Clique em Opções de etiqueta.
      3. Na caixa de diálogo Opções de etiqueta, selecione as opções que deseja, tais como o tipo e o tamanho da etiqueta, e clique em OK.

        Para obter ajuda sobre uma opção, clique no ponto de interrogação e na opção.
    • Inicie com uma planilha de etiquetas existente:
      1. Clique em Iniciar com base em documento existente.
      2. Na caixa Iniciar com base em, selecione o documento desejado e clique em Abrir.
      3. Se não for possível ver o documento, clique em Mais arquivos e clique em Abrir. Na caixa de diálogo Abrir, localize o documento desejado e clique em Abrir.

        O Word exibe o documento em uma janela de documento. Se você decidir usar um diferente documento de etiqueta, clique em Iniciar em um documento existente e selecione um documento diferente. Se você quiser alterar o layout, clique em Alterar o layout do documento e em Opções de etiqueta.
  5. Clique em Próximo: Selecione os destinatários.

Etapa 3: Especificar a fonte de dados do Excel

  1. Em Selecionar destinatários, clique em Usar uma lista existente.
  2. Clique em Navegar.
  3. Na caixa de diálogo Selecionar fonte de dados, localize e clique na planilha do Excel que deseja usar.

    Por padrão, o Word abre a pasta Minhas fontes de dados.
  4. Clique em Abrir.
  5. Se a sua planilha do Excel contiver informações sobre várias etiquetas, será necessário selecionar a guia que contém as informações desejadas e clicar em OK. Todas as entradas na fonte de dados aparecem na caixa de diálogo Destinatários da mala direta, onde é possível refinar a lista de destinatários para incluir na mesclagem.

Etapa 4: Selecionar os destinatários

  1. Na caixa de diálogo Destinatários da mala direta, selecione os destinatários que deseja incluir. Para isso, faça o seguinte.
    • Use as caixas de seleção para designar os destinatários.

      Este método será o mais útil se a sua lista for pequena. Marque as caixas de seleção ao lado dos destinatários que deseja incluir e desmarque as caixas ao lado dos destinatários que deseja excluir.

      OBSERVAÇÃO: Se você deseja incluir a maioria da lista na mesclagem, clique em Selecionar tudo e desmarque os registros específicos. Da mesma forma, se você deseja incluir apenas alguns registros na lista, clique em Limpar tudo e selecione os registros desejados.
    • Classifique os itens na lista.

      Isto será útil se você deseja ver os itens em ordem alfabética ou numérica. Clique no cabeçalho da coluna do item que deseja classificar. Por exemplo, se você deseja exibir a lista em ordem alfabética pelo sobrenome, clique no cabeçalho da coluna Sobrenome.
    • Filtre os itens na lista.

      Isto será útil se a lista contiver registros que você sabe que não deseja ver ou incluir na mesclagem. Depois de filtrar a lista, é possível usar as caixas de seleção para incluir e excluir os registros conforme descrito na seção anterior. Para filtrar esta lista, execute as seguintes etapas:
      1. Clique na seta ao lado do cabeçalho da coluna do item pelo qual deseja filtrar.
      2. Clique em um dos seguintes itens:
        • (Vazias) exibe todos os registros nos quais o campo correspondente está vazio.
        • (NãoVazias) exibe todos os registros nos quais o campo correspondente contém informações.
        • Se a sua fonte de dados contiver registros que compartilham as mesmas informações, e houver dez ou menos valores na coluna, será possível filtrar por informação específica. Por exemplo, se houver vários endereços que listam Austrália como país/região, será possível filtrar por Austrália.
    • A caixa de diálogo Destinatários da mala direta exibe somente os registros designados. Para exibir todos os registros novamente, clique em (Todos).
    OBSERVAÇÕES:
    • Para classificação e filtragem avançadas, clique na seta ao lado de qualquer nome de coluna e clique em (Avançados). Use as guias Filtrar os registros te Classificar os registros para configurar a consulta de classificação ou de filtragem desejada.
    • Se você tem software de validação de endereço instalado, clique em Validar na caixa de diálogo Destinatários da mala direta para validar os endereços dos seus destinatários.
  2. :Clique em OK para retornar ao Assistente de mala direta.

    O Word usará os destinatários designados para a mesclagem.
  3. :Clique em Próximo: Organize suas etiquetas.

Etapa 5: Organize o conteúdo de suas etiquetas

Para organizar o conteúdo de suas etiquetas, execute essas etapas.

Inserir campos de mesclagem

Insira campos de mesclagem nos quais deseja mesclar nomes, endereços e outras informações, tais como código postal. Por exemplo, insira o campo de mesclagem "Cidade" para que o Word insira um nome de cidade como "Atlanta", que está armazenado no campo de dados Cidade. Para inserir campos de mesclagem, execute as seguintes etapas:
  1. No documento principal, clique no local que deseja inserir o campo.
  2. Insira um dos seguintes itens:
    • Bloco de endereço com nome, endereço e outras informações
      1. Clique em Bloco de endereço.
      2. Na caixa de diálogo Inserir bloco de endereço, selecione os elementos de endereço que deseja incluir e os formatos desejados e clique em OK. Para obter ajuda sobre uma opção, clique no ponto de interrogação e na opção.

      3. Para obter ajuda sobre uma opção, clique no ponto de interrogação e na opção. Se a caixa de diálogo Coincidir campos aparecer, talvez o Word não possa encontrar algumas das informações necessárias no bloco de endereço. Clique na seta ao lado de (não disponível) e selecione o campo da sua fonte de dados que corresponde ao campo exigido para a mala direta.
    • Linha de saudação
      1. Clique em Linha de saudação.
      2. Selecione o formato da linha de saudação, que inclui a saudação, o formato de nome e a seguinte pontuação.
      3. Selecione o texto para aparecer nos casos em que o Word não pode interpretar o nome do destinatário, por exemplo, quando a fonte de dados não contém nome nem sobrenome de um destinatário, mas somente um nome de empresa.
      4. Clique em OK.
      5. Se a caixa de diálogo Coincidir campos aparecer, talvez o Word não possa encontrar algumas das informações necessárias para a linha de saudação. Clique na seta ao lado de (não disponível) e selecione o campo da sua fonte de dados que corresponde ao campo exigido para a mala direta.
    • Outros campos de informações
      1. Clique em Mais itens.
      2. Execute um dos seguintes procedimentos:
        • Para selecionar nos campos de endereço que irão automaticamente mapear para corresponder aos campos na sua fonte de dados, mesmo se os campos da fonte de dados não tiverem o mesmo nome que os seus campos, clique em Campos de endereço.
        • Para selecionar nos campos que sempre obtêm dados diretamente de uma coluna em um banco de dados, clique em Campos de banco de dados.
      3. Na caixa Campos, clique no campo desejado.
      4. Clique em Inserir e em Fechar.
      5. Se a caixa de diálogo Coincidir campos aparecer, talvez o Word não possa encontrar algumas das informações necessárias para inserir no campo. Clique na seta ao lado de (não disponível) e selecione o campo da sua fonte de dados que corresponde ao campo exigido para a mala direta.

        OBSERVAÇÃO: Se você inserir um campo da lista Campos de banco de dados e mais tarde alternar para uma fonte de dados que não tem uma coluna com o mesmo nome, o Word não poderá inserir aquelas informações de campo no documento mesclado.
    • Postagem eletrônica

      Para adicionar postagem eletrônica, é necessário primeiro instalar um programa de postagem eletrônica como o que você comprou de um serviço na Web. Para usar a postagem eletrônica, execute as etapas a seguir:
      1. Clique em Postagem eletrônica.

        Se você não tiver um programa de postagem eletrônica instalado, o Word solicitará que você instale um e oferecerá uma conexão com o seguinte site da Microsoft:
        Microsoft Office Web
      2. Insira a postagem de acordo com as instruções do programa.
    • Para adicionar postagem eletrônica, é necessário primeiro instalar um programa de postagem eletrônica como o que você comprou de um serviço na Web.

      Código postal

      Você deve seleciona uma etiqueta ou tipo de envelope que ofereça suporte ao código de barra POSTNET. Para usar o Código postal, execute as seguintes etapas:
      1. Clique em Código postal.
      2. Na caixa de diálogo Inserir código postal, selecione os campos de endereço apropriados.

        OBSERVAÇÃO: A opção Código postal aparecerá somente se você estiver usando a versão em inglês do Word.
      3. Repita as etapas a e b para todos os campos que deseja inserir.

        OBSERVAÇÕES:
        • No Word 2003 e em versões anteriores, não é possível digitar caracteres de campo mesclado (" ") ou inseri-los usando o comando Símbolo no menu Inserir.

          No Word 2007, não é possível digitar caracteres de campo mesclado (" ") ou inseri-los usando o comando Símbolo no grupo Símbolos na guia Inserir.
        • Se os campos mesclados aparecerem entre colchetes, por exemplo, { MERGEFIELD City }, o Word exibirá os códigos de campo em vez dos resultados de campo. Isso não afetará a mesclagem, mas se você deseja exibir os resultados, clique com o botão direito do mouse no código de campo e clique em Alternar códigos de campo no menu de atalho.
    Observação No Word 2003 e em versões anteriores do Word, também é possível usar a barra de ferramentas Mala direta para inserir campos de mesclagem, trabalhar com o documento principal da mala direta ou executar uma mala direta. Para exibir a barra de ferramentas Mala direta, aponte para Cartas e correspondências no menu Ferramentas e clique em Mostrar barra de ferramentas Mala direta. A barra de ferramentas Mala direta fornece comandos adicionais que não estão inclusos no painel de tarefas no assistente Mala direta. Por exemplo, é possível usar o menu suspenso Inserir campo do Word na barra de ferramentas Mala direta para inserir campos do Word para controlar o processo de mesclagem (por exemplo, um campo Se que insere texto somente se um campo de mesclagem específico tiver um valor especificado). Ou, é possível clicar em Verificar se há erros para que o Word execute a mala direta e comunique qualquer erro encontrado no documento principal.

Alterar o formato dos dados mesclados

Para formatas os dados mesclados, é necessário formatar os campos de mesclagem no documento principal. Não formate os dados na fonte de dados, pois o seu formato não é mantido ao mesclar os dados com o documento. Para alterar o formato dos dados mesclados, execute estas etapas:
  1. No documento principal, selecione o campo que contém as informações que deseja formatar, incluindo os caracteres de campo de mesclagem ("" "") que se adequam a ele.
  2. No Word 2003 e em versões anteriores do Word, clique em Fonte no menu Formatar e selecione as opções desejadas.

    No Word 2007, na guia Iniciar, clique em Fonte no grupo Fonte para abrir a caixa de diálogo Fonte e selecione as opções desejadas.

Formatar usando códigos de campo

Para controlar outros aspectos de formatação, pressione ALT+F9 para exibir os códigos de campo e adicionar opções aos campos de mesclagem. Ao trabalhar com os campos, uma opção é uma instrução especial que causa uma ação específica. Geralmente, você adiciona uma opção a um campo para modificar um resultado.

Por exemplo:
  1. Para exibir o número "34987.89" como "$34,987.89," adicione a opção Formato Numérico (\#).
  2. Para imprimir nomes de clientes em letra maiúscula, adicione a opção Formato (\*).
  3. Para verificar se as informações mescladas têm a mesma fonte e tamanho que você aplicou ao campo de mesclagem, adicione a opção \* Charformat.
Para copiar o formato e o layout da primeira etiqueta para todas as outras etiquetas na página, clique Atualizar todas as etiquetas.

Por exemplo, no banco de dados de exemplo exibido anteriormente neste artigo, se você inserir somente o campo BlocodeEndereço e clicar em Atualizar todas as etiquetas, a página deverá ser parecida com o seguinte:

<<AddressBlock>><<Next Record>><<AddressBlock>>

<<Next Record>><<AddressBlock>><<Next Record>><<AddressBlock>>

Etapa 6: Salvar o documento

Após a conclusão do documento principal e inserção de todos os campos de mesclagem, salve o documento antes de continuar.
  1. No Word 2003 e em versões anteriores do Word, clique em Salvar como no menu Arquivo.

    No Word 2007, clique em Botão do Microsoft Office e em Salvar como.
  2. Nomeie o documento e clique em Salvar.
  3. Clique em Próximo: Visualizar suas etiquetas.

Etapa 7: Visualizar as etiquetas e fazer ajuste fino na lista de destinatários

Quando o assistente exibe o painel de tarefas Mala direta da Etapa 5, ele substitui cada um dos campos de mesclagem no documento principal pelo texto real da primeira entrada da lista de destinatários, de modo que você possa ver a aparência do seu primeiro documento de saída.

Por exemplo, se você continuar a usar o banco de dados de exemplo exibido anteriormente, após clicar em Próximo: Visualize as etiquetas, a primeira página deverá ser parecida com o seguinte:
Vice-Presidente, Vendas Andrew Fuller     Representante de vendas Anne Dodsworth
1235 Main St                            1231 Elm St.
Tacoma                                  Londres
	
	
Representante de vendas Janet Leverling     Coordenadora de vendas interna Laura Callahan
1235 Elm St.                             1230 Elm St.
Kirkland                                 Seattle
				
Para visualizar entradas adicionais, faça o seguinte:
  • Para visualizar os itens em ordem, clique nos botões de seta para a esquerda ou para a direita.

    Cada registro é visualizado na primeira etiqueta na planilha.
  • Para localizar e visualizar um item específico, clique em Localizar um destinatário e digite os critérios de busca na caixa de diálogo Localizar entrada.
Para fazer ajuste fino da lista de destinatários, por exemplo, para excluir um destinatário:
  1. Clique em Editar lista de destinatários e faça as alterações na caixa de diálogo Destinatários da mala direta.
  2. Clique em Próximo: Concluir a mesclagem.

Etapa 8: Concluir a mesclagem

Para concluir a mesclagem, faça o seguinte:

Personalizar etiquetas individuais

Para personalizar etiquetas individuais, conclua a mesclagem e edite as informações que deseja no documento mesclado resultante.
  1. Clique em Editar etiquetas individuais.
  2. Na caixa de diálogo Mesclar para novo documento, selecione os registros que deseja mesclar.
  3. Clique em OK.

    O Word cria e abre um novo documento mesclado. Seu principal documento também permanecerá aberto e você poderá retornar para ele se desejar fazer uma alteração para todos os itens.
  4. Vá até as informações que deseja editar e faça as alterações.
  5. Imprima ou salve o documento exatamente como faria com qualquer documento.

Imprimir a planilha de etiquetas

Para imprimir a planilha de etiquetas, faça o seguinte:
  • Se você personalizou os itens e o documento mesclado está ativo:
    1. No Word 2003 e em versões anteriores do Word, clique em Imprimir no menu Arquivo.

      No Word 2007, clique no Botão do Microsoft Office, aponte para Imprimir e clique em Imprimir.
    2. Selecione as opções desejadas.
  • Se você deseja imprimir diretamente do assistente Mala direta:
    1. Na Etapa 6 do assistente Mala direta (Conclua a mesclagem), clique em Imprimir.
    2. Na caixa de diálogo Mesclar para impressora, digite o seguinte e clique em OK:
      • Para imprimir todos os documentos, clique em Tudo.
      • Para imprimir o documento que deseja ver na janela de documento, clique em Registro atual.
      • Para imprimir uma variedade de documentos, clique em De e digite os números de registro nas caixas De e Para .
    3. Na caixa de diálogo Imprimir, selecione as opções desejadas.

Salvar a planilha de etiquetas para uso posterior

Se você deseja editar etiquetas mescladas ou salvá-las para uso posterior, você poderá coletá-las em um único documento.
  1. Clique em Editar etiquetas individuais.
  2. Na caixa de diálogo Mesclar para um novo documento, digite o seguinte e clique em OK:
    • Para mesclar todos os documentos, clique em Tudo.
    • Para mesclar somente o documento que deseja ver na janela de documento, clique em Registro atual.
    • Para mesclar uma variedade de documentos, clique em De e digite os números de registro nas caixas De e Para .
  3. O Word abre um único documento novo que contém todas as etiquetas individuais. Você pode salvar o documento para uso posterior, exatamente como faria com qualquer documento.

REFERÊNCIAS

Para obter mais informações sobre campos SE, pressione F1 para abrir a Ajuda do Word, digite Códigos de campo: campo SE na caixa Pesquisar e clique em Pesquisa para exibir os tópicos encontrados.

Para obter mais informações sobre os campos MERGESEQ, pressione F1 para abrir a Ajuda do Word, digite Códigos de campo: campo MERGESEQ na caixa Pesquisar e clique em Pesquisa para exibir os tópicos encontrados.

Para obter mais informações sobre o campo SET, pressione F1 para abrir a Ajuda do Word, digite Códigos de campo: SET na caixa Pesquisar e clique em Pesquisa para exibir os tópicos encontrados.

Para obter mais informações sobre as opções gerais de formatação de campo, pressione F1 para abrir a Ajuda do Word, digite opções gerais na caixa Pesquisar e clique em Pesquisa para exibir o tópico.
294686 Como usar a mala direta para criar uma lista classificada por categorias no Word 2002
290408 Perguntas freqüentes sobre a mala direta no Word 2002
294688 Como criar e configurar uma lista de endereço de mala direta no Word 2002
294693 Como usar a mala direta para criar um diretório no Word 2002
294683 Como usar a mala direta para criar cartas modelo no Word 2002

Propriedades

ID do artigo: 318117 - Última revisão: terça-feira, 27 de março de 2012 - Revisão: 5.0
A informação contida neste artigo aplica-se a:
  • Microsoft Office Excel 2007
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Office Word 2007
  • Microsoft Word 2002 Standard Edition
Palavras-chave: 
kbhowtomaster kbmerge KB318117

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com