Использование адресов в книге Excel для создания наклеек в Word

Переводы статьи Переводы статьи
Код статьи: 318117 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Аннотация

Функцию слияния Microsoft Word можно использовать для создания и печати наклеек для массовых рассылок с помощью данных книги Microsoft Excel. В данной статье содержатся инструкции по созданию такого списка.

При использовании функции слияния Word происходит объединение «основного документа» со «списком получателей», в результате чего создается «комплект выходных документов».
  • В основном документе содержится текст, являющийся одинаковым для всех выходных документов. В документе может содержаться бланк, текст и инструкции в «полях слияния» по вставке текста (такого как имена получателей и адреса) для отдельных выходных документов.
  • Список получателей является базой данных, например, файлом базы данных Microsoft Access 2002 или книгой Excel, с данными для объединения в выходных документах. Обычно эта база данных является списком имен, адресов и номеров телефонов.
  • Результатов слияния являются выходных документы. Текст всех выходных документов может быть одинаковым, но возможно форматирование отдельных документов.

Шаг 1. Настройка файлы данных Excel

До запуска мастера писем необходимо убедиться, что книга Excel структурирована соответствующим образом. Обратите внимание на следующие требования для таблицы данных.
  • В первой строке должны содержаться имена полей для всех столбцов. Например, должность, обращение, имя, отчество, фамилия, адрес1 и адрес2.
  • Все имена полей должны быть уникальными.
  • В каждой строке должны содержаться сведения об определенном элементе. Например, в списке рассылки, каждая строка должна содержать информацию об определенном получателе.
  • В таблице не должно быть пустых строк.
Для упорядочивания файла данных Excel выполните следующие действия.
  1. Создайте файл данных Excel и упорядочите его с помощью полей, которые необходимо использовать для наклейки, как показано в следующем примере файла данных.

    Фамилия Имя Должность Адрес Город Почтовый индекс Страна
    Davolio Nancy Sales Representative 1234 Main St. Apt. 2A Seattle 14222 USA
    Fuller Andrew Vice President, Sales 1235 Main St. Tacoma 14222 USA
    Leverling Janet Sales Representative 1235 Elm St. Kirkland 14222 USA
    Peacock Margaret Sales Representative 1236 Main St. Redmond 14222 USA
    Buchanan Steven Sales Manager 1237 Main St London SW2 8MR UK
    Steven Michael Sales Representative 1238 Elm St. London EC3 7HR UK
    King Robert Sales Representative 1239 Main St. London RK2 9NP UK
    Callahan Laura Inside Sales Coordinator 1230 Elm St. Seattle 14222 USA
    Dodsworth Anne Sales Representative 1231 Elm St. London WG2 7LT UK


  2. После создания файла данных Excel сохраните его, а затем закройте.
Дополнительные сведения о создании списка адресов для слияния см. в следующей статье базы знаний Майкрософт:
294688 Разработка и создание списка адресов для слияния в Word 2002 (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Шаг 2. Настройка основного документа

  1. Откройте Microsoft Office Word 2003 или более раннюю версию программы Word, выберите Письма и рассылки в меню Сервис, затем щелкните Мастер писем.

    Откройте Microsoft Office Word 2007, щелкните вкладку Рассылки, щелкните Начать слияние в группе Начать слияние, затем щелкните Пошаговый мастер слияния.
  2. В списке Выбор типа документа выберите Наклейки.

    Активный документ становится основным документом (документ, который содержит текст и рисунки, совпадающие во всех версиях составного документа, например обратный адрес или приветствие в документе на бланке).
  3. Щелкните Далее. Открытие документа.

    Примечание. Если вы знакомы с функцией слияния или предпочитайте работать без мастера, можно использовать панель инструментов слияния.
  4. Выполните одно из следующих действий.
    • Создайте новый лист с наклейками.
      1. Щелкните Изменить макет документа.
      2. Щелкните Параметры наклейки.
      3. В диалоговом окне Параметры наклейки установите нужные параметры, такие как тип и размер наклейки, и нажмите кнопку OK.

        Для получения справки по определенному параметру щелкните знак вопроса, затем щелкните параметр.
    • Начните с существующего листа наклеек.
      1. Щелкните Существующий документ.
      2. В поле Существующий документ выберите нужный документ и щелкните Открыть.
      3. Если документ отсутствует, щелкните Другие файлы, затем щелкните Открыть. Выберите нужный документ в диалоговом окне Открыть и нажмите кнопку Открыть.

        Документ отображается в окне документа программы Word. При необходимости использования другого документа с наклейками в существующем документе щелкните Запуск и выберите другой документ. При необходимости изменения макета щелкните Изменить макет документа, затем щелкните Параметры наклейки.
  5. Щелкните Далее. Выбор получателей.

Шаг 3. Указание источника данных Excel

  1. В группе Выбор получателей щелкните Существующий список.
  2. Щелкните Обзор.
  3. В диалоговом окне Выбор источника данных выберите нужный лист Excel.

    По умолчанию в программе Word открывается папка «Мои источники данных».
  4. Нажмите кнопку Открыть.
  5. Если на листе Excel содержится информация на нескольких вкладках, выберите вкладку с нужными сведениями и нажмите кнопку OK. Все записи источника данных появляются в диалоговом окне Получатели слияния, в котором можно уточнить список получателей для включения в слияние.

Шаг 4. Выбор получателей

  1. В диалоговом окне Получатели слияния выберите получателей, которых необходимо включить. Для этого воспользуйтесь одним из следующих способов.
    • Укажите получателей с помощью флажков.

      Этот способ является наиболее предпочтительным вариантом, если ваш список короткий. Установите флажки для получателей, которых необходимо включить, и снимите флажки для получателей, которых необходимо исключить.

      Примечание. Если известно, что в слияние необходимо включить большую часть получателей в списке, щелкните Выбрать все, затем снимите флажки для определенных получателей. Аналогично, если необходимо включить только несколько записей в списке, щелкните Очистить все, затем выберите нужные записи.
    • Сортировка элементов списка.

      Это может быть полезным при необходимости расположения элементов в алфавитном или цифровом порядке. Щелкните заголовок столбца элемента, по которому необходимо выполнить сортировку. Например, при необходимости отображения списка в алфавитном порядке с сортировкой по фамилии, щелкните заголовок столбца Фамилия.
    • Фильтрация элементов списка.

      Это может быть полезным, если в списке содержатся записи, отображение или включение в слияние которых не требуются. После фильтрации списка можно включить или исключить записи, используя флажки, как описано в предыдущем разделе. Для фильтрации списка выполните следующие действия.
      1. Щелкните стрелку рядом с заголовком столбца элемента, по которому необходимо выполнить фильтрацию.
      2. Щелкните одно из следующего.
        • (Пустые) — отображение всех записей, в которых соответствующее поле является пустым.
        • (Непустые) — отображение всех записей, в которых в соответствующем поле содержится информация.
        • Если в источнике данных содержатся записи с идентичной информацией и в столбце не более десяти уникальных значений, можно выполнить фильтрацию по определенной информации. Например, если для нескольких адресов в качестве страны/региона указана Австралия, можно выполнить фильтрацию по значению «Австралия».
    • В диалоговом окне «Получатели слияния» отображаются только назначенные записи. Чтобы снова отобразить все записи, щелкните (Все).
    Примечания.
    • Для расширенной сортировки и фильтрации щелкните стрелку рядом с именем какого-либо столбца, затем щелкните (Дополнительно). Для настройки запроса на сортировку или фильтрацию используйте вкладки Отбор записей и Сортировка записей.
    • Если установлено программное обеспечение для проверки адресов, можно щелкнуть Проверить в диалоговом окне Получатели слияния для проверки адресов получателей.
  2. :Нажмите кнопку OK для возврата к мастеру слияния.

    Программа Word будет использовать получателей, назначенных для слияния.
  3. :Щелкните Далее. Настройка наклеек.

Шаг 5. Упорядочивание содержимого наклеек

Чтобы упорядочить содержимое наклеек, выполните следующие действия.

Вставка полей слияния

Вставьте поля слияния для объединения имен, адресов и других сведений, например, почтовый штрих-код. Например, если поместить в документ поле слияния «Город», то Word подставит вместо него название «Атланта», хранящееся в поле данных «Город». Для вставки полей слияния выполните следующие действия.
  1. В основном документе щелкните в месте, в которое необходимо вставить поле.
  2. Вставьте одно из следующего.
    • Адресный блок с именем, адресом и другой информацией
      1. Щелкните Блок адреса.
      2. В диалоговом окне Вставка блока адреса выберите элементы адреса, которые необходимо включить, и нужные форматы, затем нажмите OK. Для получения справки по определенному параметру щелкните знак вопроса, затем щелкните параметр.

      3. Для получения справки по определенному параметру щелкните знак вопроса, затем щелкните параметр. Если появилось диалоговое окно Подбор полей, программе Word не удалось найти определенную информацию для блока адреса. Щелкните стрелку около (отсутствует), затем выберите поле в источнике данных, соответствующем полю, необходимому для слияния.
    • Строка приветствия
      1. Щелкните Строка приветствия.
      2. Выберите формат строки приветствия, включающий приветствие, формат имени и следующие знаки препинания.
      3. Выберите текст, который будет отображаться, если программа Word не может определить имя получателя, например, если в источнике данных содержится название компании получателя, но отсутствует его имя или фамилия.
      4. Нажмите кнопку ОК.
      5. Если появилось диалоговое окно Подбор полей, программе Word не удалось найти определенную информацию для строки приветствия. Щелкните стрелку около (отсутствует), затем выберите поле в источнике данных, соответствующем полю, необходимому для слияния.
    • Другие поля с информацией
      1. Щелкните Другие элементы.
      2. Выполните одно из следующих действий.
        • Для выбора полей адресов, которые будут автоматически сопоставляться соответствующими полям в источнике данных, даже если имена полей источника данных не совпадают с именами ваших полей, щелкните «Поля адреса».
        • Для выбора полей, которые всегда напрямую используют данные столбца базы данных, щелкните Поля базы данных.
      3. В поле Поля выберите нужное поле.
      4. Щелкните Вставить, затем — Закрыть.
      5. Если появилось диалоговое окно Подбор полей, программе Word не удалось найти определенную информацию для вставки поля. Щелкните стрелку около (отсутствует), затем выберите поле в источнике данных, соответствующем полю, необходимому для слияния.

        Примечание. При вставке поля из списка Поля базы данных и последующем переключении к источнику данных, в котором отсутствует столбец с таким же именем, Word не сможет вставить информацию этого поля в созданный документ.
    • Почтовая марка

      Для добавления электронной почтовой марки сначала необходимо установить соответствующее программное обеспечение, например, приобретенное у службы в Интернете. Для использования электронной почтовой марки выполните следующие действия.
      1. Щелкните Почтовая марка.

        Если программное обеспечение для работы с электронными почтовыми марками не установлено, появляется запрос на его установку и предложение подключиться к следующему веб-узлу:
        веб-узел Microsoft Office
      2. Вставьте марку в соответствие с инструкциями программы.
    • Для добавления электронной почтовой марки сначала необходимо установить соответствующее программное обеспечение, например, приобретенное у службы в Интернете.

      Почтовый штрих-код

      Необходимо выбрать тип наклейки или конверта с поддержкой штрих-кода POSTNET. Для использования почтового штрих-кода выполните следующие действия.
      1. Щелкните Почтовый штрих-код.
      2. В диалоговом окне Вставка почтового штрих-кода выберите соответствующие поля адреса.

        Примечание. Параметр Почтовый штрих-код отображается только при использовании программы Word на английском языке (США).
      3. Повторите шаги a и b для всех полей, которые необходимо вставить.

        Примечания.
        • В программе Word 2003 и более ранних версиях ввод или вставка символов поля слияния (" ") с помощью команды Символ в меню Вставка невозможны.

          В программе Word 2007 ввод или вставка символов поля слияния (" ") с помощью команды Символ в группе Символ на вкладке Вставить невозможны.
        • Если поля слияния заключены в фигурные скобки, например, { MERGEFIELD City }, программа Word вместо значений отображает коды полей. Это не влияет на слияние, но при необходимости отображения результатов правой кнопкой мыши щелкните кода поля, затем выберите Коды/значения полей в контекстном меню.
    Примечание. В программе Word 2003 и более ранних версиях для вставки полей слияния, работы с основным документом слияния или выполнения слияния также можно использовать панель инструментов слияния. Чтобы отобразить панель инструментов слияния, в меню Сервис выберите Письма и расылки, затем щелкните Показать панель инструментов слияния. На панели инструментов слияния доступны дополнительные команды, отсутствующие в мастере слияния. Например, можно использовать раскрывающееся меню «Вставить поле Word» на панели инструментов слияния для вставки полей Word для управления процессом слияния (например, поле IF, использующееся для вставки текста, если определенное поле слияние имеет указанное значение). Или можно щелкнуть Поиск ошибок для выполнения слияния и создания отчета об ошибках, содержащихся в основном документе.

Изменение формата объединенных данных

Для форматирования объединенных данных необходимо отформатировать поля в основном документе. Не форматируйте данные в источнике данных, поскольку это форматирование не сохраняется при слиянии данных в документе. Для изменения формата объединенных данных выполните следующие действия.
  1. В основном документе выберите поле с информацией, которую необходимо отформатировать, включая символы поля слияния ("" "").
  2. В Word 2003 и более ранних версиях щелкните Шрифт в меню Формат и установите нужные параметры.

    В Word 2007 на вкладке Домашняя страница щелкните Шрифт в группе Шрифт, чтобы открыть диалоговое окно Шрифт, затем установите нужные параметры.

Форматирование с помощью кодов полей

Для доступа к другим параметрам форматирования нажмите ALT+F9, чтобы отобразить коды полей, затем добавьте ключи в поля слияния. В случае полей ключ – это специальная инструкция, вызывающая выполнение определенного действия. В общем смысле, ключ добавляется к полю для изменения результата.

Например.
  1. Для отображения числа "34987,89" как "$34 987,89", добавьте ключ числового формата (\#).
  2. Для печати имен клиентов в верхнем регистре добавьте ключ формата (\*).
  3. Чтобы размер и шрифт объединенной информации совпадали с размером и шрифтом, которые установлены для поля слияния, добавьте ключ \* Charformat.
Для применения формата и структуры первой наклейки для всех остальных наклеек на странице щелкните Обновить все наклейки.

Например, если в примере базы данных, описанной ранее в этой статье, вставить только поле AddressBlock и щелкнуть Обновить все наклейки, страница будет выглядеть следующим образом:

<<AddressBlock>><<Next Record>><<AddressBlock>>

<<Next Record>><<AddressBlock>><<Next Record>><<AddressBlock>>

Шаг 6. Сохранение документа

После завершения работы с основным документом и вставки всех полей слияния перед продолжением необходимо сохранить документ.
  1. В программе Word 2003 и более ранних версиях щелкните Сохранить как в меню Файл.

    В программе Word 2007 нажмите кнопку Microsoft Office и щелкните Сохранить как.
  2. Укажите имя документа и нажмите кнопку Сохранить.
  3. Щелкните Далее. Просмотр наклеек.

Шаг 7. Просмотр наклеек и настройка списка получателей

При появлении области задач «Шаг 5. Слияние» мастера все поля слияния основного документа заменяются текстом первой записи списка получателей, чтобы можно было просмотреть первый выходной документ.

Например, если продолжить использование описанного ранее примера базы данных, после нажатия кнопки Далее. Просмотр наклеек первая страница будет выглядеть следующим образом:
Vice President, Sales Andrew Fuller     Sales Representative Anne Dodsworth
1235 Main St                            1231 Elm St.
Tacoma                                  London
	
	
Sales Representative Janet Leverling     Inside Sales Coordinator Laura Callahan
1235 Elm St.                             1230 Elm St.
Kirkland                                 Seattle
				
Для просмотра остальных элементов выполните одно из следующих действий:
  • Для просмотра элементов по порядку используйте кнопки со стрелками влево и вправо.

    Каждая запись отображается в первой наклейке листа.
  • Для просмотра определенного элемента щелкните Найти получателя, затем в диалоговом окне Поиск элемента введите условие поиска.
Для настройки списка получателя, например, чтобы исключить получателя, выполните следующее.
  1. Щелкните Изменить список получателей и внесите изменения в диалоговом окне Получатели слияния.
  2. Щелкните Далее. Завершение слияния.

Шаг 8. Завершение слияния

Для завершения слияния выполните одно из следующих действий.

Персонализация отдельных наклеек

Для персонализации отдельных наклеек завершите слияние, затем в полученном объединенном документе измените необходимую информацию.
  1. Щелкните Изменить отдельные наклейки.
  2. В диалоговом окне Составные новые документы выберите записи, которые необходимо объединить.
  3. Нажмите кнопку ОК.

    Word создает и открывает новый объединенный документ. Основной документ также остается открытым, в него можно вернуться при необходимости изменения всех элементов.
  4. Найдите информацию, которую необходимо изменить, и внесите изменения.
  5. Напечатайте или сохраните документ так же, как любой другой обычный документ.

Печать листа с наклейками

Чтобы напечатать лист с наклейками, выполните одно из следующих действия.
  • Если элементы персонализированы и объединенный документ является активным.
    1. В программе Word 2003 и более ранних версиях щелкните Печать в меню Файл.

      В программе Word 2007 нажмите кнопку Microsoft Office, выберите Печать и щелкните Печать.
    2. Выберите нужные параметры.
  • При необходимости печати напрямую из мастера слияния.
    1. В шаге 6 мастера слияния (Завершение слияния) щелкните Печать.
    2. В диалоговом окне Составные печатные документы выполните одно из следующих действий и нажмите кнопку OK.
      • Для печати всех документов щелкните все.
      • Для печати документа, отображаемого в окне документа, щелкните текущую запись.
      • Для печати диапазона документов щелкните с и введите номера записей в поля с и до .
    3. В диалоговом окне Печати выберите нужные параметры.

Сохранение листа с наклейками для последующего использования

При необходимости изменения объединенных наклеек и их сохранения для последующего использования наклейки можно вставить в один документ.
  1. Щелкните Изменить отдельные наклейки.
  2. В диалоговом окне Составные новые документы выполните одно из следующих действий и нажмите кнопку OK.
    • Для объединения всех документов щелкните все.
    • Для слияния только документа, отображаемого в окне документа, щелкните текущую запись.
    • Для объединения диапазона документов щелкните с и введите номера записей в поля с и до .
  3. Word открывает новый докмент со всеми отдельным наклейками. Затем можно сохранить документ для последующего использования так же, как любой другой обычный документ.

Ссылки

Для получения дополнительных сведения о полях IF нажмите клавишу F1, чтобы открыть справку Word Help, в поле поиска введите Коды полей: поле IF, нажмите кнопку Поиск и просмотрите найденные разделы.

Для получения дополнительных сведения о полях MERGESEQ, чтобы открыть справку Word Help, в поле поиска введите Коды полей: поле MERGESEQ, нажмите кнопку Поиск и просмотрите найденные разделы.

Для получения дополнительных сведения о поле SET, чтобы открыть справку Word Help, в поле поиска введите Коды полей: поле SET, нажмите кнопку Поиск и просмотрите найденные разделы.

Для получения дополнительных сведений об общих ключах форматирования полей нажмите клавишу F1, чтобы открыть справку Word, в окно поиска введите общие ключи, нажмите кнопку Поиск и просмотрите раздел справки.
294686 Использование слияния для создания списков, отсортированных по категориям, в Word 2002 (Эта ссылка может указывать на содержимое полностью или частично на английском языке)
290408 Вопросы и ответы о слиянии в Word 2002
294688 Разработка и создание списка адресов для слияния в Word 2002 (Эта ссылка может указывать на содержимое полностью или частично на английском языке)
294693 Использование слияния для создания каталога в Word 2002 (Эта ссылка может указывать на содержимое полностью или частично на английском языке)
294683 Как использовать слияние для создания документов на бланках в Microsoft Word 2002

Свойства

Код статьи: 318117 - Последний отзыв: 29 декабря 2007 г. - Revision: 4.2
Информация в данной статье относится к следующим продуктам.
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Office Word 2007
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
Ключевые слова: 
kbhowtomaster kbmerge KB318117

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com