如何使用 Excel 工作表中的地址在 Word 中创建标签

文章翻译 文章翻译
文章编号: 318117 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

概要

利用 Microsoft Word 中的“邮件合并”功能,您便可以使用 Microsoft Excel 工作表中的数据创建和打印标签以进行邮件群发。本文包含了可用于创建此类列表的说明。

当您使用 Word 邮件合并功能时,Word 会将“主文档”与“收件人列表”合并以生成一组“输出文档”:
  • 主文档包含所有输出文档中都具有的相同基本文本。主文档可以在“合并域”中包含信头、文本和说明以便插入文本(例如收件人姓名和地址),插入的文本会随输出文档的不同而有所不同。
  • 收件人列表是一个包含要合并到输出文档中的数据的数据库,例如 Microsoft Access 2002 数据库文件或 Excel 工作簿。此数据库通常是名称、地址和电话号码的列表。
  • 输出文档是邮件合并的结果。在所有输出文档中,输出文档的文本可以是相同的,但是您可以向特定文档应用格式设置。

步骤 1:设置 Excel 数据文件

在进行“邮件合并向导”之前,请确保很好地组织了您的 Excel 工作簿的结构以实现此目的。请注意对数据表的下列要求:
  • 第一行应该包含每一列的域名。例如,“职务”、“称呼”、“名字”、“中间名”、“姓氏”、“地址 1”和“地址 2”。
  • 每个域名必须是唯一的。
  • 每一行必须提供有关特定项的信息。例如,在邮件列表中,每一行可包含有关特定收件人的信息。
  • 表中一定不能包含空行。
要排列 Excel 数据文件,请按照下列步骤操作:
  1. 创建您的 Excel 数据文件,然后使用要用于您的标签的域对该文件进行排列,如下面的数据文件示例所示:

    姓氏 名字 职务 地址 市/县 邮政编码 国家/地区
    Davolio Nancy Sales Representative 1234 Main St. Apt. 2A Seattle 14222 USA
    Fuller Andrew Vice President, Sales 1235 Main St. Tacoma 14222 USA
    Leverling Janet Sales Representative 1235 Elm St. Kirkland 14222 USA
    Peacock Margaret Sales Representative 1236 Main St. Redmond 14222 USA
    Buchanan Steven Sales Manager 1237 Main St London SW2 8MR UK
    Suyama Michael Sales Representative 1238 Elm St. London EC3 7HR UK
    King Robert Sales Representative 1239 Main St. London RK2 9NP UK
    Callahan Laura Inside Sales Coordinator 1230 Elm St. Seattle 14222 USA
    Dodsworth Anne Sales Representative 1231 Elm St. London WG2 7LT UK


  2. 创建了 Excel 数据文件之后,请将其保存,然后关闭该数据文件。
有关如何创建邮件合并地址列表的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
294688 如何在 Word 中设计和设置邮件合并地址列表

步骤 2:设置主文档

  1. 启动 Microsoft Office Word 2003 或早期版本的 Word,指向“工具”菜单上的“信函与邮件”,然后单击“邮件合并向导”。

    启动 Microsoft Office Word 2007,单击“邮件”选项卡,单击“开始邮件合并”组上的“开始邮件合并”,然后单击“邮件合并分步向导”。
  2. 在“选择文档类型”下,单击“标签”。

    活动文档将变为主文档(该文档包含对于每个合并文档的版本都相同的文本和图形,例如套用信函中的寄信人地址或称呼)。
  3. 单击“下一步: 正在启动文档”。

    注意:如果您熟悉邮件合并功能或者您不想使用向导,则可以使用“邮件合并”工具栏。
  4. 执行下列操作之一:
    • 创建一个新的标签页:
      1. 单击“更改文档版式”。
      2. 单击“标签选项”。
      3. 在“标签选项”对话框中,选择所需的选项(例如标签类型和尺寸),然后单击“确定”。

        要获得有关某一选项的帮助,请单击问号,然后单击该选项。
    • 从现有的标签页开始:
      1. 单击“从现有文档开始”。
      2. 在“从现有文档开始”框中,选择所需的文档,然后单击“打开”。
      3. 如果您没有看到所需文档,请单击“其他文件”,然后单击“打开”。在“打开”对话框中,找到所需的文档,然后单击“打开”。

        Word 将在文档窗口中显示该文档。如果您决定改用不同的标签文档,请单击“从现有文档开始”,然后选择一个不同的文档。如果您想更改版式,请单击“更改文档版式”,然后单击“标签选项”。
  5. 单击“下一步: 选择收件人”。

步骤 3:指定 Excel 数据源

  1. 在“选择收件人”下,单击“使用现有列表”。
  2. 单击“浏览”。
  3. 在“选择数据源”对话框中,找到并单击要使用的 Excel 工作表。

    默认情况下,Word 会打开“我的数据源”文件夹。
  4. 单击“打开”。
  5. 如果您的 Excel 工作表在多个选项卡上都具有信息,则必须选择包含所需信息的选项卡,然后单击“确定”。数据源中的所有条目都将显示在“邮件合并收件人”对话框中,您可以在其中细化要包括在合并中的收件人列表。

步骤 4:选择收件人

  1. 在“邮件合并收件人”对话框中,选择要包括的收件人。为此,请执行下列任一操作:
    • 使用复选框指定收件人。

      在列表很小的情况下,此方法最有用。选中要包括的收件人旁边的复选框,同时清除要排除的收件人旁边的复选框。

      注意:如果您确信要在合并中包括列表的大部分,请单击“全选”,然后清除特定记录。类似地,如果您只想包括列表中的少数几个记录,请单击“全部清除”,然后选择所需的记录。
    • 对列表中的项目进行排序。

      如果您想按字母顺序或数字顺序查看项目,这样做非常有用。单击您希望作为排序依据的项目的列标题。例如,如果您想要按姓氏的字母顺序显示列表,请单击“姓氏”列标题。
    • 对列表中的项目进行筛选。

      如果列表包含您确信不希望看到或包含在合并中的记录,则此操作非常有用。在对列表进行筛选之后,您可以使用复选框来包含和排除记录,如上一节中所述。要对列表进行筛选,请按照下列步骤操作:
      1. 单击您希望作为筛选依据的项目的列标题旁边的箭头。
      2. 单击下列任一选项:
        • “(空白)”显示相应域为空的所有记录。
        • “(非空白)”显示相应域包含信息的所有记录。
        • 如果数据源包含共享相同信息的记录,并且在列中只有十个或更少的唯一值,则可以按特定信息进行筛选。例如,如果有多个将“澳大利亚”列为国家/地区的地址,则可以根据“澳大利亚”进行筛选。
    • “邮件合并收件人”对话框只显示指定的记录。要再次显示所有记录,请单击“(全部)”。
    注意
    • 要进行高级排序和筛选,请单击任一列名称旁边的箭头,然后单击“(高级)”。使用“筛选记录”选项卡和“排序记录”选项卡可设置所需的排序或筛选查询。
    • 如果您已经安装了地址验证软件,则可以单击“邮件合并收件人”对话框中的“验证”以验证收件人的地址。
  2. 单击“确定”以返回到“邮件合并向导”。

    Word 将使用您为合并指定的收件人。
  3. 单击“下一步: 排列标签”。

步骤 5:排列标签内容

要排列标签内容,请按照下列步骤操作。

插入合并域

在想合并名称、地址以及其他信息(例如邮政条码)的位置插入合并域。例如,插入合并域“市/县”会指示 Word 插入一个存储在“市/县”数据域中的城市名称(例如“亚特兰大”)。要插入合并域,请按照下列步骤操作:
  1. 在主文档中,单击要插入域的位置。
  2. 插入下列任一选项:
    • 包含名称、地址及其他信息的地址块
      1. 单击“地址块”。
      2. 在“插入地址块”对话框中,选择要包括的地址元素以及所需的格式,然后单击“确定”。要获得有关某一选项的帮助,请单击问号,然后单击该选项。

      3. 要获得有关某一选项的帮助,请单击问号,然后单击该选项。如果显示了“匹配域”对话框,则表示 Word 可能无法找到所需的某些地址块信息。单击“(不可用)”旁边的箭头,然后从对应于邮件合并所需域的数据源中选择域。
    • 问候语
      1. 单击“问候语”。
      2. 选择问候语格式,其中包括称呼、姓名格式以及后面的标点。
      3. 选择在 Word 无法解释收件人的姓名的情况下希望显示的文本。例如,当数据源中不包含收件人的姓氏或名字而只有公司名称时。
      4. 单击“确定”。
      5. 如果显示了“匹配域”对话框,则表示 Word 可能无法找到所需的某些问候语信息。单击“(不可用)”旁边的箭头,然后从对应于邮件合并所需域的数据源中选择域。
    • 其他信息域
      1. 单击“其他项目”。
      2. 执行下列操作之一:
        • 要从将自动映射到数据源中相应域的地址域中进行选择,即使数据源的域名与您的域名不相同,也请单击“地址域”。
        • 要从始终直接从数据库中的某一列获取数据的域中进行选择,请单击“数据库域”。
      3. 在“域”框中,单击所需的域。
      4. 单击“插入”,然后单击“关闭”。
      5. 如果显示了“匹配域”对话框,则表示 Word 可能无法找到插入该域所需的某些信息。单击“(不可用)”旁边的箭头,然后从对应于邮件合并所需域的数据源中选择域。

        注意:如果您插入“数据库域”列表中的一个域,稍后切换到了没有相同名称的列的数据源,则 Word 无法将该域信息插入到合并文档中。
    • 电子邮政 要添加电子邮政,必须首先安装一个电子邮政程序,例如您从万维网服务购买的电子邮政程序。要使用电子邮政,请按照下列步骤操作:
      1. 单击“电子邮政”。

        如果您尚未安装电子邮政程序,Word 将提示您安装一个程序并试图连接到以下 Microsoft 网站:
        Microsoft Office Web
      2. 根据程序的说明插入邮政。
    • 要添加电子邮政,必须首先安装一个电子邮政程序,例如您从万维网服务购买的电子邮政程序。要使用电子邮政,请按照下列步骤操作:邮政条码 您必须选择一个支持 POSTNET 条码的标签或信封类型。要使用邮政条码,请按照下列步骤操作:
      1. 单击“邮政条码”。
      2. 在“插入邮政条码”对话框中,选项相应的地址域。

        注意:仅当您使用美国英语版的 Word 时,才会显示“邮政条码”选项。
      3. 对于要插入的所有域,重复步骤 a 和 b。

        注意
        • 在 Word 2003 和早期版本的 Word 中,无法通过使用“插入”菜单上的“符号”命令来键入合并域字符 (" ") 或插入这些字符。

          在 Word 2007 中,无法通过使用“插入”选项卡上“符号”组中的“符号”命令来键入合并域字符 (" ") 或插入这些字符。
        • 如果合并域出现在大括号内,例如 { MERGEFIELD City },那么 Word 将显示域代码而不是域结果。这样并不会对合并产生影响,但是如果您想要显示结果,请右键单击域代码,然后单击快捷菜单上的“切换域代码”。
    注意:在 Word 2003 和早期版本的 Word 中,还可以使用“邮件合并”工具栏来插入合并域、处理邮件合并主文档或者运行邮件合并。要显示“邮件合并”工具栏,请指向“工具”菜单上的“信函与邮件”,然后单击“显示邮件合并工具栏”。“邮件合并”工具栏提供了“邮件合并向导”任务窗格中没有包括的其他命令。例如,您可以使用“邮件合并”工具栏上的“插入 Word 域”下拉菜单来插入 Word 域以便控制合并进程(例如,仅当特定合并域具有指定值时才插入文本的 IF 域)。或者,您也可以单击“检查错误”以使 Word 运行邮件合并并报告主文档中包含的所有错误。

更改合并数据的格式

要设置合并数据的格式,必须在主文档中设置合并域的格式。请不要在数据源中设置数据格式,这是因为在将数据合并到文档后不会保留其格式。要更改合并数据的格式,请按照下列步骤操作:
  1. 在主文档中,选择包含要设置格式的信息的域,包括它周围的合并域字符 ("" "")。
  2. 在 Word 2003 和早期版本的 Word 中,单击“格式”菜单上的“字体”,然后选择所需的选项。

    在 Word 2007 中,在“开始”选项卡上,单击“字体”组中的“字体”以打开“字体”对话框,然后选择所需的选项。

使用域代码设置格式

要控制格式的其他方面,请按 Alt+F9 以显示域代码,然后向合并域中添加开关。当您处理域时,开关是导致出现特定操作的特殊指令。通常,向域中添加开关可修改结果。

例如:
  1. 要将数字“34987.89”显示为“$34,987.89”,请添加数字图片开关 (\#)。
  2. 要打印大写字母的客户名称,请添加格式开关 (\*)。
  3. 要确保合并信息的字体大小和磅值与应用于合并域的字体大小和磅值相同,请添加 \* Charformat 开关。
要将页面上第一个标签的格式和布局复制到其他所有标签,请单击“更新所有标签”。

例如,在本文前面显示的示例数据库中,如果只插入了 AddressBlock 域,然后单击“更新所有标签”,则该页面应该看起来与下面的内容类似:

<<AddressBlock>><<Next Record>><<AddressBlock>>

<<Next Record>><<AddressBlock>><<Next Record>><<AddressBlock>>

步骤 6:保存文档

在完成主文档并插入所有合并域之后,请保存该文档,然后继续操作。
  1. 在 Word 2003 和早期版本的 Word 中,单击“文件”菜单上的“另存为”。

    在 Word 2007 中,单击“Microsoft Office 按钮”,然后单击“另存为”。
  2. 对文档命名,然后单击“保存”。
  3. 单击“下一步: 预览标签”。

步骤 7:预览标签并微调收件人列表

当向导显示“邮件合并步骤 5”任务窗格时,它会将主文档中的每个合并域都替换为收件人列表第一个条目的实际文本,这样您便可以查看第一个输出文档的外观。

例如,如果您继续使用前面所示的示例数据库,则在单击“下一步: 预览标签”之后,第一页应该看起来与下面的内容类似:
Vice President, Sales Andrew Fuller     Sales Representative Anne Dodsworth
1235 Main St                            1231 Elm St.
Tacoma                                  London
	
	
Sales Representative Janet Leverling     Inside Sales Coordinator Laura Callahan
1235 Elm St.                             1230 Elm St.
Kirkland                                 Seattle
				
要预览其他条目,请执行下列两项操作之一:
  • 要按顺序预览项目,请单击向左或向右箭头按钮。

    在工作表上的第一个标签中预览每个记录。
  • 要找到并预览特定项目,请单击“查找收件人”,然后在“查找条目”对话框中输入搜索条件。
要微调收件人列表,例如排除收件人:
  1. 单击“编辑收件人列表”,然后在“邮件合并收件人”对话框中做出所需的更改。
  2. 单击“下一步: 完成合并”。

步骤 8:完成合并

要完成合并,请执行下列任一操作:

对单个标签进行个性化设置

要对单个标签进行个性化设置,请完成合并,然后在所产生的合并文档中编辑所需的信息。
  1. 单击“编辑单个标签”。
  2. 在“合并到新文档”对话框中,选择要合并的记录。
  3. 单击“确定”。

    Word 将创建并打开一个新的合并文档。您的主文档也保留为打开状态,如果您想要对所有项目进行更改,则可以切换回主文档。
  4. 滚动到要编辑的信息,然后进行更改。
  5. 打印或保存该文档,就像您对任何常规文档所执行的操作一样。

打印标签页

要打印标签页,请执行下列任一操作:
  • 如果您已对项目进行了个性化设置并且合并文档处于活动状态:
    1. 在 Word 2003 和早期版本的 Word 中,单击“文件”菜单上的“打印”。

      在 Word 2007 中,单击“Microsoft Office 按钮”,指向“打印”,然后单击“打印”。
    2. 选择所需的选项。
  • 如果您想要直接从“邮件合并向导”中进行打印:
    1. 在“邮件合并向导”的步骤 6(“完成合并”)中,单击“打印”。
    2. 在“合并到打印机”对话框中,执行下列操作之一,然后单击“确定”:
      • 要打印所有文档,请单击“全部”。
      • 要打印您在文档窗口中看到的文档,请单击“当前记录”。
      • 要打印一定范围的文档,请单击“从”,然后在“从”和“到”框中键入记录号。
    3. 在“打印”对话框中,选择所需的选项。

保存标签页以供以后使用

如果您想要编辑合并的标签或将其保存以供以后使用,则可以将其收集到单个文档中。
  1. 单击“编辑单个标签”。
  2. 在“合并到新文档”对话框中,执行下列操作之一,然后单击“确定”:
    • 要合并所有文档,请单击“全部”。
    • 要只合并您在文档窗口中看到的文档,请单击“当前记录”。
    • 要合并一定范围的文档,请单击“从”,然后在“从”和“到”框中键入记录号。
  3. Word 将打开一个包含所有单个标签的新文档。然后,您可以保存该文档以供以后使用,就像您对任何常规文档所执行的操作一样。

参考

有关 IF 域的更多信息,请按 F1 打开 Word 帮助,在搜索框中键入域代码:IF 域,然后单击“搜索”以查看返回的主题。

有关 MERGESEQ 域的更多信息,请按 F1 打开 Word 帮助,在搜索框中键入域代码:MERGESEQ 域,然后单击“搜索”以查看返回的主题。

有关 SET 域的更多信息,请按 F1 打开 Word 帮助,在搜索框中键入域代码:SET 域,然后单击“搜索”以查看返回的主题。

有关通用的域格式编排开关的更多信息,请按 F1 打开 Word 帮助,在搜索框中键入通用开关,然后单击“搜索”以查看主题。
294686 如何在 Word 中使用邮件合并功能创建按类别排序的列表
290408 关于 Word 2002 中邮件合并的常见问题
294688 如何在 Word 中设计和设置邮件合并地址列表
294693 如何在 Word 中使用邮件合并功能创建目录
294683 如何在 Word 中使用邮件合并功能创建套用信函

属性

文章编号: 318117 - 最后修改: 2007年2月26日 - 修订: 4.1
这篇文章中的信息适用于:
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 标准版
  • Microsoft Office Word 2007
  • Microsoft Office Word 2003
  • Microsoft Word 2002 标准版
关键字:?
kbhowtomaster kbmerge KB318117
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com