CÓMO: Crear en Word 2002 una carta formulario con la información de una hoja de cálculo de Excel 2002

Seleccione idioma Seleccione idioma
Id. de artículo: 318118 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

Este artículo explica cómo usar la característica Combinación de correspondencia de Microsoft Word para crear e imprimir cartas con los datos de una hoja de cálculo de Microsoft Excel.

Cuando usa la característica de combinación de correspondencia de Word 2002, Word combina un documento principal con una lista de destinatarios para generar un conjunto de documentos resultantes:
  • El documento principal contiene el texto básico, que es el mismo en todos los documentos resultantes. Puede contener un membrete, texto e instrucciones de combinación de campos para insertar texto (como nombres y direcciones de destinatario) que varía de un documento resultante a otro.
  • La lista de destinatarios es una base de datos, por ejemplo una base de datos de Microsoft Access 2002 o una hoja de cálculo de Excel 2002, que contiene los datos que se van a combinar en los documentos resultantes. Esta base de datos es habitualmente una lista de nombres, direcciones, números de teléfono y otras categorías de información personal.
  • Los documentos resultantes son el resultado de la combinación de correspondencia. El texto de un documento resultante puede ser el mismo en todos los documentos resultantes, pero puede aplicar formato a documentos específicos.

Paso 1: configurar el archivo de datos de Excel

Antes de proceder con el Asistente para combinar correspondencia, compruebe que la hoja de cálculo de Excel está bien estructurada para este propósito. Tenga en cuenta los siguientes requisitos para la tabla de datos:

  • La primera fila debe contener los nombres de campo de cada columna, por ejemplo Cargo, Salutación, Nombre, Segundo nombre, Apellido, Dirección1 y Dirección2.
  • Cada nombre de campo debe ser único.
  • Cada fila debe proporcionar información acerca de un elemento particular. Por ejemplo, en una lista de correo cada fila puede incluir información acerca de un destinatario particular.
  • La tabla no debe contener filas en blanco.
Cree el archivo de datos de Excel y organícelo después utilizando los campos que quiere usar para la carta, tal como se muestra en el siguiente archivo de datos de ejemplo.

Apellido Nombre Ciudad Dirección Ciudad Código postal País
Davolio Nancy Representante de ventas 507 - 20th Ave. E. Apt. 2A Seattle 98122 EE.UU.
Fuller Andrew Vicepresidente de ventas 908 W. Capital Way Tacoma 98401 EE.UU.
Leverling Janet Representante de ventas 722 Moss Bay Blvd. Kirkland 98033 EE.UU.
Peacock Margaret Representante de ventas 4110 Old Redmond Rd. Redmond 98052 EE.UU.
Buchanan Steven Director de ventas 14 Garrett Hill Londres SW1 8JR Reino Unido
Suyama Michael Representante de ventas Coventry House Miner Rd. Londres EC2 7JR Reino Unido
King Robert Representante de ventas Edgeham Hollow Winchester Way Londres RG1 9SP Reino Unido
Callahan Laura Coordinador de ventas internas 4726 - 11th Ave. N.E. Seattle 98105 EE.UU.
Dodsworth Anne Representante de ventas 7 Houndstooth Rd. Londres WG2 7LT Reino Unido


Después de crear el archivo de datos de Excel, guárdelo y después cierre el archivo de datos.

Para obtener información adicional acerca de cómo crear una lista de filtros de direcciones de combinar correspondencia, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
294688 WD2002: HOW TO: Design and Set Up a Mail Merge Address List in Word 2002

Paso 2: configurar el documento principal

  1. Inicie Word 2002, seleccione Cartas y correspondencia en el menú Herramientas y haga clic en Asistente para combinar correspondencia.
  2. Bajo Seleccione el tipo de documento, haga clic en Cartas.

    El documento activo se convierte en el documento principal (el documento que contiene el texto y los gráficos que son los mismos para cada versión del documento combinado, por ejemplo el remite o el saludo de una carta modelo).
  3. Haga clic en Siguiente: inicie el documento.
  4. Siga uno de estos procedimientos:
    • Comenzar con el documento mostrado en la ventana. Para ello, haga clic en Utilice el documento actual.

      Puede escribir la carta en la ventana del documento o esperar a que el asistente le pida hacerlo en un paso posterior.
    • Comenzar con una plantilla:
      1. Haga clic en Comenzar con una plantilla.
      2. Haga clic en Seleccionar plantilla.
      3. En la ficha Combinar correspondencia, seleccione la plantilla que desea en el cuadro de diálogo Seleccionar plantilla y después haga clic en Aceptar.
    • Empezar a partir de un documento existente:
      1. Haga clic en Empezar a partir de un documento existente.
      2. En el cuadro Empiece a partir de un documento existente, seleccione el documento que desea y haga clic en Abrir.
      3. Si no ve el documento, haga clic en Más archivos y, a continuación, en Abrir. En el cuadro de diálogo Abrir, busque el documento que desea y haga clic en Abrir.
  5. Haga clic en Siguiente: seleccionar los destinatarios.

Paso 3: especificar el origen de datos Excel

  1. En Seleccionar los destinatarios, haga clic en Utilizar una lista existente.
  2. Haga clic en Examinar.
  3. En el cuadro de diálogo Seleccionar archivos de origen de datos, busque la hoja de cálculo de Excel que quiere usar y haga clic en ella.

    De manera predeterminada, Word abre la carpeta Mis archivos de origen de datos.
  4. Haga clic en Abrir.
  5. Si la hoja de cálculo de Excel contiene información en varias fichas, debe seleccionar la que contiene la información que desea y hacer clic en Aceptar.
  6. Todas las entradas de los orígenes de datos aparecen en el cuadro de diálogo Destinatarios de combinar correspondencia, donde puede reajustar la lista de destinatarios a incluir en la combinación.

Paso 4: seleccionar los destinatarios

  1. En el cuadro de diálogo Destinatarios de combinar correspondencia, seleccione los destinatarios que desea incluir. Para ello, utilice cualquiera de los métodos siguientes:
    • Utilizar las casillas de verificación para designar los destinatarios.

      Es el método más útil si la lista es breve. Haga clic para seleccionar las casillas de verificación situadas junto a los destinatarios que desea incluir y haga clic para anular la selección de los destinatarios que quiere excluir.

      NOTA: si en la combinación de correspondencia quiere incluir casi toda la lista, haga clic en Seleccionar todos y anule la selección de los que desea excluir. Similarmente, si sólo quiere incluir algunos registros, haga clic en Eliminar todos y seleccione después los registros que quiere.
    • Ordenar elementos de la lista.

      Este método es útil si quiere ver los elementos en orden alfabético o numérico. Haga clic en el encabezado de columna del elemento que quiere usar para ordenar. Por ejemplo, si quiere mostrar la lista alfabéticamente por el apellido, haga clic en el encabezado de columna Apellidos.
    • Filtrar elementos de la lista.

      Este método es útil si la lista contiene registros que sabe que no quiere ver o incluir en la combinación. Después de haber filtrado la lista, puede usar las casillas de verificación para incluir y excluir registros tal como se describió antes. Para filtrar la lista, siga estos pasos:
      1. Haga clic en la flecha ubicada junto al encabezado de columna del elemento por el que quiere filtrar.
      2. Haga clic en cualquiera de los elementos siguientes:
        • (Vacíos): muestra todos los registros en los que el campo correspondiente está vacío.
        • (No vacíos): muestra todos los registros en los que el campo correspondiente contiene información.
        • Si los orígenes de datos contienen registros que comparten la misma información, y hay diez o menos valores únicos en la columna, puede filtrar por informaciones específicas. Por ejemplo, si hay varias direcciones que tienen Australia como país o región, puede filtrar por Australia.
    • El cuadro de diálogo Destinatarios de combinar correspondencia sólo muestra los registros designados. Para mostrar de nuevo todos los registros, haga clic en (Todos).
    NOTAS:
    • Para la ordenación y filtrado avanzados, haga clic en la flecha situada junto a cualquier nombre de columna y luego haga clic en (Avanzado). Usar las fichas Filtrar registros y Ordenar registros para configurar la ordenación o filtrado de la consulta que desea.
    • Si instaló el software de validación de software, puede hacer clic en Validar en el cuadro de diálogo Destinatarios de combinar correspondencia para validar las direcciones de destinatarios.
  2. : Haga clic en Aceptar para volver al Asistente para combinar correspondencia.

    Word usa los destinatarios que designó para la combinación.
  3. : Haga clic en Siguiente: escriba la carta.

Paso 5: terminar la carta y agregar campos de combinación

Si todavía no lo ha hecho en el documento principal, escriba el texto que quiere que aparezca en toda carta modelo.

Insertar campos de combinación

Insertar los campos de combinación donde quiere combinar nombres, direcciones y otras informaciones desde el origen de datos. Para insertar campos de combinación, siga estos pasos:
  1. En el documento principal, haga clic donde desea insertar el campo.
  2. Inserte cualquiera de los campos siguientes:
    • Bloque de direcciones con nombre, dirección y otras informaciones:
      1. Haga clic en Bloque de direcciones.
      2. En el cuadro de diálogo Insertar bloque de direcciones, seleccione los elementos de dirección que quiere incluir y los formatos que desea y después haga clic en Aceptar. Para obtener ayuda para una opción, haga clic en el signo de interrogación y, después, en la opción.

      3. Para obtener ayuda para una opción, haga clic en el signo de interrogación y, después, en la opción. Si aparece el cuadro de diálogo Asignar campos, es posible que Word no haya podido encontrar alguna información que necesita para el bloque de direcciones. Haga clic en la flecha que hay junto a (no disponible) y seleccione después el campo de su origen de datos que corresponde al campo requerido para combinar correspondencia.
    • Línea de saludo:
      1. Haga clic en Línea de saludo.
      2. Seleccione el formato de la línea de saludo, que incluye el saludo, el formato de nombre y la siguiente puntuación.
      3. Seleccione el texto que quiere que aparezca en los casos en los que Word no puede interpretar el nombre del destinatario, por ejemplo, cuando el origen de datos no contiene nombre o apellido del destinatario, si no sólo el nombre de la compañía.
      4. Haga clic en Aceptar.
      5. Si aparece el cuadro de diálogo Asignar campos, es posible que Word no haya podido encontrar alguna información que necesita para la línea de saludo. Haga clic en la flecha que hay junto a (no disponible) y seleccione después el campo de su origen de datos que corresponde al campo requerido para combinar correspondencia.
    • Otros campos de información:
      1. Haga clic en Más elementos.
      2. Siga uno de estos procedimientos:
        • Para seleccionar desde campos de dirección que automáticamente asignarán a los campos correspondientes de su origen de datos, incluso aunque los campos de origen de datos no tienen el mismo nombre que sus campos, haga clic en Campos de dirección.
        • Para seleccionar de campos que toman siempre los datos directamente desde una columna de la base de datos, haga clic en Campos de base de datos.
      3. En el cuadro Campos, haga clic en el campo que desea.
      4. Haga clic en Insertar y, a continuación, en Cerrar.
      5. Si aparece el cuadro de diálogo Asignar campos, es posible que Word no pueda encontrar alguna información que necesita para insertar el campo. Haga clic en la flecha que hay junto a (no disponible) y seleccione después el campo de su origen de datos que corresponde al campo requerido para combinar correspondencia.

        NOTA: si inserta un campo desde la lista Campos de base de datos y después cambia a un origen de datos que no tiene una columna con ese nombre, Word no puede insertar la información de ese campo en el documento combinado.
    • Franqueo electrónico: para agregar franqueo electrónico, primero debe instalar un programa de franqueo electrónico, que puede comprar en el Web a otro proveedor. Para usar el franqueo electrónico, siga estos pasos:

      1. Haga clic en Franqueo electrónico.

        Si tiene instalado un programa de franqueo electrónico, Word le pedirá que instale uno y le ofrecerá la conexión con el siguiente sitio Web de Microsoft Office:
        Print Online Postage
        http://office.microsoft.com/services/service.aspx?sid=2.4
      2. Insertar el franqueo de acuerdo con las instrucciones del programa.
    • Para agregar franqueo electrónico, primero debe instalar un programa de franqueo electrónico, que puede comprar en el Web a otro proveedor. Para usar el franqueo electrónico, siga estos pasos: Postal bar code: debe seleccionar un tipo de carta o sobre que admita el código de barras POSTNET. Para usar el código de barras postal, siga estos pasos:

      1. Haga clic en Postal bar code.
      2. En el cuadro de diálogo Insert Postal Bar Code, seleccione los campos de dirección apropiados.

        NOTA: la opción Postal bar code sólo aparece si usa la versión de inglés EE.UU. de Word.
      3. Repita los pasos a y b en todos los campos que quiere insertar. NOTAS:
        • No puede escribir en los campos de combinación los caracteres (" ") ni insertarlos mediante el comando Símbolo del menú Insertar.
        • Si los campos de combinación aparecen dentro de llaves, como { MERGEFIELD City }, Word muestra códigos de campo en lugar de resultados de campo. Esto no afecta a la combinación, pero si quiere mostrar los resultados haga clic con el botón secundario del mouse (ratón) y, después, haga clic en Activar o desactivar códigos de campo en el menú contextual.
      Por ejemplo, usando la base de datos de ejemplo mostrada anteriormente, su carta podría contener los campos AddressBlock y GreetingLine, con lo que su primera página tendría un aspecto similar al siguiente:
      26 de febrero de 2002

      AddressBlock

      GreetingLine

      Escriba aquí la carta.

      Atentamente,

      Escriba aquí su nombre

    NOTA: también puede usar la barra de herramientas Combinar correspondencia para insertar campos de combinación, trabajar con el documento principal de la combinación de correspondencia o ejecutar una combinación de correspondencia. Para mostrar la barra de herramientas Combinar correspondencia, en el menú Herramientas seleccione Cartas y correspondencia y, a continuación, haga clic en Mostrar barra de herramientas Combinar correspondencia. La barra de herramientas Combinar correspondencia proporciona comandos adicionales no incluidos en los paneles de tareas del Asistente para combinar correspondencia. Por ejemplo, puede usar el menú desplegable Insertar campo de Word en la barra de herramientas Combinar correspondencia para insertar campos de Word con el objetivo de controlar el proceso de combinación (por ejemplo, un campo IF que inserta texto sólo si un campo de combinación particular tiene un valor especificado). O bien, puede hacer clic en Revisar errores para que Word ejecute la combinación de correspondencia e informe de cualquier error contenido en el documento principal.

Cambiar el formato de los datos combinados

Para dar formato a los datos combinados, debe dar formato a los campos de combinación en el documento principal. No dé formato a los datos en el origen de datos, porque ese formato no se conserva cuando combina los datos en el documento. Para cambiar el formato de los datos combinados, siga estos pasos:
  1. En el documento principal, seleccione el campo que contiene la información a la que quiere dar formato, incluyendo los caracteres (<< >>) que rodean el campo de combinación.
  2. En el menú Formato, haga clic en Fuente y seleccione después las opciones que desea.

Dar formato con códigos de campo

Para controlar otros aspectos del formato, presione ALT+F9 para mostrar códigos de campo y agregue modificadores a los campos de combinación. Al trabajar con campos, un modificador es una instrucción especial que hace que se produzca una acción específica. Generalmente, un modificador se agrega a un campo para modificar un resultado.

Por ejemplo:
  1. Para mostrar el número 34987.89 como $34,987.89, agregue el modificador de imagen de número (\#).
  2. Para imprimir nombres de cliente en mayúsculas, agregue el modificador de formato (\*).
  3. Para garantizar que la información combinada tiene la misma fuente y tamaño que aplicó al campo combinado, agregue el modificador de formato de caracteres (\*).

Paso 6: guardar el documento

Después de haber completado el documento principal e insertado todos los campos de combinación, compruebe que ha guardado el documento antes de proseguir:
  1. Haga clic en Guardar como en el menú Archivo.
  2. Asigne nombre al documento y haga clic en Guardar.
  3. Haga clic en Siguiente: obtenga una vista previa de las cartas.

Paso 7: obtener una vista previa de las cartas y refinar la lista de destinatarios

Cuando el asistente muestra el panel de tareas Combinar correspondencia del paso 5, sustituye cada uno de los campos de combinación del documento principal por el texto actual desde la primera entrada de la lista de destinatarios, por lo que puede ver el aspecto que tendrá el primer documento resultante.

Por ejemplo, si fuera a seguir usando la base de datos de ejemplo mostrada antes, la primera página debería tener un aspecto similar al siguiente después de hacer clic en Siguiente: obtenga una vista previa de las cartas:
26 de febrero de 2002

Andrew Fuller
908 W. Capital Way
Tacoma 98401

Estimado Andrew Fuller:

Escriba aquí la carta.

Atentamente,

Escriba aquí su nombre
Para obtener una vista previa adicional, realice una de las siguientes acciones:
  • Para obtener una vista previa de los elementos en orden, haga clic en los botones de flecha izquierda o derecha.
  • Para buscar un elemento específico y obtener de él una vista previa, haga clic en Buscar un destinatario e introduzca los criterios de búsqueda en el cuadro de diálogo Buscar entrada.
Refinar la lista de destinatarios si lo desea. Para ello, utilice uno de los métodos siguientes:
  • Para excluir un destinatario particular desde la operación de combinación, haga clic en Excluir al destinatario.
  • Para cambiar la lista de destinatarios, haga clic en Modificar la lista de destinatarios y realice luego los cambios en el cuadro de diálogo Destinatarios de combinar correspondencia.

Paso 8: completar la combinación

Para completar la combinación, siga uno de estos procedimientos.

Personalizar cartas individuales

Para personalizar elementos individuales, complete la combinación y modifique la información que desea en el documento combinado resultante. Para ello, siga estos pasos:
  1. Haga clic en Editar cartas individuales.
  2. En el cuadro de diálogo Combinar en un documento nuevo, seleccione los registros que desea combinar.
  3. Haga clic en Aceptar.

    Word crea y abre un nuevo documento combinado. El documento principal también permanece abierto y puede volver a él si quiere realizar algún cambio en todos los documentos.
  4. Despliegue la información que desea modificar y realice los cambios.
  5. Imprimir o guardar el documento tal como haría con cualquier documento normal.

Imprimir las cartas

Para imprimir las cartas, realice uno de los procedimientos siguientes:
  • Si personalizó los elementos y el documento combinado está activo:
    1. En el menú Archivo, haga clic en Imprimir.
    2. Seleccione las opciones que desee utilizar.
  • Si desea imprimir directamente desde el Asistente para combinar correspondencia:
    1. En el paso 6 del Asistente para combinar correspondencia (Completar la combinación), haga clic en Imprimir.
    2. En el cuadro de diálogo Combinar al imprimir, haga clic en una de las opciones siguientes y, después, haga clic en Siguiente:
      • Para imprimir todos los documentos, haga clic en Todos.
      • Para imprimir el documento que ve en la ventana de documentos, haga clic en Registro actual.
      • Para imprimir un intervalo de documentos, haga clic en De y escriba los números de registro en los cuadros De y A .
    3. En el cuadro de diálogo Imprimir, elija las opciones que desee.

Guardar las cartas combinadas para uso posterior

Si quiere modificar las cartas combinadas o guardarlas para uso posterior, puede reunirlas en un solo documento.
  1. Haga clic en Editar cartas individuales.
  2. En el cuadro de diálogo Combinar en un documento nuevo, haga clic en una de las opciones siguientes y, después, haga clic en Aceptar:
    • Para combinar todos los documentos, haga clic en Todos.
    • Para combinar sólo el documento que ve en la ventana de documentos, haga clic en Registro actual.
    • Para combinar un intervalo de documentos, haga clic en De y escriba los números de registro en los cuadros De y A .
  3. Word abre un único documento nuevo que contiene todas las cartas individuales. Después puede guardar el documento para uso posterior, como haría con cualquier documento normal.

REFERENCIAS

Para obtener más información acerca de los campos IF, haga clic en Ayuda de Microsoft Word en el menú Ayuda, escriba Códigos de campo: campo IF en el Ayudante de Office o en el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver los temas devueltos.

Para obtener más información acerca de los campos MERGESEQ, haga clic en Ayuda de Microsoft Word en el menú Ayuda, escriba Códigos de campo: campo MERGESEQ en el Ayudante de Office o en el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver los temas devueltos.

Para obtener más información acerca del campo SET, haga clic en Ayuda de Microsoft Word en el menú Ayuda, escriba Códigos de campo: campo SET en el Ayudante de Office o en el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver los temas devueltos.

Para obtener más información acerca de los modificadores de campo generales, haga clic en Ayuda de Microsoft Word en el menú Ayuda, escriba modificadores generales en el Ayudante de Office o el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver el tema.

318117 HOW TO: Utilizar en Word 2002 las direcciones de una hoja de cálculo de Excel 2002 para crear etiquetas
318115 HOW TO: Create a Form Letter by Using Information from an Access Database in Word 2002
318112 CÓMO: Utilizar en Word 2002 las direcciones de una base de datos de Access 2002 para crear etiquetas
294686 WD2002: Cómo utilizar Combinar correspondencia para crear una lista ordenada por categoría
290408 WD2002: Preguntas más frecuentes acerca de Combinar correspondencia
294688 HOW TO: Design and Set Up a Mail Merge Address List in Word 2002
294693 WD2002: How to Use Mail Merge to Create a Directory
294683 HOW TO: Use Mail Merge to Create Form Letters in Word 2002

Propiedades

Id. de artículo: 318118 - Última revisión: jueves, 20 de septiembre de 2007 - Versión: 2.4
La información de este artículo se refiere a:
  • Microsoft Word 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
Palabras clave: 
kbhowtomaster kbdownload kbmerge KB318118

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com