Error message when you use the Find, Route Planner, or Data-Import feature or you try to add map pushpins in AutoRoute, MapPoint, or Streets & Trips

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Article ID: 318251 - View products that this article applies to.
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SYMPTOMS

When you try to use the Find feature, the Route Planner feature, or the Data-Import feature in any of the products that are listed in the "Applies to" section, you receive an error message that resembles one of the following error messages:
Streets and Trips has encountered a problem and needs to close. Application unable to continue running due to an internal error (6-40028--1073741819)
When you view the details of the error message, you see an error signature that resembles the following:

AppName AppVer ModName ModVer Offset 
-------------------------------------------------------------- 
Streets.exe 9.0.16.2001 Streets.exe 6.0.8397.0 000212fa 

Microsoft MapPoint has encountered a problem and needs to close. We are sorry for the inconvenience.

When you view the details of the error message, you receive an error signature that resembles the following:
AppName AppVer ModName ModVer Offset 
-------------------------------------------------------------- 
Mappoint.exe 9.0.16.2001 Mappoint.exe 9.0.16.2001 000212fa

Microsoft Streets & Trips has encountered a problem and needs to close. We are sorry for the inconvenience.

When you view the details of the error message, you receive an error signature that resembles the following:
AppName AppVer ModName ModVer Offset ------------------------------------------------------------ Streets.exe 9.0.16.2001 Streets.exe 9.0.16.2001 000212fa 
This application is unable to continue running. The problem may be the result of low system resources such as memory or disk space. Try closing down other applications, increasing the amount of file space on the disk drive that contains Windows, or adding more memory.

When you try to add pushpins to a map, you may receive an error message that resembles the following:
Streets & Trips 2002 has encountered a problem and needs to close.
Application unable to continue running due to an internal error (6-40028-529697949).

CAUSE

This problem may occur if one or more of the following conditions are true:
  • There is a damaged map file in the program.
  • A background program is interfering with the application.
  • Printer hardware drivers have been installed incorrectly or have become corrupted.

RESOLUTION

Method 1: Test whether the file is corrupted

If you are working with an old map file, the file may be corrupted. To determine whether the file is corrupted, create a new map file. If you receive no error messages when you use a new map file, this indicates that the original map file is corrupted. In this case, you must copy the pushpins set under the Legend & Overview menu, and then paste it into a new map file.

To copy the pushpins set, follow these steps:
  1. Open the corrupted map file.
  2. Under the File menu, click Legend & Overview.
  3. Under Legend & Overview, right-click the pushpin set that you want to copy, and then click Copy.
  4. Open the new map.
  5. Click Edit, and then click Paste.
  6. Repeat steps 1 through 5 for all the pushpin sets that you want to copy to the new map.

Method 2: Install Access Database Engine

Note Exit all applications before you access the product DVD.

2008 and earlier versions of the programs do not contain the AccessDatabaseEngine.exe file. If you have one of these versions, install the Access Database Engine from the website that follows these steps.

Earlier versions:
  1. Insert the Streets & Trips or MapPoint DVD in the DVD drive.
  2. Click Start, click My Computer, and then browse to the following location (as appropriate for your program):
    <drive>:\MapPoint\MSMap\Redist\ADE
    <drive> :\ Streets\MSMap\Redist\ADE

    Note In these paths, <drive> is the disc drive that contains the product installation DVD.
  3. Double-click AccessDatabaseEngine.exe, and then follow the instructions on your screen. Restart the computer if you are if prompted.
2008 and later versions:

Or, to access an online installation point for Access Database Engine, visit the following Microsoft website:
http://www.microsoft.com/downloads/details.aspx?FamilyID=7554f536-8c28-4598-9b72-ef94e038c891&DisplayLang=en

Method 3: Install a printer driver

To determine whether a printer driver is causing this problem, install a new default printer driver for the computer. To install a new printer driver, follow the steps for your operating system.

Windows Vista:
  1. Close all programs that might be using the printer driver.
  2. Click Start
    Collapse this imageExpand this image
     Start button
    , type printers in the Start Search box, and then click printers in the Programs list.
  3. Right-click the printer, point to Run as administrator, and then click Properties.

    Collapse this imageExpand this image
    User Account Control permission
    If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
  4. Click the Advanced tab.
  5. Click New Driver.
  6. Follow the steps in the Add Printer Driver Wizard to add a different printer driver.

Windows XP:
  1. Click Start, and then click Printers and Faxes.
  2. Click Add a Printer. The Add Printer Wizard starts.
  3. Follow the steps in the Add Printer Wizard to add a different printer driver.
After you install the new printer driver, start the program, and open the map. If you do not receive the error messages that are listed in the "Symptoms" section, download and install a new version of the original printer driver. Contact the manufacturer of your printer to ask about how to obtain and install the latest version of the printer driver for your printer.

Method 4: Start the computer in safe mode

  1. Restart the computer.

    Note If the computer is configured to use multiple operating systems, use the arrow keys to select the operating system that you want to use, and then press Enter.
  2. When you see the startup menu, press F8.
  3. Use the arrow keys to select the safe mode option, and then press Enter.

    Note Num Lock must be turned off for the arrow keys to work on the numeric keypad.
Determine whether the program is working without errors. If it does, go to Method 4. Otherwise go to Method 6 for Windows XP or to Method 4 for Windows Vista.

Method 5: Restart the computer by using a clean restart procedure, and then empty the temporary files folder

Windows Vista
Note You may experience a temporary loss of some services functionality when you follow these steps. Restoring the settings restores the functionality. However, when you restore the functionality, you may receive the original error message or experience the original behavior again.

Note If the computer is connected to a network, network policy settings may prevent you from following these steps. We strongly recommend that you do not use the System Configuration utility to modify the advanced boot options on the computer unless a Microsoft support engineer directs you to do this. Doing this may make the computer unusable.
  1. Log on to the computer by using an account that has administrator rights.
  2. Click Start
    Collapse this imageExpand this image
    Start button
    , type msconfig.exe in the Start Search box, and then press Enter to start the System Configuration Utility.

    Collapse this imageExpand this image
    User Account Control permission
    If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
  3. On the General tab, click Selective Startup, and then click to clear the Load startup items check box. (The Use Original Boot.ini check box is unavailable.)
  4. On the Services tab, click to select the Hide all Microsoft services check box, and then click Disable all.

    Note This step lets Microsoft services continue to run. These services include Networking, Plug and Play, Event Logging, Error Reporting, and other services. If you disable these services, you may permanently delete all restore points. Do not do this if you want to use the System Restore utility together with existing restore points.
  5. Click OK, and then click Restart.
Windows XP
  1. Click Start, click Run, type msconfig, and then click OK.

    Note The System Configuration Utility dialog box is displayed.
  2. In the System Configuration Utility dialog box, click the General tab, and then click Selective Startup.
  3. Click to clear the Process SYSTEM.INI File check box.
  4. Click to clear the Process WIN.INI File check box.
  5. Click to clear the Load Startup Items check box.
  6. Click the Services tab.
  7. Click to select the Hide All Microsoft Services check box.
  8. Click Disable All, and then click the General tab.
  9. Click to clear the Load System Services check box, and then click OK.

    Note This step temporarily disables Microsoft features such as Plug and Play, networking, event logging, and error reporting. Also, this step permanently removes the restore points from the computer. The System Restore feature uses restore points to restore your computer to an earlier state. If you remove the restore points, you can no longer restore Windows to an earlier state.
  10. When you are prompted, click Restart to restart the computer.
  11. Log on to Windows.
  12. When you receive the following message, click to select the Don't show this message or launch the System Configuration Utility when Windows start check box, and then click OK:
    You have used the System Configuration Utility to make changes to the way Windows starts.

    The System Configuration Utility is currently in Diagnostic or Selective Startup mode, causing this message to be displayed and the utility to run every time Windows starts.

    Choose the Normal Startup mode on the General tab to start Windows normally and undo the changes you made using the System Configuration Utility.
Determine whether the program is working without errors. If it works, the issue is related to hardware drivers such as printer drivers go to Method 4.

However, if Street & Trips does not work, follow the troubleshooting steps in the following Knowledge Base article:
331796 How to perform a clean boot procedure to prevent background programs from interfering with a game or a program that you currently use

If the problem is not resolved and you want to return to normal mode, follow these steps.


Restart Windows Vista in normal mode
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , type msconfig.exe in the Start Search box, and then press Enter.

    Collapse this imageExpand this image
    User Access Control permission
    If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
  2. On the General tab, click the Normal Startup option, and then click OK.
  3. When you are prompted to restart the computer, click Restart.
Restart Windows XP in normal mode
  1. Click Start, click Run, type msconfig, and then click OK.

    The System Configuration Utility dialog box appears.
  2. Click the General tab, click Normal Startup - load all device drivers and services, and then click OK.
  3. When you are prompted, click Restart to restart the computer.

Method 6: Install Visual C++ 2005 & 2008

  1. To install Visual C++ 2005, visit the following Microsoft website:
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=32bc1bee-a3f9-4c13-9c99-220b62a191ee
  2. Click Download & Save the file on Desktop.
  3. Run the file to install Visual C++ 2005.
  4. To install Visual C++ 2008, visit the following Microsoft website:
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=9b2da534-3e03-4391-8a4d-074b9f2bc1bf
  5. Click Download & Save the file on Desktop.
  6. Run the file to install Visual C++ 2008.

Method 7: Create a new user account

Follow the steps for your version of Windows.

Windows 7 or Windows Vista

Step 1: Open User Accounts.
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , type Control nusrmgr.cpl in the Start Search box, and then press Enter.
  2. Click User Accounts.

    Collapse this imageExpand this image
    User Access Control permission
    If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
Step 2: Add a new user.
  1. On the Users tab, click Add.
  2. Type a name for your user account, type your full name, and then type a description for your account.
  3. If the computer is set up as part of a client/server network, type the domain name, and then click Next.

    Note If the computer is set up as an individual computer without a network or in a peer-to-peer network, you do not have to provide a domain name.
  4. Type a user password, and then type the user password again to confirm it.

    Important Passwords are case-sensitive. For example, “MyPassword” and “mypassword” are treated as different passwords.
  5. Click Next.
  6. Select the level of access for your user account, and then click Finish.

Note Some games require a user account that has administrator-level access to run.

Windows XP Home Edition
  1. Click Start, click Control Panel, and then click User Accounts.
  2. On the Pick a task list, click Create a new account.
  3. Type the name that you want to use for the account, and then click Next.
  4. Select the account type that you want, and then click Create Account.

Note To run, some games require a user account that uses the administrator account type.


Properties

Article ID: 318251 - Last Review: March 4, 2011 - Revision: 4.0
APPLIES TO
  • Microsoft AutoRoute 2007
  • Microsoft MapPoint 2009 North America
  • Microsoft MapPoint 2009 North America with GPS Locator
  • Microsoft MapPoint 2006 Standard Edition
  • Microsoft MapPoint 2004 Standard Edition
  • Microsoft Streets & Trips 2009
  • Microsoft Streets & Trips 2009 with GPS Locator
  • Microsoft Streets & Trips 2008
  • Microsoft Streets & Trips 2008 with Connected Services
  • Microsoft Streets & Trips 2008 with GPS Locator
  • Microsoft Streets & Trips 2007
  • Microsoft Streets & Trips 2007 with GPS Locator
  • Microsoft Streets & Trips 2006
Keywords: 
kberrmsg kbprb KB318251

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