Article ID: 318319 - Last Review: June 14, 2007 - Revision: 2.4 Access Violations Occur in the Web Proxy Service If an Impersonation Failure Occurs
This article was previously published under Q318319 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986
(http://support.microsoft.com/kb/256986/EN-US/
)
Description of the Microsoft Windows Registry
SYMPTOMS
When users try to access resources in an outgoing Web Proxy or in a Web Publishing scenario, the Web Proxy service may generate an access violation error and stop responding if Proxy authentication is required globally, if Ask unauthenticated users for identification is enabled on the Outgoing Web Requests tab for the properties of the server, or if it is enabled specifically by access rules. Typically, the access violation error occurs only for users that are not a local administrator on the computer that is running Internet Server and Acceleration (ISA) Server. If local administrators try to access resources through the Web Proxy service, requests are served without any issues.
CAUSE
The access violation is a consequence of an impersonation failure that occurs of the user that is trying to access resources through the Web Proxy service. The impersonation failure of the user may occur if the CrashOnAuditFail registry value is set to a value of 0x2.
RESOLUTION
The installation of ISA 2000 Service Pack 1 is required prior to applying the following fix. For additional information about how to obtain Service Pack 1, click the article number below to view the article in the Microsoft Knowledge Base: 313139
(http://support.microsoft.com/kb/313139/EN-US/
)
How to Obtain the Latest Internet Security and Acceleration Server 2000 Service Pack
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: http://support.microsoft.com/contactus/?ws=support
(http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this fix should have the following file attributes or later:Date Time Version Size File name ------------------------------------------------------ 27-Mar-2002 14:10 3.0.1200.170 383,760 W3proxy.exe After installing this fix, this access violation should no longer occur; however, the impersonation failure may still occur and errors that are similar to the following ones may be displayed in the browser of the authenticating user: For a Web Proxy request:
HTTP 502 Proxy Error - The operation completed successfully. (0)
Internet Security and Acceleration Server
500 Internal Server Error - The operation completed successfully. (0)
Internet Security and Acceleration Server
The CrashOnAuditFail registry value is a security measure in the operating system. If this registry value is set to 0x1 (the default value is 0x0), it crashes the operating system if the system fails to write to the Security event log. Typically this happens if the Security event log is full and it does not allow itself to be overwritten. Before it crashes the operating system, it also changes the value of the CrashOnAuditFail registry value from 0x1 to 0x2 and when the value is set to 0x2, only local administrators can log on to the system. This behavior occurs so that administrators can store and clear the Security event log so that new, auditable actions can be recorded before any users can re-access the system. In addition, the administrator needs to manually reset the CrashOnAuditFail registry value to the original value. WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. To resolve the impersonation failure, manually reset the CrashOnAuditFail registry value:
To disable the CrashOnAuditFail security feature, change the CrashOnAuditFail registry value to 0x0 (the default value), and then restart the computer; however, Domain Policies, a Local Security Policy or security templates can reset the CrashOnAuditFail feature, so continue to monitor the system. For additional information about the CrashOnAuditFail registry value, click the article numbers below to view the articles in the Microsoft Knowledge Base: 140058
(http://support.microsoft.com/kb/140058/EN-US/
)
How To Prevent Auditable Activities When Security Log Is Full
178208
(http://support.microsoft.com/kb/178208/EN-US/
)
CrashOnAuditFail with Logon/Logoff Auditing Causes Blue Screen
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. MORE INFORMATION
If the Logon Auditing feature is enabled, you may see events that are similar to the following one in the Security event log as long as the log is not full:
Security Event 533: Logon Failure: Reason: User not allowed to logon at this computer User Name: username Domain: domainname Logon Type: 3 Logon Process: NtLmSsp Authentication Package: NTLM Workstation Name: computername
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