An event ID 1005 error message is logged, and Microsoft Exchange System Attendant does not respond

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Article ID: 318431 - View products that this article applies to.
This article was previously published under Q318431
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SYMPTOMS

In Microsoft Exchange server, you may experience the following symptoms:
  • The Microsoft Exchange System Attendant stops responding.
  • The Microsoft Exchange System Attendant service does not automatically start when you restart the computer.
  • The following event ID message is logged in the Application event log of the Event Viewer:
    Event Type: Error
    Event Source: MSExchangeSA
    Event Category: General
    Event ID: 1005
    Description: Unexpected error An unknown error has occurred. ID no: 80040a01 Microsoft Exchange System Attendant occurred.

    For more information, click http://search.support.microsoft.com/search/?adv=1.

NOTE: The Event ID 1005 event ID message may also be generated by other Exchange server services, such as Microsoft Exchange Instant Messaging.

CAUSE

This behavior may occur if the Spanning-tree Portfast feature is not turned on, on the network switch device that you use.

The "0x80040a01" error that is noted in the "Description" section of Event ID 1005 is a "timeout for topology creation" error. When Exchange server services start, the Exchange server services must contact a domain controller to read configuration information from Active Directory. If a domain controller and a global catalog is unavailable, or cannot be contacted, the Exchange server services cannot start. This is because of topology creation (DSAccess) changes in Exchange server.

RESOLUTION

To resolve this behavior, turn on the Spanning-tree Portfast option on the network switch in use. Spanning-tree Portfast causes a port to enter the spanning-tree forwarding state immediately, bypassing the listening and learning states.

Contact your network switch hardware vendor for more information about how to turn on this configuration setting.

For information about how to contact contact your network switch hardware vendor, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:
65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

WORKAROUND

To work around this behavior, try to start the System Attendant service from the Services snap-in after the network-switch port has fully initialized.

MORE INFORMATION

For more information about the possible effects of the Portfast setting with Microsoft Windows NT servers, click the following article number to view the article in the Microsoft Knowledge Base:
247922 A "Netlogon event ID 5719" event message is logged when you start a Windows NT Server 4.0-based computer


Properties

Article ID: 318431 - Last Review: September 10, 2011 - Revision: 8.0
APPLIES TO
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 4.0 Standard Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2007 Service Pack 1
  • Microsoft Exchange Server 2007 Service Pack 2
  • Microsoft Exchange Server 2007 Service Pack 3
  • Microsoft Exchange Server 2010 Service Pack 1
  • Microsoft Exchange Server 2010 Standard
Keywords: 
kbpending kbprb kbqfe KB318431

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