Chybová zpráva „Program SERVICES.EXE neočekávaně skončil se stavovým kódem 128“ při spuštění systému Windows 2000

Překlady článku Překlady článku
ID článku: 318447 - Produkty, které se vztahují k tomuto článku.
DŮLEŽITÉ: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastanou potíže. Informace o zálohování, obnovení a úpravě registru najdete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986 Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při zobrazení zprávy „Příprava připojení k síti“ v průběhu spouštění systému Windows 2000 se může zobrazit následující chybová zpráva:

Probíhá vypínání systému. Uložte všechny rozpracované soubory a odhlaste se. Neuložené změny budou ztraceny. Vypnutí vyvolal NT AUTHORITY\SYSTEM.

Systémový proces C:\WINNT\SYSTEM32\SERVICES.EXE neočekávaně skončil se stavovým kódem 128. Systém bude ukončen a restartován.

Příčina

Tyto potíže mohou nastat, pokud se v následujícím klíči registru vyskytují nesprávné odkazy na sdílené složky:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Lanmanserver\Shares
Tyto potíže mohou také nastat, pokud pod následujícím klíčem registru zůstala zastaralá hodnota zabezpečení pro sdílené položky, které již neexistují:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\Shares\Security

Řešení

UPOZORNĚNÍ: Použijete-li Editor registru nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nemůže zaručit, že potíže vzniklé v důsledku nesprávného použití Editoru registru budete moci vyřešit. Editor registru používáte na vlastní nebezpečí.

Při řešení problému postupujte takto:
  1. Restartujte počítač v nouzovém režimu:
    1. Restartujte počítač.
    2. Po zobrazení zprávy „Vyberte operační systém, který chcete spustit“ stiskněte klávesu F8.
    3. V nabídce Upřesnit možnosti spuštění systému Windows vyberte pomocí kláves se šipkami položku Nouzový režim a potom stiskněte klávesu ENTER.
    4. Jestliže v počítači používáte další operační systémy, vyberte v zobrazeném seznamu pomocí kláves se šipkami systém Microsoft Windows 2000 a potom stiskněte klávesu ENTER.
  2. Klepněte na tlačítko Start a na příkaz Spustit. Do pole Otevřít zadejte příkaz regedit a stiskněte klávesu ENTER.
  3. Vyhledejte následující klíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\Shares
  4. Zazálohujte klíč registru:
    1. V nabídce Registr klepněte na příkaz Exportovat soubor registru.
    2. Do pole Název souboru zadejte Shares_RegKey a klepněte na tlačítko Uložit.

      Tento krok uloží klíč registru sdílených položek do textového souboru Shares_RegKey, který můžete v budoucnu použít k obnovení klíče. Ve výchozím nastavení se tento soubor uloží do složky Dokumenty. Informace o obnovení klíče naleznete v tématu Import klíče registru v nápovědě nástroje Editor registru.
  5. Prohlédněte si seznam hodnot v pravém podokně Editoru registru.

    Povšimněte si, že ve sloupci Data jsou uvedeny cesty ke sdíleným složkám. Mohou se například zobrazit řádky podobné následujícím:
    CSCFlags=0 MaxUses=4294967295 Path=E:\NS Permissions=0 Remark= Type=0
    Tento řádek se vztahuje ke sdílené složce E:\NS.
  6. U každé hodnoty zkontrolujte pomocí programu Windows Explorer, zda cesta uvedená ve sloupci Data představuje skutečně existující sdílenou složku. Odstraňte všechny hodnoty, které neodpovídají existujícím sdíleným složkám.
  7. Ukončete Editor registru a restartujte počítač.

Vlastnosti

ID článku: 318447 - Poslední aktualizace: 13. března 2006 - Revize: 4.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 1
Klíčová slova: 
kberrmsg kbprb KB318447

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com