Message d'erreur "Une opération a été tentée sur autre chose qu'un socket" lorsque vous essayez d'obtenir une adresse IP

Numéro d'article: 318584 - Voir les produits auxquels s'applique cet article
IMPORTANT : cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
256986 Définition du Registre de Microsoft Windows
Agrandir tout | Réduire tout

Symptômes

Après avoir installé un modem sur votre système, il se peut que vous ne parveniez pas à vous connecter à Internet. Lorsque vous tentez de libérer puis de renouveler l'adresse IP, le message d'erreur suivant peut s'afficher :
Une opération a été tentée sur autre chose qu'un socket.

Cause

Ce problème peut se produire si la bibliothèque WinSocks ou la pile TCP/IP est endommagée.

Résolution

Pour résoudre ce problème, procédez comme suit :

AVERTISSEMENT : toute mauvaise utilisation de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.

  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la zone Ouvrir, tapez Regedit, puis appuyez sur ENTRÉE.
  3. Accédez à la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
  4. Dans le menu Registre, cliquez sur Exporter un fichier du Registre.
  5. Dans la zone Nom de fichier, tapez le nom du fichier de sauvegarde (par exemple clé_Registre_Winsock), puis cliquez sur Enregistrer. Notez le nom du dossier dans lequel le fichier de Registre est enregistré.
  6. Répétez les étapes 3 à 5 pour la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2
  7. Supprimez les clé de Registre suivantes :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2
    REMARQUE : les étapes 3 à 6 sauvegardent les deux clés de Registre. Vous pouvez utiliser les fichiers de sauvegarde pour restaurer les clés dans le cas où votre ordinateur présenterait un comportement inattendu. Pour plus d'informations sur la restauration de clés de Registre à partir de fichiers .reg, recherchez la rubrique Importer ou exporter des clés de Registre dans les fichiers d'aide de l'Éditeur du Registre.

  8. Fermez l'Éditeur du Registre.
  9. Désinstallez le protocole TCP/IP. Pour cela, procédez comme suit :
    1. Dans le Panneau de configuration, cliquez sur Connexions réseau et accès à distance, cliquez avec le bouton droit sur Connexion au réseau local, puis cliquez sur Propriétés dans le menu contextuel.
    2. Sous Les composants sélectionnés sont utilisés par cette connexion, cliquez sur Protocole Internet (TCP/IP), puis sur Désinstaller.
    3. Suivez les instructions affichées à l'écran pour désinstaller le protocole TCP/IP.
  10. Redémarrez votre ordinateur, puis réinstallez le protocole TCP/IP s'il n'est pas installé automatiquement :
    1. Dans le Panneau de configuration, double-cliquez sur Connexions réseau et accès à distance, cliquez avec le bouton droit sur Connexion au réseau local, puis cliquez sur Propriétés dans le menu contextuel.
    2. Cliquez sur Installer.
    3. Dans la boîte de dialogue Sélection du type de composant réseau, cliquez sur Protocole, puis sur Ajouter.
    4. Sous Fabricants, cliquez sur Microsoft, cliquez sur Protocole Internet (TCP/IP) sous Protocole réseau, puis cliquez sur OK.
    5. Suivez les instructions affichées à l'écran pour installer le protocole TCP/IP.
  11. Réinitialisez votre modem en l'éteignant puis en le rallumant.
  12. Testez votre connexion Internet.

Propriétés

Numéro d'article: 318584 - Dernière mise à jour: jeudi 6 novembre 2003 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Professionel
Mots-clés : 
kberrmsg kbprb KB318584
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires