ID do artigo: 318584 - Última revisão: terça-feira, 11 de janeiro de 2005 - Revisão: 4.1

Mensagem de erro "Foi tentada uma operação em algum item que não é um soquete" ao tentar obter um endereço IP

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
IMPORTANTE: Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e certifique-se de que sabe como restaurá-lo caso ocorra algum problema. Para obter informações adicionais sobre como fazer backup, restaurar e editar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft.
256986  (http://support.microsoft.com/kb/256986/PT-BR/ ) Descrição do Registro do Microsoft Windows
Expandir tudo | Recolher tudo

Sintomas

Após instalar um modem no seu sistema, talvez não seja possível se conectar à Internet. Ao tentar liberar e renovar o endereço IP, a seguinte mensagem de erro pode ser exibida:
Foi tentada uma operação em algum item que não é um soquete.

Causa

Este comportamento pode ocorrer se a biblioteca WinSocks ou a pilha TCP/IP estiver corrompida.

Resolução

Para resolver esse problema, execute essas etapas:

AVISO: O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. O uso do Editor do Registro é de sua responsabilidade.

  1. Clique em Iniciar e em Executar.
  2. Na caixa Abrir, digite Regedit e pressione ENTER.
  3. Navegue para a seguinte chave do Registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
  4. No menu Registro, clique em Exportar arquivo do Registro.
  5. Na caixa Nome do arquivo, digite o nome do arquivo de backup; por exemplo, digite Chave do Registro Winsock e clique em Salvar. Anote o nome da pasta na qual o arquivo de registro foi salvo.
  6. Repita as etapas 3 a 5 para a seguinte chave do Registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2
  7. Exclua as seguintes chaves do Registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2
    OBSERVAÇÃO: As etapas 3 a 6 fizeram um backup das duas chaves do Registro. É possível usar os arquivos de backup para restaurar as chaves caso seu computador apresente um comportamento inesperado. Para obter mais informações sobre como restaurar chaves do Registro a partir de arquivos .reg, procure nos arquivos de ajuda do Editor do Registro pelo tópico Importar ou exportar chaves do Registro.

  8. Feche o Editor do Registro.
  9. Desinstale o protocolo TCP/IP. Para fazer isso, execute estas etapas:
    1. No Painel de controle, clique em Conexões dial-up e de rede, clique com o botão direito do mouse em Conexão de área local e clique em Propriedades no menu de atalho.
    2. Em Os componentes marcados serão usados por esta conexão, clique em Protocolo TCP/IP e clique em Desinstalar.
    3. Execute as instruções na tela para desinstalar TCP/IP.
  10. Reinicie seu computador e reinstale o TCP/IP se não for instalado automaticamente:
    1. No Painel de controle, clique duas vezes em Conexões dial-up e de rede, clique com o botão direito do mouse em Conexão de área local e clique em Propriedades no menu de atalho.
    2. Clique em Instalar.
    3. Na caixa de diálogo Selecionar tipo de componente de rede, clique em Protocolo e clique em Adicionar.
    4. Em Fabricantes, clique em Microsoft, em Protocol TCP/IP em Protocolo de rede e clique em OK.
    5. Execute as instruções na tela para instalar o TCP/IP.
  11. Redefina seu modem desativando-o e ativando-o novamente.
  12. Teste a conexão com a Internet.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
Palavras-chave: 
kberrmsg kbprb KB318584