Article ID: 318827 - Last Review: July 28, 2006 - Revision: 1.7

You receive a "Error reading nickname cache" error message when you use the Outlook Nickname tool in Outlook 2002

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SYMPTOMS

When you run the Outlook Nickname tool (Nick2k.exe) in Outlook 2002, you receive the following error message:
Error reading nickname cache. Perhaps the file does not yet exist.

CAUSE

This problem occurs because the Outlook Nickname tool for Microsoft Outlook 2000 is incompatible with Outlook 2002. The nickname cache in Outlook 2002 stores items (for example, entries created by the AutoComplete feature) that are not found in the nickname cache in previous versions of Microsoft Outlook.

RESOLUTION

An updated version of the Outlook Nickname tool that is compatible with Outlook 2002 has been created, but you should review the details in the "More Information" section of this article before you decide to obtain the updated version. The new AutoComplete feature provides functionality that makes the use of the Outlook Nickname tool basically unnecessary.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date           Time     Version    Size       File name
----------------------------------------------------------
28-MAR-2002    14:56    2.0.0.1    49,152     Nickname.exe
				

WORKAROUND

To work around this problem, delete a name that is stored in the nickname cache. To do this:
  1. Open a new message.
  2. In the To box, type the first three letters of the name that you want to delete from the cache. The list of cached names that start with these three letters automatically appears below the name.

  3. Use the arrow keys on your keyboard to move the selection in this list to the name that you want to delete.
  4. Press the Delete key.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

How to Turn On the AutoComplete Feature

By default, the AutoComplete feature is turned on. However, if you have to turn on this feature, follow these steps:
  1. On the Tools menu, click Options.
  2. On the Preferences tab, click E-mail Options
  3. In the E-mail Options dialog box, click Advanced Options.
  4. Click to select the Suggest names while completing To, Cc, and Bcc fields check box.

The AutoComplete Feature and the Outlook Nickname Tool

If you are using previous versions of Outlook, you can use the Outlook Nickname tool to verify recipients' e-mail addresses and to remove any incorrect entries in the nickname cache. In Outlook 2002, the chance of incorrect entries is rare or even non-existent. The reasons for this are as follows:
  • The AutoComplete feature overlaps and replaces the older Nickname functionality. Although the nickname entries that you created in previous versions of Outlook may appear in the nickname cache, each nickname entry is replaced with an AutoComplete entry during the first use of Outlook 2002.
  • The AutoComplete entry resolves an e-mail address or alias to the full name or the display name of a Microsoft Exchange recipient or Outlook contact. This is more accurate than an arbitrary nickname.
  • If the AutoComplete feature is turned on, you can visually confirm the recipient after you type at least three characters of the name. The AutoComplete entries always resolve based on the full name or alias. This lowers, if not completely removes, the possibility of sending a message to an incorrect recipient.
For more information about the Nickname feature in previous versions of Outlook, click the article number below to view the article in the Microsoft Knowledge Base:

245421  (http://support.microsoft.com/kb/245421/EN-US/ ) XCLN: Summary of Nickname Features in Different Outlook Versions

APPLIES TO
  • Microsoft Outlook 2002 Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbstartprogram kbbug kberrmsg kbfix kbqfe KB318827
 

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