Article ID: 318913 - Last Review: January 25, 2006 - Revision: 2.1

You may receive the "A failed installation has been detected" error message when you run Visual Studio .NET Setup

This article was previously published under Q318913
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/EN-US/ ) Description of the Microsoft Windows Registry
Expand all | Collapse all

SYMPTOMS

When you run Visual Studio .NET (VS .NET) Setup, you may receive the following error message:
"A failed installation has been detected."
If you click OK to clean up the installation files, and then you try to run Setup again, you may receive the same error message.

CAUSE

There is an orphan registry key on your computer that interferes with the installation.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve the problem, follow these steps:
  1. On the Start menu, click Run, type regedit, and then click OK.
  2. Locate the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Integration
  3. The number keys you see are SKUs. For each SKU, do the following:
    1. Click the SKU. In the right pane, locate the entry for Suitename
    2. Double-click this entry, and then note the Value Data section of this window.
    3. If the entry does not pertain to Visual Studio .NET, click the next SKU in the list.
  4. Delete only the SKUs that contain information about Visual Studio .NET in the Value Data section. To delete the SKU, follow these steps:
    1. Click the SKU number, and then press DELETE.
    2. Confirm that you want to delete the key.
  5. Close the registry editor, and then restart the computer.
  6. Try the installation again.

APPLIES TO
  • Microsoft Visual Studio .NET 2003 Professional Edition
  • Microsoft Visual Studio .NET 2003 Enterprise Architect
  • Microsoft Visual Studio .NET 2003 Enterprise Developer
  • Microsoft Visual Studio .NET 2003 Academic Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2002 Enterprise Architect
  • Microsoft Visual Studio .NET 2002 Enterprise Developer
  • Microsoft Visual Studio .NET 2002 Academic Edition
Keywords: 
kbvs2005doesnotapply kbvs2005swept kbtshoot kberrmsg kbprb kbsetup KB318913
 

Article Translations