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文書番号: 319011 - 最終更新日: 2004年1月14日 - リビジョン: 3.1

エラー メッセージ : 次のファイルが存在しないかまたは壊れているため、Windows 2000 を起動できませんでした: \Winnt\System32\Config\System

目次

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現象

Microsoft Windows 2000 Server ベースのコンピュータを再起動したときに、以下のエラー メッセージが 1 つ以上表示されることがあります。
次のファイルが存在しないかまたは壊れているため、Windows 2000 を起動できませんでした:

\Winnt\System32\Config\System
または
次のファイルが存在しないかまたは壊れているため、Windows 2000 を起動できませんでした:

winnt_root\System32\Ntoskrnl.exe

上記のファイルをインストールし直してください。
: この問題は断続的に発生することがあります。

原因

この問題は、McAfee GroupShield Exchange v5.0 for Microsoft Exchange 2000 Server がコンピュータにインストールされている場合に発生することがあります。

自動更新 (AutoUpdate) の失敗が原因で、Windows 2000 のブート メニュー ファイル (Boot.ini) が破損することもあります。

解決方法

この問題を解決するには、状況に応じて以下の方法のいずれかを使用します。

Microsoft Windows 2000 を起動できる場合

Windows を起動できる場合は、McAfee GroupShield v5.0 for Microsoft Exchange 2000 フィールドパッチ 1 を入手してインストールします。このフィールドパッチを入手してインストールする方法については、Network Associates Inc. にお問い合わせください。

Network Associates Inc. の問い合わせ先を参照するには、以下の該当する「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
65416? (http://support.microsoft.com/kb/65416/ ) Hardware and Software Third-Party Vendor Contact List, A-K

60781? (http://support.microsoft.com/kb/60781/ ) Hardware and Software Third-Party Vendor Contact List, L-P

60782? (http://support.microsoft.com/kb/60782/ ) Hardware and Software Third-Party Vendor Contact List, Q-Z

Microsoft Windows 2000 を起動できない場合

Windows を起動できない場合は、Windows のスタートアップ環境を修復してから、McAfee GroupShield Exchange フィールドパッチをインストールします。この操作を行うには、以下の方法のいずれかを使用します。

起動ディスクを使用する

: この資料の「現象」に記載された最初のエラー メッセージが表示された場合は、この方法を使用しないでください。代わりに、この資料の後で説明する「Windows 2000 システム修復処理を使用する」にある方法を使用します。
  1. 以下のファイルを含む Windows 2000 起動ディスクを作成します。
    Ntldr
    Ntdetect.com
    Boot.ini
    Ntbootdd.sys
    起動ディスクの作成方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    301680? (http://support.microsoft.com/kb/301680/ ) HOW TO: Create a Boot Disk for an NTFS or FAT Partition in Windows
    301680? (http://support.microsoft.com/kb/301680/JA/ ) [HOW TO] NTFS または FAT パーティション用の起動ディスクの作成方法
    101668? (http://support.microsoft.com/kb/101668/ ) How to Use a Windows Boot Disk to Prevent Boot Failure in Windows 2000 or Windows NT
    101668? (http://support.microsoft.com/kb/101668/JA/ ) Windows NT ブート ディスクを作成しブート障害に備える方法
  2. Windows インストールの適切なハード ディスク コントローラとボリュームを指すように Boot.ini ファイルを修正します。
  3. 起動ディスクを使用してコンピュータを再起動します。
  4. Boot.ini ファイルおよび Ntbootdd.sys ファイルを起動ディスクからローカル ハード ディスク上のシステム パーティションにコピーします。
  5. McAfee GroupShield Exchange プログラムのフィールドパッチを McAfee から入手してインストールします。

Windows 2000 システム修復処理を使用する

  1. Windows 2000 CD-ROM を使用してコンピュータを起動します。
  2. [セットアップの開始] メニューで R キーを押します。
  3. R キーを押して、システム修復処理を選択します。
  4. M キーを押して、[手動修復] を選択します。
  5. Enter キーを押して、選択したタスクを実行します。
  6. 残りの指示に従って、Windows 2000 インストールを修復します。
  7. McAfee GroupShield Exchange プログラムのフィールドパッチを McAfee から入手してインストールします。

詳細

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
238359? (http://support.microsoft.com/kb/238359/ ) Differences Between Manual and Fast Repair in Windows
238359? (http://support.microsoft.com/kb/238359/JA/ ) Windows の手動修復と高速修復の違い
242112? (http://support.microsoft.com/kb/242112/ ) Ntdetect Fails When Computer Starts
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関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 319011? (http://support.microsoft.com/kb/319011/EN-US/ ) (最終更新日 2003-08-29) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Advanced Serverを以下の環境でお使いの場合
    • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Windows 2000 Serverを以下の環境でお使いの場合
    • Microsoft Exchange 2000 Server Standard Edition
キーワード:?
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