文書番号: 319095 - 最終更新日: 2009年6月30日 - リビジョン: 3.1

通知領域に [音量] アイコンが表示されず、追加しようとするとエラー メッセージが表示されることがある

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。
この資料は、初級レベルから中級レベルのコンピューター ユーザーを対象にしています。

目次

すべて展開する | すべて折りたたむ

現象

Windows XP ベースのコンピューターで、次のいずれかの現象が発生することがあります。
  • タスク バーの右端の通知領域に [音量] アイコンが表示されない。
  • 音量の調節アイコンを通知領域に追加しようとすると、以下のエラー メッセージが表示されることがあります。
    [ボリューム コントロール] がインストールされていないので、音量の調節をタスク バーに表示することはできません。コントロール パネルの [プログラムの追加と削除] を使ってインストールしてください。
このため、ボリューム コントロール プログラムを起動して、コンピューターの音量およびサウンド レベル設定を調節することができません。

原因

この問題に対して考えられる原因が 2 つあります。
  • コンピューターの通知領域に [音量] アイコンが追加されていません。(Windows XP の初回インストール時に、[音量] アイコンは通知領域に自動的に表示されません)。
  • Sndvol32.exe ファイルが存在しないか、破損しています。

解決方法

注:この資料を最初に印刷しておくと、手順を実行しやすい場合があります。

既定では、コンピューターに Windows XP を初めてインストールしたとき、[音量] アイコンは表示されません。この問題を解決するには、[音量] アイコンを通知領域に追加します。

: [音量] アイコンを追加しようとしてエラーが表示された場合は、このセクションを省略して方法 2. に進みます。

方法 1: [音量] アイコンを追加する

[音量] アイコンをコンピューターの通知領域に追加するには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスに次のコマンドをコピーして貼り付けるか入力し、Enter キーを押します。
    mmsys.cpl
  3. [タスク バーに音量アイコンを配置する] チェック ボックスをオンにします。
  4. [OK] をクリックします。
[音量] アイコンがコンピューターの通知領域に追加された場合は終了です。[音量] アイコンを追加できない場合、または追加しようとするとエラー メッセージが表示される場合は、Sndvol32.exe が破損しているか、存在しません。方法 2. に進みます。

方法 2: Sndvol32.exe ファイルの新しいコピーをハード ディスクに保存する

Sndvol32.exe ファイルが破損しているか、存在しない場合は、Windows XP CD から Sndvol32.exe ファイルの新しいコピーを抽出してコンピューターのハード ディスクに保存します。

必要条件

この方法には、Windows XP インストール CD が必要です。

: インストール ファイルが収録されている Windows XP CD にアクセスできない場合は、コンピューターが職場にある場合はネットワーク管理者に問い合わせるか、サポートに問い合わせてください。マイクロソフト サポートへのお問い合わせについては、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactUS/ (http://support.microsoft.com/contactus/)
Windows XP CD から Sndvol32.exe ファイルのコピーを抽出してコンピューターのハード ディスクに保存するには、次の手順を実行します。
  1. コンピューターの CD ドライブまたは DVD ドライブに Windows XP の CD を挿入します。インストールが自動的に開始しないようにするには、Shift キーを押しながら CD を挿入します。
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  3. [名前] ボックスに次のコマンドをコピーして貼り付けるか入力し、[OK] をクリックします。
    cmd
    コマンド プロンプトが開きます。
  4. CD ドライブまたは DVD ドライブのドライブ文字、コロンの順に入力します。次に、Enter キーを押します。たとえば、コンピューターの CD ドライブがドライブ E の場合は、次のように入力し、Enter キーを押します。
    e:
  5. 次の行をコピーして貼り付けるか入力し、Enter キーを押します。
    cd i386
  6. 次の行をコピーして貼り付けるか入力し、Enter キーを押します。
    expand sndvol32.ex_ system_root\system32\sndvol32.exe
    注: system_root はコンピューターで Windows システム ファイルが存在するフォルダー名の一部です。通常、これは C:\Windows です。コンピューターで Windows システム ファイルが存在するフォルダーが C:\Windows である場合は、次のように入力し、Enter キーを押します。
    expand sndvol32.ex_ c:\windows\system32\sndvol32.exe
    : このコマンドでは、"ex_" と "c:\windows" の間にスペースが存在します。
  7. exit」と入力し、Enter キーを押して、コマンド プロンプトを終了します。
  8. ボリューム コントロールが起動可能で、[音量] アイコンが通知領域に表示される (このオプションを方法 1. で選択した場合) ことを確認します。
[音量] アイコンが通知領域に追加された場合は終了です。[音量] アイコンがコンピューターの通知領域に追加されない場合は、「次の手順」セクションに進みます。

次の手順

以上の方法で問題が解決しない場合は、ネットワーク管理者に問い合わせてください。Microsoft Customer Support Services の Web サイトでその他の解決策が見つかることもあります。Microsoft Customer Support Services Web サイトでは、以下のようなサービスを利用できます。
  • サポート技術情報検索 (http://support.microsoft.com/search/?adv=1) :マイクロソフト製品に関するサポート技術情報とセルフ サポート ツールを検索できます。
  • 製品別サポート ページ (http://support.microsoft.com/select/?target=hub) :よく寄せられる質問と重要なサポート情報を製品別に参照できます。
  • マイクロソフト ニュースグループ (http://www.microsoft.com/japan/communities/newsgroups/browser/default.mspx) :他のユーザーやマイクロソフト MVP (Most Valuable Professionals) から情報を得ることができます。
  • その他のサポート オプション (http://support.microsoft.com/default.aspx?pr=csshome) :Web を使用した質問、Microsoft Customer Support Services への問い合わせ、フィードバックの送信を行うことができます。
これらのマイクロソフト Web サイトを使用しても問題が解決されない場合、または Microsoft Support Services Web サイトで問題の解決方法が見つからない場合は、次のリンクをクリックしてサポートにお問い合わせください。
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

詳細

通知領域に表示されるアイコンについての情報を参照するには、以下のサポート技術情報番号をクリックしてください。
310578? (http://support.microsoft.com/kb/310578/ ) Windows システム トレイ アイコンについて
サウンドの問題をトラブルシューティングする方法の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
307918? (http://support.microsoft.com/kb/307918/ ) Windows XP のサウンドの問題を解決するための情報

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kberrmsg kbprb KB319095
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"