Article ID: 319114 - View products that this article applies to.
This article was previously published under Q319114
Expand all | Collapse all

On This Page

SYMPTOMS

When you double-click System in Control Panel, or when you right-click My Computer and then click Properties, you may receive the following error message:
rundll32.exe - Unable To Locate Component

This application has failed to start because framedyn.dll was not found. Re-installing the application may fix this problem.

CAUSE

This issue occurs because of one of the following conditions:
  • The %SYSTEMROOT%\System32\Wbem\Framedyn.dll file is missing or damaged.
  • The Path environment variable does in Windows does not point to the %SYSTEMROOT%\System32\Wbem folder.

RESOLUTION

To have us fix the problem for you, visit the "Fix it for me" section. If you prefer to fix this problem yourself, visit the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Click Run in the File Download dialog box, and follow the steps in the Fix it wizard.

Fix this problem
Microsoft Fix it 50407
Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows. 
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, visit the "Did this fix the problem?" section.



Let me fix it myself

To resolve this issue, use both of the following methods.

Replace the Framedyn.dll File

  1. Click Start, and then click Run.
  2. In the Open box, type %systemroot%\system32\dllcache, and then click OK.
  3. Right-click framedyn.dll, and then click Copy.
  4. Click Start, and then click Run.
  5. In the Open box, type %systemroot%\system32\wbem, and then click OK.
  6. On the Edit menu, click Paste. If you are prompted to replace the existing file, click Yes.

Verify System Variables

  1. Click Start, right-click My Computer, and then click Properties. If you receive the following error message, click OK:
    rundll32.exe - Unable To Locate Component

    This application has failed to start because framedyn.dll was not found. Re-installing the application may fix this problem.
  2. In the System Properties dialog box, click the Advanced tab.
  3. Click Environment Variables.
  4. Under System variables, click Path, and then click Edit.

    NOTE: If no Path variable is listed, click New. In the Variable name box, type Path.
  5. In the Variable value box, type the following:
    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\wbem
  6. Click OK three times (every time that you have the option).

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.

Properties

Article ID: 319114 - Last Review: July 19, 2010 - Revision: 3.0
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kberrmsg kbprb kbmsifixme kbfixme KB319114

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com