Fehlermeldung "Anwendung konnte nicht gestartet werden, weil 'framedyn.dll' nicht gefunden wurde" beim Öffnen des Dialogfelds "Systemeigenschaften"

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 319114 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde zuvor veröffentlicht unter D319114
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Wenn Sie in der Systemsteuerung auf System doppelklicken oder mit der rechten Maustaste auf Arbeitsplatz klicken und dann auf Eigenschaften klicken, kann folgende Fehlermeldung angezeigt werden:
rundll32.exe - Komponente nicht gefunden

Die Anwendung konnte nicht gestartet werden, weil "framedyn.dll" nicht gefunden wurde. Neuinstallation der Anwendung könnte das Problem beheben.

Ursache

Dieses Verhalten tritt unter einer der folgenden Bedingungen auf:
  • Die Datei "%SYSTEMROOT%\System32\Wbem\Framedyn.dll" fehlt oder ist beschädigt.
  • Die Umgebungsvariable Path in Windows zeigt nicht auf den Ordner "%SYSTEMROOT%\System32\Wbem".

Lösung

Wenn Sie das Problem automatisch beheben lassen möchten, lesen Sie den Abschnitt "Problem automatisch beheben". Wenn Sie das Problem lieber selbst beheben möchten, lesen Sie den Abschnitt "Problem manuell beheben".

Problem automatisch beheben



Um das Problem automatisch zu beheben, klicken Sie auf die Fix it-Schaltfläche oder den Link Problem beheben. Klicken Sie im Dialogfeld Dateidownload auf Ausführen, und befolgen Sie die Schritte im Fix it-Assistenten.

Problem beheben
Microsoft Fix it 50407
Hinweise
  • Dieser Assistent ist möglicherweise nur in Englisch verfügbar. Die automatische Korrektur funktioniert aber auch für andere Sprachversionen von Windows.
  • Wenn Sie sich nicht an dem Computer befinden, auf dem das Problem auftritt, speichern Sie die Fix it-Lösung auf einem USB-Speicherstick oder einer CD, und führen Sie sie anschließend auf dem vom Problem betroffenen Computer aus.

Lesen Sie dann den Abschnitt "Wurde das Problem behoben?".



Problem manuell beheben

Verwenden Sie die beiden folgenden Methoden, um dieses Problem zu beheben.

Ersetzen der Datei "Framedyn.dll"

  1. Klicken Sie auf Start und anschließend auf Ausführen.
  2. Geben Sie in das Feld Öffnen die Zeichenfolge %systemroot%\system32\dllcache ein. Klicken Sie dann auf OK.
  3. Klicken Sie mit der rechten Maustaste auf die Datei framedyn.dll, und klicken Sie auf Kopieren.
  4. Klicken Sie auf Start und anschließend auf Ausführen.
  5. Geben Sie in das Feld Öffnen die Zeichenfolge %systemroot%\system32\wbem ein. Klicken Sie dann auf OK.
  6. Klicken Sie im Menü Bearbeiten auf Einfügen. Klicken Sie auf Ja, wenn Sie gefragt werden, ob die vorhandene Datei ersetzt werden soll.

Überprüfen der Systemvariablen

  1. Klicken Sie auf Start, klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie dann auf Eigenschaften. Wenn die folgende Fehlermeldung angezeigt wird, klicken Sie auf OK:
    rundll32.exe - Komponente nicht gefunden

    Die Anwendung konnte nicht gestartet werden, weil "framedyn.dll" nicht gefunden wurde. Neuinstallation der Anwendung könnte das Problem beheben.
  2. Klicken Sie im Dialogfeld Systemeigenschaften auf die Registerkarte Erweitert.
  3. Klicken Sie auf Umgebungsvariablen.
  4. Klicken Sie unter Systemvariablen auf Path und dann auf Bearbeiten.

    HINWEIS: Wenn keine Variable Path angezeigt wird, klicken Sie auf Neu. Geben Sie in das Feld Variablenname die Zeichenfolge Path ein.
  5. Geben Sie in das Feld Variablenwert Folgendes ein:
    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\wbem
  6. Klicken Sie dreimal auf OK (immer dann, wenn diese Option verfügbar ist).

Wurde das Problem behoben?

  • Testen Sie, ob das Problem behoben ist. Wenn das Problem beseitigt ist, sind Sie mit diesem Abschnitt fertig. Wenn das Problem noch nicht behoben ist, wenden Sie sich an den Support.
  • Ihr Feedback ist uns wichtig. Um uns Ihr Feedback zu übermitteln oder uns über Probleme mit dieser Lösung zu informieren, schreiben Sie einen Kommentar im "Fix it for me"-Blog, oder senden Sie uns eine E-Mail-Nachricht.

Eigenschaften

Artikel-ID: 319114 - Geändert am: Montag, 16. Mai 2011 - Version: 4.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kberrmsg kbprb kbmsifixme kbfixme KB319114
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com