Help and Support

Numéro d'article: 319114 - Dernière mise à jour: lundi 24 février 2003 - Version: 1.0

Affichage du message d'erreur "Cette application n'a pas pu démarrer car Framedyn.dll est introuvable" lorsque vous ouvrez la boîte de dialogue Propriétés

Ancien nº de publication de cet article : F319114

Sommaire

Agrandir tout | Réduire tout

Symptômes

Lorsque vous double-cliquez sur Système dans le Panneau de configuration ou cliquez avec le bouton droit sur Poste de travail, puis cliquez sur Propriétés, le message d'erreur risque d'apparaître :
rundll32.exe - Composant introuvable

Cette application n'a pas pu démarrer car framedyn.dll est introuvable La réinstallation de cette application peut corriger ce problème.

Cause

Ce problème peut se produire lorsque l'une des conditions suivantes est remplie :
  • Le fichier %SYSTEMROOT%\System32\Wbem\framedyn.dll est manquant ou endommagé.

    - ou -
  • La variable d'environnement Path de Windows ne pointe pas sur le dossier %SYSTEMROOT%\System32\Wbem.

Résolution

Pour résoudre ce problème, appliquez les deux méthodes ci-après.

Remplacement du fichier Framedyn.dll

  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la zone Ouvrir, tapez %systemroot%\system32\dllcache, puis cliquez sur OK.
  3. Cliquez avec le bouton droit sur framedyn.dll, puis cliquez sur Copier dans le menu contextuel qui apparaît.
  4. Cliquez sur Démarrer, puis sur Exécuter.
  5. Dans la zone Ouvrir, tapez %systemroot%\system32\wbem, puis cliquez sur OK.
  6. Dans le menu Edition, cliquez sur Coller. Si le système vous invite à remplacer le fichier existant, cliquez sur Oui.

Vérification des variables systèmes

  1. Cliquez sur Démarrer, cliquez avec le bouton droit sur Poste de travail, puis cliquez sur Propriétés dans le menu contextuel qui apparaît. Si le message d'erreur suivant s'affiche, cliquez sur OK :
    rundll32.exe - Composant introuvable

    Cette application n'a pas pu démarrer car framedyn.dll est introuvable La réinstallation de cette application peut corriger ce problème.
  2. Dans la boîte de dialogue Propriétés système, cliquez sur l'onglet Avancées.
  3. Cliquez sur Variables d'environnement.
  4. Sous Variables système, cliquez sur Path, puis sur Modifier.

    REMARQUE : si aucune variable Path ne figure dans la liste, cliquez sur Nouveau. Dans la zone Nom de variable, tapez Path.
  5. Dans la zone Valeur de la variable, tapez la ligne suivante :
    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\wbem
  6. Cliquez sur OK trois fois (chaque fois que l'option se présente).

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professionnel
Mots-clés : 
kberrmsg kbprb KB319114
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Traductions disponibles

 

Related Support Centers