Help and Support

Identificativo articolo: 319206 - Ultima modifica: martedì 12 settembre 2006 - Revisione: 6.0

Configurazione di Outlook per l'accesso a un server di catalogo globale specifico o al server di catalogo globale più vicino

Per la versione di questo articolo relativa a Microsoft Outlook 2000, vedere 272290  (http://support.microsoft.com/kb/272290/ ) .
Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

Sintomi

In alcuni casi si potrebbe notare un traffico di rete eccessivo quando in Microsoft Outlook viene effettuato il tentativo di contattare il server di catalogo globale.

Il presente articolo descrive come configurare Outlook per l'accesso a un server di catalogo globale specifico o al server di catalogo globale più vicino.

Nota Se il server di catalogo globale e il computer in cui è installato Exchange Server si trovano nella stessa sede del client Outlook, non è necessario apportare questa modifica al Registro di sistema. Il normale meccanismo di riferimento garantisce le prestazioni migliori.

Cause

Questo comportamento si verifica quando il computer in cui è installato Exchange Server (in cui è situato il client Outlook) e il server di catalogo globale si trovano entrambi in una sede remoto rispetto alla collocazione del client Outlook.

Workaround

Avviso L'errata modifica del Registro di sistema tramite l'editor può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. L'utilizzo dell'editor del Registro di sistema è a rischio e pericolo dell'utente.

Impostazione del server di catalogo globale più vicino

Attenersi alla procedura riportata di seguito per imporre l'identificazione e l'utilizzo del server di catalogo più vicino da parte di Outlook.
  1. Fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Digitare regedit.exe nella casella Apri, quindi scegliere OK.
  3. Individuare e selezionare la seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider
    Nota Potrebbe essere necessario creare il percorso del Registro di sistema.

  4. Scegliere Aggiungi valore dal menu Modifica e aggiungere il seguente valore del Registro di sistema:
    Nome valore: Closest GC
    Tipo dati: REG_DWORD
    Base: Esadecimale
    Dati valore: 0x00000001
  5. Chiudere l'editor del Registro di sistema.

Impostazione di un server di catalogo globale specifico

In altre topologie si potrebbe imporre la comunicazione da parte di Outlook con un server di catalogo specifico, non necessariamente con il server di catalogo globale più vicino al client Outlook.

Anche se è possibile modificare manualmente il parametro del Registro di sistema nel profilo MAPI, tale parametro verrà sovrascritto al successivo avvio di Outlook.

Per imporre l'utilizzo di un server di catalogo globale predefinito da parte di Outlook, attenersi alla procedura riportata di seguito per impostare il parametro speciale del Registro di sistema indicato di seguito affinché faccia riferimento al nome completo del dominio (FQDN). In questo modo vengono ignorate le impostazioni del profilo MAPI.
  1. Fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Digitare regedit.exe nella casella Apri, quindi scegliere OK.
  3. Individuare e selezionare la seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider.

    Nota Potrebbe essere necessario creare il percorso del Registro di sistema.
  4. Scegliere Aggiungi valore dal menu Modifica e aggiungere il seguente valore del Registro di sistema:
    Nome valore: DS Server
    Tipo dati: REG_SZ (stringa)
    Dati valore: FQDN del server di catalogo globale
  5. Chiudere l'editor del Registro di sistema. Se si verifica il blocco di Outlook dopo l'impostazione del server di catalogo globale più vicino o di quello specifico, il programma torna al processo DSProxy nel server Exchange 2000 e richiede un nuovo riferimento. Quelle riportate di seguito sono due possibili limitazioni se si configura Outlook per un server di catalogo globale specifico:
  • Il server di catalogo globale rilevato dal client potrebbe non essere aggiornato o essere parzialmente funzionante. Se nel server di catalogo globale si verificano problemi, ma la risposta alle richieste NSPI (Named Service Provider Interface) continua comunque a essere fornita, il blocco di Outlook e il relativo ritorno al processo DSProxy per un nuovo riferimento potrebbero non avvenire.
  • In ambienti costituiti da più domini, il server di catalogo globale selezionato potrebbe non trovarsi nello stesso dominio degli oggetti di gruppo di Active Directory. Per questo motivo gli utenti non possono aggiornare l'appartenenza al gruppo perché il server di catalogo globale locale dispone di una copia in sola lettura del gruppo.

Informazioni

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
317209  (http://support.microsoft.com/kb/317209/ ) Identificazione del server di catalogo globale mediante Outlook 2000 e Outlook 2002
Le informazioni contenute in questo articolo sono riportate nel white paper relativo alla comprensione e alla risoluzione dei problemi di accesso alle directory. Per visualizzare il white paper, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/downloads/details.aspx?familyid=C976433F-F979-4745-B7A6-9D8446EF6409&displaylang=en (http://www.microsoft.com/downloads/details.aspx?familyid=C976433F-F979-4745-B7A6-9D8446EF6409&displaylang=en)


Le informazioni in questo articolo si applicano a
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard Edition
Chiavi: 
kbregistry kbconfig kbhowto kbprb KB319206
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Traduzione articoli

 

Related Support Centers