Cómo utilizar la base de datos de línea de comandos modificador/Convert para convertir sólo en formato de archivo de Access 2000

Seleccione idioma Seleccione idioma
Id. de artículo: 319253 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Moderada: Requiere macro básico, codificación y las capacidades de interoperabilidad.

Este artículo se aplica únicamente a las bases de datos de Microsoft Access (.mdb).

Expandir todo | Contraer todo

Síntomas

El tema de Ayuda de Microsoft Access 2002 "Opciones de línea de comandos de inicio" indica incorrectamente lo siguiente:

Convierte una base de datos de versión anterior de Access o proyecto de Access en el formato de archivo predeterminado, cambia el nombre del nuevo archivo y, a continuación, cierra Access. Debe especificar la base de datos de origen antes de utilizar la opción /Convert . Para ver el formato de archivo predeterminado, haga clic en Opciones en el menú Herramientas y, a continuación, haga clic en la ficha Avanzadas .

Causa

El modificador / convertir no puede detectar la propiedad DefaultDatabaseFormat . En Access 2002, el modificador puede convertir la base de datos sólo en formato de archivo de Access 2000.

Solución

Si desea convertir una versión anterior de una base de datos en formato de archivo de Access 2002, utilice uno de los métodos siguientes.

Mediante los menús integrados de Access

En el menú Herramientas , elija Utilidades de base de datos , seleccione convertir la base de datos y, a continuación, haga clic en Para el formato de archivo de Access 2002 .

Utilizar el método ConvertAccessProject

El código siguiente convierte una versión anterior de una base de datos en formato de archivo de Access 2002:
  1. Cree un módulo y, a continuación, escriba la línea siguiente en la sección Declaraciones si no está ya allí:
    Option Explicit
    						
  2. Escriba el siguiente procedimiento:
    Function ConvDB2002(SourceDb As String, DestDb As String)
       Application.ConvertAccessProject SourceDb, DestDb, acFileFormatAccess2002
    End Function
    						
  3. Para probar esta función, escriba la línea siguiente en la ventana Inmediato. Asegúrese de sustituir el ruta de acceso y el nombre correcto para la base de datos. A continuación, presione ENTRAR:
    ?ConvDB2002("c:\data\MyAcc97.mdb", "c:\data\MyAcc2002.mdb")
    						
Para obtener más información acerca del método ConvertAccessProject, en el Editor de Visual Basic, haga clic en Ayuda de Microsoft Visual Basic en el menú Ayuda , escriba el Método ConvertAccessProject en el Ayudante de Office o el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver el tema.

Para obtener información adicional acerca de cómo convertir varias bases de datos, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304318ACC2002: Cómo convertir varias bases de datos Access mediante programación

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo.

Más información

Para establecer la propiedad DefaultDatabaseFormat , haga clic en Opciones en el menú Herramientas y, a continuación, haga clic en la ficha Avanzadas .

Referencias

Para obtener más información acerca de modificadores de línea de comandos, haga clic en Ayuda de Microsoft Access en el menú Ayuda , escriba las opciones de línea de comandos de inicio en el Ayudante de Office o en el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver el tema.

Propiedades

Id. de artículo: 319253 - Última revisión: lunes, 03 de febrero de 2014 - Versión: 4.1
La información de este artículo se refiere a:
  • Microsoft Access 2002 Standard Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbhowto kbdocerr kbdta kbnofix KB319253 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 319253

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com