Como utilizar a base de dados do linha de comandos parâmetro /convert para converter apenas no formato de ficheiro do Access 2000

Traduções de Artigos Traduções de Artigos
Artigo: 319253 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Moderado: Requer básica macros, codificação e interoperabilidade competências.

Este artigo aplica-se apenas a uma base de dados do Microsoft Access (.mdb).

Expandir tudo | Reduzir tudo

Sintomas

O tópico de ajuda do Microsoft Access 2002 "Opções da linha de comandos de arranque" indica incorrectamente o seguinte:

Converte uma base de dados versão anterior ou projecto de Access para o formato de ficheiro predefinido, muda o nome do novo ficheiro e, em seguida, fecha o Access. Tem de especificar base de dados de origem antes de utilizar a opção / Converter . Para visualizar o formato de ficheiro predefinido, clique em Opções no menu Ferramentas e, em seguida, clique no separador Avançadas .

Causa

O parâmetro / Converter não consegue detectar a propriedade DefaultDatabaseFormat . No Access 2002, o parâmetro pode converter a base de dados apenas em formato de ficheiro do Access 2000.

Resolução

Se pretende converter uma versão anterior de uma base de dados do Access num formato de ficheiro do Access 2002, utilize um dos seguintes métodos.

Utilizar os menus incorporados do Access

No menu Ferramentas , aponte para Utilitários de base de dados , aponte para Converter base de dados e clique em Para o formato de ficheiro do Access 2002 .

Utilizar o método ConvertAccessProject

O seguinte código converte uma versão anterior de uma base de dados do Access num formato de ficheiro do Access 2002:
  1. Crie um módulo e, em seguida, escreva a seguinte linha na secção declarações se não estiver já existe:
    Option Explicit
    						
  2. Escreva o seguinte procedimento:
    Function ConvDB2002(SourceDb As String, DestDb As String)
       Application.ConvertAccessProject SourceDb, DestDb, acFileFormatAccess2002
    End Function
    						
  3. Para testar esta função, escreva a seguinte linha na janela imediata. Certifique-se substituir o nome de ficheiro e o caminho correcto para a base de dados. Em seguida, prima ENTER:
    ?ConvDB2002("c:\data\MyAcc97.mdb", "c:\data\MyAcc2002.mdb")
    						
Para mais informações sobre o método ConvertAccessProject, no Editor do Visual Basic, clique em Ajuda do Microsoft Visual Basic no menu Ajuda , escreva ConvertAccessProject método na Assistente do Office ou no Assistente de respostas e, em seguida, clique em Procurar para visualizar o tópico.

Para obter informações adicionais sobre como converter várias bases de dados Access, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
304318ACC2002: Como converter programaticamente várias bases de dados Access

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no início deste artigo.

Mais Informação

Para definir a propriedade DefaultDatabaseFormat , clique em Opções no menu Ferramentas e, em seguida, clique no separador Avançadas .

Referências

Para obter mais informações sobre parâmetros da linha de comandos, clique em Ajuda do Microsoft Access no menu de Ajuda escreva Opções da linha de comandos de arranque no Assistente do Office ou no Assistente de respostas e, em seguida, clique em Procurar para visualizar o tópico.

Propriedades

Artigo: 319253 - Última revisão: 13 de fevereiro de 2014 - Revisão: 4.1
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbhowto kbdocerr kbdta kbnofix KB319253 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 319253

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com