Como usar o banco de dados /convert para converter opção de linha de comando apenas em formato de arquivo do Access 2000

Traduções deste artigo Traduções deste artigo
ID do artigo: 319253 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Moderado: Requer básica de macro, codificação e interoperabilidade habilidades.

Este artigo se aplica somente a um banco de dados do Microsoft Access (.mdb).

Expandir tudo | Recolher tudo

Sintomas

O tópico da Ajuda "Opções de linha de comando de inicialização" Microsoft Access 2002 afirma incorretamente o seguinte:

Converte uma banco de dados de versão anterior do Access ou projeto do Access para o formato de arquivo padrão, renomeia o novo arquivo e, em seguida, fecha o Access. Você deve especificar o banco de dados de origem antes de usar a opção / Converter . Para exibir o formato de arquivo padrão, clique em Opções no menu Ferramentas e, em seguida, clique na guia Avançado .

Causa

A opção / Converter não pode detectar a propriedade DefaultDatabaseFormat . No Access 2002, a opção pode converter o banco de dados somente em formato de arquivo do Access 2000.

Resolução

Se você quiser converter uma versão anterior de um banco de dados do Access no formato de arquivo do Access 2002, use um dos seguintes métodos.

Usando os menus internos do Access

No menu Ferramentas , aponte para Utilitários de banco de dados , aponte para Converter banco de dados e, em seguida, clique em Para o formato de arquivo do Access 2002 .

Usando o método ConvertAccessProject

O código a seguir converte uma versão anterior de um banco de dados do Access em formato de arquivo do Access 2002:
  1. Criar um módulo e digite a seguinte linha na seção Declaração caso ele não esteja lá:
    Option Explicit
    						
  2. Digite o seguinte procedimento:
    Function ConvDB2002(SourceDb As String, DestDb As String)
       Application.ConvertAccessProject SourceDb, DestDb, acFileFormatAccess2002
    End Function
    						
  3. Para testar essa função, digite a seguinte linha na janela Verificação imediata. Certifique-se de substituir o nome caminho e o arquivo correto para seu banco de dados. Em seguida, pressione ENTER:
    ?ConvDB2002("c:\data\MyAcc97.mdb", "c:\data\MyAcc2002.mdb")
    						
Para obter mais informações sobre o método ConvertAccessProject, no Editor do Visual Basic, clique em Ajuda do Microsoft Visual Basic no menu Ajuda , digite o Método ConvertAccessProject no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir o tópico.

Para obter informações adicionais sobre como converter vários bancos de dados, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
304318ACC2002: Como converter programaticamente vários bancos de dados Access

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo.

Mais Informações

Para definir a propriedade DefaultDatabaseFormat , clique em Opções no menu Ferramentas e, em seguida, clique na guia Avançado .

Referências

Para obter mais informações sobre opções de linha de comando, clique em Ajuda do Microsoft Access no menu Ajuda , digite as Opções de linha de comando de inicialização no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir o tópico.

Propriedades

ID do artigo: 319253 - Última revisão: quinta-feira, 24 de outubro de 2013 - Revisão: 4.1
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbhowto kbdocerr kbdta kbnofix KB319253 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 319253

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com