XADM: Exchange 2000 Server não pode registrar novas notificações de email do Outlook

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256986Descrição do registro do Microsoft Windows
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Neste artigo

Sintomas

Pode parecer que o Microsoft Outlook não receber novas mensagens de email. No entanto, apenas novas notificações de email não estão sendo recebidas.

Se você clicar em outra pasta e, em seguida, clique em caixa de entrada , novas mensagens são recebidas. Se você aguardar um minuto, novo email é recebido.

Observação : se a nova notificação de email não for registrada, Outlook controla ao servidor a cada minuto para ver se há novos emails.

Causa

As duas causas comuns desse problema são:
  • O servidor não pode registrar as notificações de email novo cliente.
  • O tráfego de UDP não é transferido do servidor para o computador cliente.
Novas notificações de email dependem do UDP (User Datagram Protocol) e um registro válido do servidor.

Resolução

Servidor novo registro de notificação de email

Se o servidor de email não é possível registrar o cliente para novas notificações de email, você pode usar várias ferramentas para resolver o problema.

O programa Regedt32

Você pode usar o programa de Regedt32 para resolver esse problema.

Aviso : se você usar o Editor do Registro incorretamente, poderá causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você pode resolver problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do registro por sua própria conta e risco.

Quando um cliente envia a solicitação para o servidor para registrar para notificações de email novo, o armazenamento de informações usa várias chaves do Registro.

A primeira chave é:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock\Parameters\Transports
O valor na chave transportes é corresponder as chaves de registro de serviços correspondentes.

Por exemplo, se os valores para a chave de transportes são TCPIP, NetBIOS e AppleTalk, as chaves do Registro correspondentes são:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBIOS

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AppleTalk
Se todos os valores na chave do Registro HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock\Parameters\Transports não tiverem chaves serviços correspondentes, a nova notificação de email não irá funcionar.

O programa EnumProt

Para determinar se há problemas no servidor, execute o programa EnumProt. Para executar este utilitário:
  1. Salve o arquivo EnumProt.exe para o servidor do Exchange 2000.
  2. De uma linha de comando, localize a pasta onde você salvou EnumProt.exe.
  3. Digite EnumProt > EnumProt.txt.
  4. Abra o arquivo EnumProt.txt para ver se o teste bem-sucedida.
O exemplo a seguir é um teste bem-sucedido:
Teste de "TCPIP suporte"! AF_INET = família (2)
EnumProtocols() chamada com buffer de 2048 bytes.
Despejando disponível transportes [8]

Protocolo de 1: Família (2) (0 x 6) TCP
Protocolo de 2: Família (2) (0 x 11) UDP/IP
Protocolo de 3: \Device\NetBT_Tcpip_{EBDFB267-726B-44D0-8151-991AADA9CC48 família (17) protocolo (0 x 80000000)}
Protocolo de 4: \Device\NetBT_Tcpip_{EBDFB267-726B-44D0-8151-991AADA9CC48 família (17) protocolo (0 x 80000000)}
Protocolo de 5: \Device\NetBT_Tcpip_{940E55D2-C11F-4FAF-8D9A-DE8420445A8E família (17) protocolo (0xffffffff)}
Protocolo de 6: \Device\NetBT_Tcpip_{940E55D2-C11F-4FAF-8D9A-DE8420445A8E família (17) protocolo (0xffffffff)}
Protocolo de 7: \Device\NetBT_Tcpip_{D8272D57-6520-460F-9F37-984EAE14BBD0 família (17) protocolo (0xfffffffe)}
Protocolo 8: \Device\NetBT_Tcpip_{D8272D57-6520-460F-9F37-984EAE14BBD0 família (17) protocolo (0xfffffffe)}
BEM-SUCEDIDA!
O exemplo a seguir é um teste sem êxito:
Teste de "TCPIP suporte"! AF_INET = família (2)
EnumProtocols() chamada com buffer de 2048 bytes.
Erro retornado! GetLastError() = 0 x 2
FALHA AO! 0 X 80040102 ao retornado

O programa DPMon

Execute o programa DPMon no computador cliente durante o processo de logon do Outlook. A nova notificação de email é representada por:
CNCT::EcOpenSocketAndRegisterForNotifications
Se o servidor não é possível registrar a notificação de email novo, será gerado o seguinte erro:
EC = ecNotSupported-MAPI_E_NO_SUPPORT (0 x 80040102 ao)
Observação : se a nova notificação de email não for registrada, o cliente controla ao servidor a cada minuto para ver se há novos emails.

Tráfego UDP

O Monitor de rede você pode usar o Monitor de rede para determinar se os pacotes UDP são enviados. Para determinar se pacotes UDP são enviados entre o servidor e o cliente, capture o processo de logon do Outlook. Também capture o processo de envio uma nova mensagem para o cliente. Se não pacotes UDP são enviados do servidor, ou UDP está sendo bloqueado ou se o registro não foi bem-sucedido no servidor.

Observação : O cliente liga ao armazenamento de informações (A4F1DB00-CA47-1067-B31F-00DD010662DA). Em seguida, envie um numopc 0 x 4 (ecRRegisterPushNotification) para o servidor. O servidor responde com êxito a este numopc 0 x 4, se o cliente está registrado ou não.

Para obter informações adicionais sobre como usar o Monitor de rede para solucionar problemas de conectividade de cliente, consulte o documento "Tráfego de rede cliente com o Exchange 2000" no site da Microsoft:
http://technet.microsoft.com/en-us/library/cc722850.aspx

Como Contornar

Para contornar esse problema se as chaves do Registro são incompatíveis, modificar manualmente os parâmetros de Winsock. Para fazer isso, você precisará modificar o registro.

Aviso : se você usar o Editor do Registro incorretamente, poderá causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você pode resolver problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do registro por sua própria conta e risco.

Para modificar manualmente os parâmetros do Winsock:
  1. Clique em Iniciar e, em seguida, clique em Executar . Digite RegEdt32 e, em seguida, clique em OK .
  2. Localize a seguinte chave no Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock\Parameters
  3. Clique duas vezes em transportes .
  4. Se um ou mais dos valores não têm uma chave de registro de serviços correspondente (por exemplo, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AppleTalk ), exclua o valor.
  5. Reinicie o servidor
  6. Certifique-se que os clientes recebem novas notificações de email

Observação : Verifique o log de eventos de erro ou mensagens de aviso que podem ser geradas quando você editar manualmente o registro.

Mais Informações

Falha UDP

Os motivos comuns para permitir tráfego UDP são:
  • Um roteador não está permitindo pacotes UDP entre o servidor e o cliente. Você precisa configurar o roteador para permitir pacotes UDP passar do servidor para o cliente. Para fazer isso, consulte documentação do fabricante do roteador.
  • Um firewall está bloqueando as portas UDP do servidor para o cliente. Abra as portas efêmeras (1024 e superiores) para permitir que UDP do servidor o cliente.
  • Clientes VPN Cisco que anteriores à versão 4.0 desativar o registro de WinSock a seguir:
    HKEY_CURRENT-USER\Software\Microsoft\Windows NT\currentVersion\Windows Messaging Subsystem\Profiles\<Microsoft Outlook profile name>\13dbb0c8aa05101a9bb000aa002fc45a
    Há um valor regBinary:
    PR_DISABLE_WINSOCK. "00036618" = hex: 01, 00, 00, 00
Para obter informações adicionais sobre como solucionar problemas de UDP, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
264035XADM: Método de não configurar porta para UDP novo pacotes de notificação de email

Propriedades

ID do artigo: 319572 - Última revisão: quinta-feira, 27 de fevereiro de 2014 - Revisão: 5.7
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange 2000 Server Standard Edition nas seguintes plataformas
    • the operating system: Microsoft Windows 2000
Palavras-chave: 
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