Las aplicaciones MFC pierden objetos GDI en equipos que ejecutan Windows Server 2003 o Windows XP

Seleccione idioma Seleccione idioma
Id. de artículo: 319740 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando ejecuta una aplicación Microsoft Foundation Classes (MFC) en un equipo que ejecuta Microsoft Windows XP con el Service Pack 2 (SP2) instalado, puede ver pérdidas de memoria para los objetos Interfaz de dispositivo gráfico (GDI, Graphics Device Interface) cuando crea y destruye ventanas secundarias. Para ver las pérdidas de memoria, vea los objetos GDI del proceso en el Administrador de tareas.

Este problema también se produce en los equipos que ejecutan Windows Server 2003 cuando se inicia el servicio Temas. De forma predeterminada, el servicio Temas está deshabilitado en Windows Server 2003.

Causa

Este problema se debe a un error en la implementación de la nueva interfaz de temas.

Solución

Información de hotfix

Windows Server 2003

Hay disponible una revisión para la que Microsoft proporciona soporte técnico. Sin embargo, esta revisión sólo se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo en sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, le recomendamos que espere al próximo Service Pack de Windows Server 2003 que contenga esta revisión.

Para resolver este problema, envíe una solicitud a los servicios al cliente en línea de Microsoft con el fin de obtener la revisión. Para enviar una solicitud en línea y obtener la revisión, visite el siguiente sitio web de Microsoft:
http://go.microsoft.com/?linkid=6294451
Nota: si se producen más problemas o si es necesario investigar la causa de los problemas, es posible que tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas y temas de soporte técnico adicionales que no reúnan las condiciones necesarias para esta revisión en cuestión. Para crear una solicitud de servicio independiente, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS

Requisitos previos

No es necesario ningún requisito previo.

Requisitos de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información de reemplazo del hotfix

Este hotfix no reemplaza a ningún otro hotfix.

Información sobre archivos

La versión en inglés de esta revisión tiene los atributos de archivo mostrados en la siguiente tabla (u otros posteriores). Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
Windows Server 2003, versiones basadas en x86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño del archivoFechaHoraPlataforma
Uxtheme.dll6.0.3790.274200.70418-Feb-200505:38x86
Updspapi.dll6.1.22.0371.93616-Feb-200500:18x86

Windows Server 2003, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño del archivoFechaHoraPlataformaTipo de servicio
Uxtheme.dll6.0.3790.274539.64817-Feb-200513:38IA-64RTMQFE
Wuxtheme.dll6.0.3790.274200.70417-Feb-200513:38x86WOW
Updspapi.dll6.1.22.0639.71215-Feb-200508:18IA-64No aplicable

Windows XP

Requisitos previos

Para instalar esta revisión, debe tener instalado Windows XP Service Pack 2 (SP2).

Requisito de reinicio

Una vez aplicada esta revisión, debe reiniciar el equipo.

Información de reemplazo de la revisión

Esta revisión no sustituye a ninguna otra publicada previamente.

Información sobre los archivos

La versión en inglés de esta revisión tiene los atributos de archivo mostrados en la siguiente tabla (u otros posteriores). Las fechas y las horas de estos archivos se muestran según el Horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño del archivoFechaHoraPlataforma
Uxtheme.dll6.0.2900.2523218.62423-Sep-200417:16x86
Updspapi.dll6.1.22.4371.93625-Feb-200503:53x86
El siguiente archivo se puede descargar desde el Centro de descarga de Microsoft:

Contraer esta imagenAmpliar esta imagen
Descarga
Descargar ahora el paquete de la Actualización de Windows XP (KB319740).
Fecha de publicación: 21 de marzo de 2006

Para obtener más información acerca de cómo descargar los archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
119591 Cómo obtener Archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft exploró este archivo en busca de virus con el software de detección de virus más reciente disponible en la fecha de publicación. Asimismo, el archivo se almacenó en servidores seguros que ayudan a impedir la realización de cambios no autorizados.

Solución

Si esta pérdida de GDI está degradando mucho el rendimiento, puede desactivar la nueva interfaz de usuario de temas en Windows XP. Para ello, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, haga clic en Panel de control.
  2. Haga clic en Apariencia y temas y, después, haga clic en Pantalla.
  3. En la ficha Temas del cuadro de diálogo Propiedades de Pantalla, haga clic en Clásico de Windows en la lista Tema.
  4. Haga clic en Aplicar y, después, haga clic en Aceptar.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Propiedades

Id. de artículo: 319740 - Última revisión: miércoles, 14 de noviembre de 2007 - Versión: 7.4
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
Palabras clave: 
kbbug kbfix kbshell kbqfe kbwinxp64bit2003sp1fix atdownload kbwinxppresp3fix kbwinxpsp3fix kbhotfixserver KB319740

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com