Help and Support

Id. de artículo: 319829 - Última revisión: lunes, 25 de septiembre de 2006 - Versión: 3.3

No se puede abrir un archivo Tagged Information File Format (TIFF) en Internet Explorer

Este artículo se publicó anteriormente con el número E319829
Importante
Este artículo contiene información sobre cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

Síntomas

Al hacer clic en un vínculo para descargar una imagen Tagged Information File Format (TIFF) de un sitio Web, puede que el botón Abrir del cuadro de diálogo Descarga de archivos no esté disponible (aparece atenuado).

Aunque puede descargar el archivo TIFF, quizás no pueda abrirlo en Internet Explorer.

Causa

El problema se produce si tiene instalada la versión 6.0.2713.1500 (o posterior) del archivo Shdocvw.dll. La versión 6.0.2713.1500 de Shdocvw.dll se incluía en la Revisión acumulativa de Internet Explorer del boletín de seguridad de Microsoft MS02-005.

Cuando examina un archivo, Internet Explorer utiliza la extensión del nombre de archivo para recuperar la siguiente información acerca del mismo:
  1. El valor predeterminado de la clave HKEY_CLASSES_ROOT\.extensión del Registro, que contiene el Id. de programación del servidor asociado al tipo de archivo.
  2. La clave HKEY_CLASSES_ROOT\ProgID del Registro, que contiene una subclave para el CLSID.
  3. La clave HKEY_CLASSES_ROOT\CLSID\CLSID del Registro, que contiene una subclave para el Id. de programación. Si los Id. de programación de los elementos 1 y 3 no son iguales, Internet Explorer deshabilita la opción para abrir el archivo si tiene instalada la versión 6.0.2713.1500 (o posterior) del archivo Shdocvw.dll.

Solución

Para resolver este problema, obtenga el Service Pack más reciente para Internet Explorer 6. Para obtener más información al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
328548  (http://support.microsoft.com/kb/328548/ ) Cómo obtener el Service Pack más reciente para Internet Explorer 6

Solución

Advertencia
Pueden producirse graves problemas si modifica incorrectamente el Registro mediante el Editor del Registro o con cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Para evitar este problema, siga estos pasos.
  1. Haga clic en Inicio y en Ejecutar, escriba regedit en el cuadro Abrir y haga clic en Aceptar.
  2. Desplácese hasta la siguiente subclave del Registro:
    HKEY_CLASSES_ROOT\.tif
  3. En el panel derecho del Editor del Registro, haga clic con el botón secundario del mouse en (Default) y, a continuación, haga clic en Modificar en el menú contextual que aparecerá.
  4. En el cuadro Información del valor, escriba uno de los valores siguientes, según corresponda a su sistema operativo.
    • Microsoft Windows 2000 y Microsoft Windows 98:
      Imaging.Document
    • Microsoft Windows NT 4.0 y Microsoft Windows 95:
      WangImage.Document
  5. Haga clic en Aceptar.
  6. Desplácese hasta la siguiente subclave del Registro:
    HKEY_CLASSES_ROOT\.tiff
  7. En el panel derecho del Editor del Registro, haga clic con el botón secundario del mouse en (Default) y, a continuación, haga clic en Modificar en el menú contextual que aparecerá.
  8. En el cuadro Información del valor, escriba uno de los valores siguientes, según corresponda a su sistema operativo.
    • Windows 2000 y Windows 98:
      Imaging.Document
    • Windows NT 4.0 y Windows 95:
      WangImage.Document
  9. Haga clic en Aceptar.
  10. Salga del Editor del Registro.
Nota
Si utiliza un visor de gráficos compatible con archivos TIFF (por ejemplo, Microsoft Imaging en Windows 2000), se puede cambiar cualquiera de los valores del Registro enumerados en la sección "Causa". Por tanto, puede volver a producirse este problema.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a". Este problema se corrigió por primera vez en el Service Pack 1 de Internet Explorer 6.

Más información

Para obtener más información al respecto, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
316059  (http://support.microsoft.com/kb/316059/ ) MS02-005: 11 de febrero de 2002, Revisión acumulativa para Internet Explorer
313675  (http://support.microsoft.com/kb/313675/ ) MS01-058: Revisión de vulnerabilidad de archivos para Internet Explorer 5.5 e Internet Explorer 6
320289  (http://support.microsoft.com/kb/320289/ ) La casilla de verificación "Preguntar siempre antes de abrir este tipo de archivos" no está disponible para los archivos .tif

La información de este artículo se refiere a:
  • Service Pack 1 de Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0
Palabras clave: 
kbprb KB319829

Seleccione idioma

 

Related Support Centers