Article ID: 319844 - View products that this article applies to.
This article was previously published under Q319844
For a Microsoft Access 2000 version of this article, see 319841.

Novice: Requires knowledge of the user interface on single-user computers.

For a Microsoft Access 97 version of this article, see 296205.
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Symptoms

When you use Microsoft Access, you receive the following error message:
ActiveX component can't create object
This article describes some common causes for this error message and offers methods that you can use to resolve the issue.

Cause

This behavior can occur if any of the following conditions are true:
  • Data Access Objects (DAO) is not properly registered.

    -or-
  • One or more references are missing.

    -or-
  • There is a utility database reference that is not valid.

    -or-
  • You do not have the required permissions for required libraries.

    -or-
  • There is a damaged wizard file.

Resolution

Cause 1: DAO is not properly registered

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Resolution

Reregister the DAO 3.6 library. To do this, follow these steps:
  1. On the computer on which Microsoft Access is installed or on the computer that hosts Microsoft Windows Terminal Server, click Start, and then click Run. (If you don't see Run, you can add it to your Start menu options by customizing the Windows Start menu).
    How to customize the Start menu in Windows 7
    How to customize the Start menu in Window XP
  2. In the Run text box, type regsvr32 followed by the path to your DAO file. Enclose this path in quotation marks. For example, to register the DAO 3.6 library, use the following command, which includes the default path to the DAO library file:
    regsvr32 "C:\Program Files\Common Files\Microsoft Shared\DAO\DAO360.DLL"
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Cause 2: One or more references are missing

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Resolution

Check for missing references. To this, follow these steps:
  1. Open the database for which you receive the error message.
  2. Press ALT+F11 to open the Microsoft Visual Basic Editor.
  3. In the Visual Basic Editor, click References on the Tools menu.
  4. Review the list of available references that are checked. If any of the checked items display the word "Missing," uncheck the reference.

    Alternatively, you can click the Browse button in the References dialog box to browse to the location of the library file associated with the missing reference.
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Cause 3: There is a utility database reference that is not valid

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Resolution

As of the release of Microsoft Access 2000, a reference to Utility is not required. If you converted a database from a previous version, you may still see a reference to Utility in your list of references. Uncheck any references to Utility or Utility.mda. To do this, follow these steps:
  1. Open the database for which you receive the error message.
  2. Press ALT+F11 to open the Visual Basic Editor.
  3. In the Visual Basic Editor, click References on the Tools menu.
  4. Click to clear the check box next to any reference to Utility Database or Utility.mda.
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Cause 4: You do not have the required permissions for required libraries

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Resolution

All Microsoft Access users must have permissions to Windows System folders.
  • Make sure that users have "read" permissions for all files in the following folders.

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    Operating SystemLocation
    Windows XP, Windows Vista, Windows 7, Windows 8, Windows 2003, Windows 2008, and Windows 2012 (x86)\Windows\System32
    Windows XP, Windows Vista, Windows 7, Windows 8, Windows 2003, Windows 2008, and Windows 2012 (x64)\Windows\SysWOW64
  • If you cannot grant read permissions, you can use a utility such as Process Monitor to determine which file or files the users do not have the required permissions to use. To obtain Process Monitor, visit the following Sysinternals Web site:
    Sysinternals
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Cause 5: There is a damaged wizard file

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Resolution

To repair damaged wizard files, follow these steps:  
  1. Use Windows Explorer to locate the following wizard files: Acwzmain.mde, Acwztool.mde and Acwzlib.mde.
  2. Change the file name extension of each file to "old." For example, change Acwzmain.mde to Acwzmain.old.
  3. Repair Microsoft Access or Microsoft Office Professional to reinstall the Wizard files.
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More information

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 319844 - Last Review: August 7, 2013 - Revision: 11.0
Applies to
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
Keywords: 
kbPubTypeKC kberrmsg kbprb KB319844

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