ID Artikel: 319844 - Kajian Terakhir: 24 September 2011 - Revisi: 2.0

Anda menerima pesan galat "komponen ActiveX tidak dapat membuat objek" ketika menggunakan akses

Tips SistemThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Untuk versi Microsoft Access 2000 artikel ini, lihat 319841  (http://support.microsoft.com/kb/319841/ ) .

Pemula: Memerlukan pengetahuan antarmuka pengguna pada komputer pengguna tunggal.

Untuk Microsoft Access Versi 97 artikel ini, lihat 296205  (http://support.microsoft.com/kb/296205/ ) .

Pada Halaman ini

Perbesar semua | Perkecil semua

GEJALA

Ketika Anda menggunakan Microsoft Access, Anda menerima berikut pesan galat:
Komponen ActiveX tidak dapat membuat objek
Artikel ini menjelaskan beberapa penyebab umum untuk pesan galat ini dan menawarkan metode yang dapat Anda gunakan untuk menyelesaikan masalah.

PENYEBAB

Perilaku ini dapat terjadi jika salah satu kondisi berikut ini benar:
  • Data Access objek (DAO) adalah tidak benar terdaftar.

    -atau-
  • Satu atau lebih referensi hilang.

    -atau-
  • Ada referensi database utilitas yang tidak berlaku.

    -atau-
  • Anda tidak memiliki izin yang diperlukan diperlukan perpustakaan.

    -atau-
  • Ada file rusak wizard.

PEMECAHAN MASALAH

Penyebab 1: DAO tidak benar terdaftar

Penyelesaian

  1. Pada komputer yang memiliki Microsoft Windows Terminal Server atau komputer di mana Microsoft Access diinstal, klik Mulai, lalu klik Menjalankan.
  2. Jenis regsvr32 diikuti oleh path untuk DAO file. Sertakan jalan ini dalam tanda kutip. Misalnya, untuk daftar perpustakaan DAO 3,6, gunakan perintah berikut:
    regsvr32 "c: program files Microsoft Shared\DAO\DAO360.DLL"

Penyebab 2: Satu atau lebih referensi hilang

Penyelesaian

  1. Membuka database yang Anda menerima galat kepada kami.
  2. Tekan ALT + F11 untuk membuka Microsoft Visual Basic Editor.
  3. Di Editor Visual Basic, klik Referensi pada Alat menu.
  4. Memeriksa daftar perpustakaan. Jika item yang ditandai sebagai "hilang," Cari berkas perpustakaan dan kembali peranti referensi. Atau, klik untuk mengosongkan kotak centang di sebelah nama perpustakaan.

Penyebab 3: Ada referensi database utilitas yang tidak sah

Penyelesaian

  1. Membuka database yang Anda menerima galat kepada kami.
  2. Tekan ALT + F11 untuk membuka Editor Visual Basic.
  3. Di Editor Visual Basic, klik Referensi pada Alat menu.
  4. Klik untuk mengosongkan kotak centang di sebelah setiap referensi untuk Utility Database atau Utility.mda.

Penyebab 4: Anda tidak memiliki izin yang diperlukan untuk perpustakaan yang diperlukan

Penyelesaian

  • Pastikan bahwa pengguna telah "membaca" izin untuk semua file dalam folder berikut.
    Perkecil tabel iniPerbesar tabel ini
    Sistem operasiLokasi
    Windows XP\Windows\System32
    Windows NT dan Windows 2000\Winnt\System32
    Windows 95, Windows 98, dan Windows Millennium Edition\Windows\System
  • Jika Anda tidak dapat memberikan hak akses baca, Anda dapat menggunakan sebuah utilitas seperti FileMon untuk menentukan file atau file yang pengguna tidak memiliki diperlukan izin untuk menggunakan. Untuk mendapatkan FileMon, kunjungi berikut Situs SysInternals Web:
    SysInternals (http://technet.microsoft.com/en-us/sysinternals/default.aspx)

Penyebab 5: Ada file rusak wizard

Penyelesaian

  1. Menggunakan Windows Explorer untuk menemukan file-file wizard yang berikut: Acwzmain.MDE, Acwztool.mde dan Acwzlib.mde.
  2. Mengubah ekstensi nama berkas dari setiap file untuk "lama." Untuk contoh, mengubah Acwzmain.mde untuk Acwzmain.old.
  3. Instal ulang akses untuk memulihkan berkas.

INFORMASI LEBIH LANJUT

Produk pihak ketiga yang dibahas di artikel ini dibuat oleh perusahaan yang independen terhadap Microsoft. Microsoft tidak memberikan garansi, secara tersirat maupun apa pun, berkenaan dengan kinerja atau keandalan produk.

Berlaku bagi:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
Kata kunci: 
kbpubtypekc kberrmsg kbprb kbmt KB319844 KbMtid
Penerjemahan MesinPenerjemahan Mesin
PENTING: Artikel ini diterjemahkan menggunakan perangkat lunak mesin penerjemah Microsoft dan bukan oleh seorang penerjemah. Microsoft menawarkan artikel yang diterjemahkan oleh seorang penerjemah maupun artikel yang diterjemahkan menggunakan mesin sehingga Anda akan memiliki akses ke seluruh artikel baru yang diterbitkan di Pangkalan Pengetahuan (Knowledge Base) dalam bahasa yang Anda gunakan. Namun, artikel yang diterjemahkan menggunakan mesin tidak selalu sempurna. Artikel tersebut mungkin memiliki kesalahan kosa kata, sintaksis, atau tata bahasa, hampir sama seperti orang asing yang berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab terhadap akurasi, kesalahan atau kerusakan yang disebabkan karena kesalahan penerjemahan konten atau penggunaannya oleh para pelanggan. Microsoft juga sering memperbarui perangkat lunak mesin penerjemah.
Klik disini untuk melihat versi Inggris dari artikel ini:319844  (http://support.microsoft.com/kb/319844/en-us/ )