Help and Support

Identificativo articolo: 319844 - Ultima modifica: mercoledì 21 marzo 2007 - Revisione: 8.3

Messaggio di errore "Il componente ActiveX non può creare l'oggetto" quando si utilizza Access

Per la versione di questo articolo relativa a Microsoft Access 2000, vedere 319841  (http://support.microsoft.com/kb/319841/ ) .

Utenti inesperti: è richiesta la conoscenza dell'interfaccia utente dei computer a utente singolo.

Per la versione di questo articolo relativa a Microsoft Access 97, vedere 296205  (http://support.microsoft.com/kb/296205/ ) .

In questa pagina

Espandi tutto | Chiudi tutto

Sintomi

Quando si utilizza Microsoft Access, è possibile che venga visualizzato un messaggio di errore analogo al seguente:
Il componente ActiveX non può creare l'oggetto
In questo articolo vengono descritte alcune cause comuni per questo messaggio di errore e vengono forniti i metodi da utilizzare per risolvere il problema.

Cause

Questo comportamento può verificarsi in presenza di una qualsiasi delle seguenti condizioni:
  • Un file DAO (Data Access Objects) non è registrato correttamente.

    Oppure
  • Uno o più riferimenti sono mancanti.

    Oppure
  • Un riferimento a un database di utilità non è valido.

    Oppure
  • Non si dispone delle autorizzazioni necessarie per le librerie richieste.

    Oppure
  • Un file di procedura guidata è danneggiato.

Risoluzione

Causa 1: un file DAO non è registrato correttamente

Risoluzione

  1. Nel computer che ospita Microsoft Windows Terminal Server o in quello in cui è installato Microsoft Access fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Digitare regsvr32 seguito dal percorso del file DAO. Racchiudere questo percorso tra virgolette. Per registrare la libreria DAO 3.6, ad esempio, utilizzare il comando seguente:
    regsvr32 "C:\Programmi\File comuni\Microsoft Shared\DAO\DAO360.DLL"

Causa 2: uno o più riferimenti sono mancanti

Risoluzione

  1. Aprire il database per cui si riceve il messaggio di errore.
  2. Premere ALT+F11 per aprire Microsoft Visual Basic Editor.
  3. In Visual Basic Editor scegliere Riferimenti dal menu Strumenti.
  4. Esaminare l'elenco di librerie. Se alcune voci sono contrassegnate come mancanti, individuare il file della libreria e riassociare il riferimento In alternativa, deselezionare la casella di controllo accanto al nome della libreria.

Causa 3: è presente un riferimento non valido a un database di utilità

Risoluzione

  1. Aprire il database per cui si riceve il messaggio di errore.
  2. Premere ALT+F11 per aprire Visual Basic Editor.
  3. In Visual Basic Editor scegliere Riferimenti dal menu Strumenti.
  4. Deselezionare la casella di controllo accanto a qualsiasi riferimento al database di utilità o Utility.mda.

Causa 4: non si dispone delle autorizzazioni necessarie per le librerie richieste

Risoluzione

  • Assicurarsi che gli utenti dispongano delle autorizzazioni di lettura per tutti i file delle seguenti cartelle:
    Riduci questa tabellaEspandi questa tabella
    Sistema operativoPercorso
    Windows XP\Windows\System32
    Windows NT e Windows 2000\Winnt\System32
    Windows 95, Windows 98 e Windows Millennium Edition\Windows\System
  • Se non è possibile concedere le autorizzazioni di lettura, utilizzare un'utilità come FileMon per determinare il file o i file per cui l'utente non dispone delle autorizzazioni richieste. Per ottenere FileMon, visitare il seguente sito Web Sysinternals (informazioni in lingua inglese):
    Sysinternals (http://www.microsoft.com/technet/sysinternals/default.mspx)

Causa 5: un file di procedura guidata è danneggiato

Risoluzione

  1. Utilizzare Esplora risorse per individuare i seguenti file di procedura guidata: Acwzmain.mde, Acwztool.mde e Acwzlib.mde.
  2. Cambiare l'estensione di ciascun file in "old". Modificare, ad esempio, Acwzmain.mde in Acwzmain.old.
  3. Reinstallare Access per ripristinare i file.

Informazioni

I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilita? di tali prodotti.

Le informazioni in questo articolo si applicano a:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
Chiavi: 
kbmsccsearch kbpubtypekc kberrmsg kbprb KB319844
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Traduzione articoli

 

Related Support Centers